Patchwork mtd: cfi_cmdset_0002: consider version 1.4 as a valid primary extension version

login
register
mail settings
Submitter Guillaume LECERF
Date Aug. 4, 2010, 8:50 p.m.
Message ID <20100804204916.27906.74766.stgit@dev.siriade.com>
Download mbox | patch
Permalink /patch/60894/
State New
Headers show

Comments

Guillaume LECERF - Aug. 4, 2010, 8:50 p.m.
As my first patch has been pushed, here is the change requested by Gernot Hoyler.

---
The Spansion S29WS-P device family uses CFI version 1.4 [1].
Consider it as a valide version.

[1] http://www.spansion.com/Support/Datasheets/s29ws-p_00_a12_e.pdf

Signed-off-by: Guillaume LECERF <glecerf@gmail.com>
---
 drivers/mtd/chips/cfi_cmdset_0002.c |    7 ++++---
 1 files changed, 4 insertions(+), 3 deletions(-)
Artem Bityutskiy - Aug. 5, 2010, 6:08 a.m.
On Wed, 2010-08-04 at 22:50 +0200, Guillaume LECERF wrote:
> As my first patch has been pushed, here is the change requested by Gernot Hoyler.
> 
> ---

Because of this my git-am removes the below comment part... and your
signed-off-by.

> The Spansion S29WS-P device family uses CFI version 1.4 [1].
> Consider it as a valide version.
> 
> [1] http://www.spansion.com/Support/Datasheets/s29ws-p_00_a12_e.pdf
> 
> Signed-off-by: Guillaume LECERF <glecerf@gmail.com>
> ---
>  drivers/mtd/chips/cfi_cmdset_0002.c |    7 ++++---
>  1 files changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/mtd/chips/cfi_cmdset_0002.c b/drivers/mtd/chips/cfi_cmdset_0002.c
> index 749203f..16c4eee 100644
> --- a/drivers/mtd/chips/cfi_cmdset_0002.c
> +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
> @@ -418,12 +418,13 @@ struct mtd_info *cfi_cmdset_0002(struct map_info *map, int primary)
>  			cfi_fixup_major_minor(cfi, extp);
>  
>  			/*
> -			 * Valid primary extension versions are: 1.0, 1.1, 1.2, 1.3
> -			 * see: http://www.amd.com/us-en/assets/content_type/DownloadableAssets/cfi_r20.pdf, page 19 and on
> +			 * Valid primary extension versions are: 1.0, 1.1, 1.2, 1.3, 1.4
> +			 * see: http://www.amd.com/us-en/assets/content_type/DownloadableAssets/cfi_r20.pdf, page 19
>  			 *      http://www.amd.com/us-en/assets/content_type/DownloadableAssets/cfi_100_20011201.pdf
> +			 *      http://www.spansion.com/Support/Datasheets/s29ws-p_00_a12_e.pdf
>  			 */
>  			if (extp->MajorVersion != '1' ||
> -			    (extp->MajorVersion == '1' && ( extp->MinorVersion < '0' || extp->MinorVersion > '3'))) {
> +			    (extp->MajorVersion == '1' && ( extp->MinorVersion < '0' || extp->MinorVersion > '4'))) {
>  				printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
>  				       "version %c.%c (%#02x/%#02x).\n",
>  				       extp->MajorVersion, extp->MinorVersion,
> 
> 
> ______________________________________________________
> Linux MTD discussion mailing list
> http://lists.infradead.org/mailman/listinfo/linux-mtd/

Patch

diff --git a/drivers/mtd/chips/cfi_cmdset_0002.c b/drivers/mtd/chips/cfi_cmdset_0002.c
index 749203f..16c4eee 100644
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
@@ -418,12 +418,13 @@  struct mtd_info *cfi_cmdset_0002(struct map_info *map, int primary)
 			cfi_fixup_major_minor(cfi, extp);
 
 			/*
-			 * Valid primary extension versions are: 1.0, 1.1, 1.2, 1.3
-			 * see: http://www.amd.com/us-en/assets/content_type/DownloadableAssets/cfi_r20.pdf, page 19 and on
+			 * Valid primary extension versions are: 1.0, 1.1, 1.2, 1.3, 1.4
+			 * see: http://www.amd.com/us-en/assets/content_type/DownloadableAssets/cfi_r20.pdf, page 19
 			 *      http://www.amd.com/us-en/assets/content_type/DownloadableAssets/cfi_100_20011201.pdf
+			 *      http://www.spansion.com/Support/Datasheets/s29ws-p_00_a12_e.pdf
 			 */
 			if (extp->MajorVersion != '1' ||
-			    (extp->MajorVersion == '1' && ( extp->MinorVersion < '0' || extp->MinorVersion > '3'))) {
+			    (extp->MajorVersion == '1' && ( extp->MinorVersion < '0' || extp->MinorVersion > '4'))) {
 				printk(KERN_ERR "  Unknown Amd/Fujitsu Extended Query "
 				       "version %c.%c (%#02x/%#02x).\n",
 				       extp->MajorVersion, extp->MinorVersion,