diff mbox

[RFC,4/8] exec: introduce address_space_get_iotlb_entry()

Message ID 1458872009-13342-5-git-send-email-jasowang@redhat.com
State New
Headers show

Commit Message

Jason Wang March 25, 2016, 2:13 a.m. UTC
This patch introduces a helper to query the iotlb entry for a
possible iova. This will be used by later device IOTLB API to enable
the capability for a dataplane (e.g vhost) to query the IOTLB.

Cc: Paolo Bonzini <pbonzini@redhat.com>
Cc: Peter Crosthwaite <crosthwaite.peter@gmail.com>
Cc: Richard Henderson <rth@twiddle.net>
Signed-off-by: Jason Wang <jasowang@redhat.com>
---
 exec.c                | 30 ++++++++++++++++++++++++++++++
 include/exec/memory.h |  7 +++++++
 2 files changed, 37 insertions(+)

Comments

Peter Xu March 28, 2016, 2:18 a.m. UTC | #1
On Fri, Mar 25, 2016 at 10:13:25AM +0800, Jason Wang wrote:
> This patch introduces a helper to query the iotlb entry for a
> possible iova. This will be used by later device IOTLB API to enable
> the capability for a dataplane (e.g vhost) to query the IOTLB.
> 
> Cc: Paolo Bonzini <pbonzini@redhat.com>
> Cc: Peter Crosthwaite <crosthwaite.peter@gmail.com>
> Cc: Richard Henderson <rth@twiddle.net>
> Signed-off-by: Jason Wang <jasowang@redhat.com>
> ---
>  exec.c                | 30 ++++++++++++++++++++++++++++++
>  include/exec/memory.h |  7 +++++++
>  2 files changed, 37 insertions(+)
> 
> diff --git a/exec.c b/exec.c
> index f398d21..31fac9f 100644
> --- a/exec.c
> +++ b/exec.c
> @@ -411,6 +411,36 @@ address_space_translate_internal(AddressSpaceDispatch *d, hwaddr addr, hwaddr *x
>  }
>  
>  /* Called from RCU critical section */
> +IOMMUTLBEntry address_space_get_iotlb_entry(AddressSpace *as, hwaddr addr,
> +                                            bool is_write)
> +{
> +    IOMMUTLBEntry iotlb = {0};
> +    MemoryRegionSection *section;
> +    MemoryRegion *mr;
> +    hwaddr plen;
> +
> +    for (;;) {
> +        AddressSpaceDispatch *d = atomic_rcu_read(&as->dispatch);
> +        section = address_space_translate_internal(d, addr, &addr, &plen, true);
> +        mr = section->mr;
> +
> +        if (!mr->iommu_ops) {
> +            break;
> +        }
> +
> +        iotlb = mr->iommu_ops->translate(mr, addr, is_write);
> +        if (!(iotlb.perm & (1 << is_write))) {
> +            iotlb.target_as = NULL;
> +            break;
> +        }

Here, do we still need something like:

        addr = ((iotlb.translated_addr & ~iotlb.addr_mask)
                | (addr & iotlb.addr_mask));

Just as address_space_translate() does? Now "addr" should be the
offset in memory region "mr", while we need it to be the offset in
address space if there are more loops, right?

Also, not sure whether we can abstract a shared function out of this
function and address_space_translate().

Thanks.

-- peterx
Jason Wang March 30, 2016, 1:13 a.m. UTC | #2
On 03/28/2016 10:18 AM, Peter Xu wrote:
> On Fri, Mar 25, 2016 at 10:13:25AM +0800, Jason Wang wrote:
>> This patch introduces a helper to query the iotlb entry for a
>> possible iova. This will be used by later device IOTLB API to enable
>> the capability for a dataplane (e.g vhost) to query the IOTLB.
>>
>> Cc: Paolo Bonzini <pbonzini@redhat.com>
>> Cc: Peter Crosthwaite <crosthwaite.peter@gmail.com>
>> Cc: Richard Henderson <rth@twiddle.net>
>> Signed-off-by: Jason Wang <jasowang@redhat.com>
>> ---
>>  exec.c                | 30 ++++++++++++++++++++++++++++++
>>  include/exec/memory.h |  7 +++++++
>>  2 files changed, 37 insertions(+)
>>
>> diff --git a/exec.c b/exec.c
>> index f398d21..31fac9f 100644
>> --- a/exec.c
>> +++ b/exec.c
>> @@ -411,6 +411,36 @@ address_space_translate_internal(AddressSpaceDispatch *d, hwaddr addr, hwaddr *x
>>  }
>>  
>>  /* Called from RCU critical section */
>> +IOMMUTLBEntry address_space_get_iotlb_entry(AddressSpace *as, hwaddr addr,
>> +                                            bool is_write)
>> +{
>> +    IOMMUTLBEntry iotlb = {0};
>> +    MemoryRegionSection *section;
>> +    MemoryRegion *mr;
>> +    hwaddr plen;
>> +
>> +    for (;;) {
>> +        AddressSpaceDispatch *d = atomic_rcu_read(&as->dispatch);
>> +        section = address_space_translate_internal(d, addr, &addr, &plen, true);
>> +        mr = section->mr;
>> +
>> +        if (!mr->iommu_ops) {
>> +            break;
>> +        }
>> +
>> +        iotlb = mr->iommu_ops->translate(mr, addr, is_write);
>> +        if (!(iotlb.perm & (1 << is_write))) {
>> +            iotlb.target_as = NULL;
>> +            break;
>> +        }
> Here, do we still need something like:
>
>         addr = ((iotlb.translated_addr & ~iotlb.addr_mask)
>                 | (addr & iotlb.addr_mask));
>
> Just as address_space_translate() does? Now "addr" should be the
> offset in memory region "mr", while we need it to be the offset in
> address space if there are more loops, right?

Right, will address this in next version.

>
> Also, not sure whether we can abstract a shared function out of this
> function and address_space_translate().

Looks possible.

Thanks

>
> Thanks.
>
> -- peterx
>
diff mbox

Patch

diff --git a/exec.c b/exec.c
index f398d21..31fac9f 100644
--- a/exec.c
+++ b/exec.c
@@ -411,6 +411,36 @@  address_space_translate_internal(AddressSpaceDispatch *d, hwaddr addr, hwaddr *x
 }
 
 /* Called from RCU critical section */
+IOMMUTLBEntry address_space_get_iotlb_entry(AddressSpace *as, hwaddr addr,
+                                            bool is_write)
+{
+    IOMMUTLBEntry iotlb = {0};
+    MemoryRegionSection *section;
+    MemoryRegion *mr;
+    hwaddr plen;
+
+    for (;;) {
+        AddressSpaceDispatch *d = atomic_rcu_read(&as->dispatch);
+        section = address_space_translate_internal(d, addr, &addr, &plen, true);
+        mr = section->mr;
+
+        if (!mr->iommu_ops) {
+            break;
+        }
+
+        iotlb = mr->iommu_ops->translate(mr, addr, is_write);
+        if (!(iotlb.perm & (1 << is_write))) {
+            iotlb.target_as = NULL;
+            break;
+        }
+
+        as = iotlb.target_as;
+    }
+
+    return iotlb;
+}
+
+/* Called from RCU critical section */
 MemoryRegion *address_space_translate(AddressSpace *as, hwaddr addr,
                                       hwaddr *xlat, hwaddr *plen,
                                       bool is_write)
diff --git a/include/exec/memory.h b/include/exec/memory.h
index 2de7898..0411a59 100644
--- a/include/exec/memory.h
+++ b/include/exec/memory.h
@@ -1310,6 +1310,13 @@  void address_space_stq(AddressSpace *as, hwaddr addr, uint64_t val,
                             MemTxAttrs attrs, MemTxResult *result);
 #endif
 
+
+/* address_space_get_iotlb_entry: translate an address into an IOTLB
+ * entry. Should be called from an RCU critical section.
+ */
+IOMMUTLBEntry address_space_get_iotlb_entry(AddressSpace *as, hwaddr addr,
+                                            bool is_write);
+
 /* address_space_translate: translate an address range into an address space
  * into a MemoryRegion and an address range into that section.  Should be
  * called from an RCU critical section, to avoid that the last reference