diff mbox

PCI: rcar, rcar-gen2: Use ARCH_RENESAS

Message ID 1456361156-16798-1-git-send-email-horms+renesas@verge.net.au
State Accepted
Headers show

Commit Message

Simon Horman Feb. 25, 2016, 12:45 a.m. UTC
Make use of ARCH_RENESAS in place of ARCH_SHMOBILE.

This is part of an ongoing process to migrate from ARCH_SHMOBILE to
ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.

Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
---
 drivers/pci/host/Kconfig | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

 Based on the next branch of the pci tree

Comments

Geert Uytterhoeven Feb. 25, 2016, 8:04 a.m. UTC | #1
On Thu, Feb 25, 2016 at 1:45 AM, Simon Horman
<horms+renesas@verge.net.au> wrote:
> Make use of ARCH_RENESAS in place of ARCH_SHMOBILE.
>
> This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
>
> Signed-off-by: Simon Horman <horms+renesas@verge.net.au>

Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>

> --- a/drivers/pci/host/Kconfig
> +++ b/drivers/pci/host/Kconfig

> @@ -49,7 +49,7 @@ config PCI_RCAR_GEN2
>
>  config PCI_RCAR_GEN2_PCIE
>         bool "Renesas R-Car PCIe controller"
> -       depends on ARCH_SHMOBILE || (ARM && COMPILE_TEST)
> +       depends on ARCH_RENESAS || (ARM && COMPILE_TEST)
>         help
>           Say Y here if you want PCIe controller support on R-Car Gen2 SoCs.

BTW, this looks like a misnomer: the driver supports a compatible value for
R-Car H1, too ("renesas,pcie-r8a7779"), but it's not used in r8a7779.dtsi.

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Phil Edworthy Feb. 26, 2016, 9:22 a.m. UTC | #2
Hi Geert,

On 25 February 2016 08:05, Geert Uytterhoeven wrote:
> On Thu, Feb 25, 2016 at 1:45 AM, Simon Horman

> <horms+renesas@verge.net.au> wrote:

> > Make use of ARCH_RENESAS in place of ARCH_SHMOBILE.

> >

> > This is part of an ongoing process to migrate from ARCH_SHMOBILE to

> > ARCH_RENESAS the motivation for which being that RENESAS seems to be a

> more

> > appropriate name than SHMOBILE for the majority of Renesas ARM based

> SoCs.

> >

> > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>

> 

> Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>

> 

> > --- a/drivers/pci/host/Kconfig

> > +++ b/drivers/pci/host/Kconfig

> 

> > @@ -49,7 +49,7 @@ config PCI_RCAR_GEN2

> >

> >  config PCI_RCAR_GEN2_PCIE

> >         bool "Renesas R-Car PCIe controller"

> > -       depends on ARCH_SHMOBILE || (ARM && COMPILE_TEST)

> > +       depends on ARCH_RENESAS || (ARM && COMPILE_TEST)

> >         help

> >           Say Y here if you want PCIe controller support on R-Car Gen2 SoCs.

> 

> BTW, this looks like a misnomer: the driver supports a compatible value for

> R-Car H1, too ("renesas,pcie-r8a7779"), but it's not used in r8a7779.dtsi.

IIRC, H1 PCIe support was nobbled in some way that meant you could not
use it with any normal PCIe card. You could connect to another R-Car that
was acting as an endpoint though.

Phil
Simon Horman Feb. 29, 2016, 12:36 a.m. UTC | #3
On Fri, Feb 26, 2016 at 09:22:04AM +0000, Phil Edworthy wrote:
> Hi Geert,
> 
> On 25 February 2016 08:05, Geert Uytterhoeven wrote:
> > On Thu, Feb 25, 2016 at 1:45 AM, Simon Horman
> > <horms+renesas@verge.net.au> wrote:
> > > Make use of ARCH_RENESAS in place of ARCH_SHMOBILE.
> > >
> > > This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> > > ARCH_RENESAS the motivation for which being that RENESAS seems to be a
> > more
> > > appropriate name than SHMOBILE for the majority of Renesas ARM based
> > SoCs.
> > >
> > > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> > 
> > Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>
> > 
> > > --- a/drivers/pci/host/Kconfig
> > > +++ b/drivers/pci/host/Kconfig
> > 
> > > @@ -49,7 +49,7 @@ config PCI_RCAR_GEN2
> > >
> > >  config PCI_RCAR_GEN2_PCIE
> > >         bool "Renesas R-Car PCIe controller"
> > > -       depends on ARCH_SHMOBILE || (ARM && COMPILE_TEST)
> > > +       depends on ARCH_RENESAS || (ARM && COMPILE_TEST)
> > >         help
> > >           Say Y here if you want PCIe controller support on R-Car Gen2 SoCs.
> > 
> > BTW, this looks like a misnomer: the driver supports a compatible value for
> > R-Car H1, too ("renesas,pcie-r8a7779"), but it's not used in r8a7779.dtsi.
> IIRC, H1 PCIe support was nobbled in some way that meant you could not
> use it with any normal PCIe card. You could connect to another R-Car that
> was acting as an endpoint though.

It sounds like that might be worth documenting somewhere.

In any case, I think we could s/Gen2 // in the text above.
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Bjorn Helgaas March 8, 2016, 6:36 p.m. UTC | #4
On Thu, Feb 25, 2016 at 09:45:56AM +0900, Simon Horman wrote:
> Make use of ARCH_RENESAS in place of ARCH_SHMOBILE.
> 
> This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> 
> Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> ---
>  drivers/pci/host/Kconfig | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
>  Based on the next branch of the pci tree
> 
> diff --git a/drivers/pci/host/Kconfig b/drivers/pci/host/Kconfig
> index 75a605426538..dcf4d5a349ca 100644
> --- a/drivers/pci/host/Kconfig
> +++ b/drivers/pci/host/Kconfig
> @@ -41,7 +41,7 @@ config PCI_TEGRA
>  config PCI_RCAR_GEN2
>  	bool "Renesas R-Car Gen2 Internal PCI controller"
>  	depends on ARM
> -	depends on ARCH_SHMOBILE || COMPILE_TEST
> +	depends on ARCH_RENESAS || COMPILE_TEST
>  	help
>  	  Say Y here if you want internal PCI support on R-Car Gen2 SoC.
>  	  There are 3 internal PCI controllers available with a single
> @@ -49,7 +49,7 @@ config PCI_RCAR_GEN2
>  
>  config PCI_RCAR_GEN2_PCIE
>  	bool "Renesas R-Car PCIe controller"
> -	depends on ARCH_SHMOBILE || (ARM && COMPILE_TEST)
> +	depends on ARCH_RENESAS || (ARM && COMPILE_TEST)

I don't object to this, but I don't know what's happening with Phil's
question.  Is there another revision coming with a doc change and/or the
"s/Gen2//" change?

>  	help
>  	  Say Y here if you want PCIe controller support on R-Car Gen2 SoCs.
>  
> -- 
> 2.7.0.rc3.207.g0ac5344
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-pci" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Simon Horman March 11, 2016, 1:49 a.m. UTC | #5
On Tue, Mar 08, 2016 at 12:36:50PM -0600, Bjorn Helgaas wrote:
> On Thu, Feb 25, 2016 at 09:45:56AM +0900, Simon Horman wrote:
> > Make use of ARCH_RENESAS in place of ARCH_SHMOBILE.
> > 
> > This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> > ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> > appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> > 
> > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> > ---
> >  drivers/pci/host/Kconfig | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> > 
> >  Based on the next branch of the pci tree
> > 
> > diff --git a/drivers/pci/host/Kconfig b/drivers/pci/host/Kconfig
> > index 75a605426538..dcf4d5a349ca 100644
> > --- a/drivers/pci/host/Kconfig
> > +++ b/drivers/pci/host/Kconfig
> > @@ -41,7 +41,7 @@ config PCI_TEGRA
> >  config PCI_RCAR_GEN2
> >  	bool "Renesas R-Car Gen2 Internal PCI controller"
> >  	depends on ARM
> > -	depends on ARCH_SHMOBILE || COMPILE_TEST
> > +	depends on ARCH_RENESAS || COMPILE_TEST
> >  	help
> >  	  Say Y here if you want internal PCI support on R-Car Gen2 SoC.
> >  	  There are 3 internal PCI controllers available with a single
> > @@ -49,7 +49,7 @@ config PCI_RCAR_GEN2
> >  
> >  config PCI_RCAR_GEN2_PCIE
> >  	bool "Renesas R-Car PCIe controller"
> > -	depends on ARCH_SHMOBILE || (ARM && COMPILE_TEST)
> > +	depends on ARCH_RENESAS || (ARM && COMPILE_TEST)
> 
> I don't object to this, but I don't know what's happening with Phil's
> question.  Is there another revision coming with a doc change and/or the
> "s/Gen2//" change?

Sorry for not following up earlier. I have a slight preference to handle
the Gen2 issue as a separate change. Could you consider picking up this
patch as is?

With regards to the Gen2 change:

* I think its entirely reasonable to s/Gen2// in the help text but;
* I think it would also be worth considering, as a follow-up change,
  s/PCI_RCAR_GEN2/PCI_RCAR/ though I'm wary of breaking existing configs.

  So I don't have a clear view of how to move forwards at this time.
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Bjorn Helgaas March 11, 2016, 6:08 p.m. UTC | #6
On Thu, Feb 25, 2016 at 09:45:56AM +0900, Simon Horman wrote:
> Make use of ARCH_RENESAS in place of ARCH_SHMOBILE.
> 
> This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> 
> Signed-off-by: Simon Horman <horms+renesas@verge.net.au>

Applied with Geert's ack to pci/host-rcar for v4.6, thanks, Simon!

> ---
>  drivers/pci/host/Kconfig | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
>  Based on the next branch of the pci tree
> 
> diff --git a/drivers/pci/host/Kconfig b/drivers/pci/host/Kconfig
> index 75a605426538..dcf4d5a349ca 100644
> --- a/drivers/pci/host/Kconfig
> +++ b/drivers/pci/host/Kconfig
> @@ -41,7 +41,7 @@ config PCI_TEGRA
>  config PCI_RCAR_GEN2
>  	bool "Renesas R-Car Gen2 Internal PCI controller"
>  	depends on ARM
> -	depends on ARCH_SHMOBILE || COMPILE_TEST
> +	depends on ARCH_RENESAS || COMPILE_TEST
>  	help
>  	  Say Y here if you want internal PCI support on R-Car Gen2 SoC.
>  	  There are 3 internal PCI controllers available with a single
> @@ -49,7 +49,7 @@ config PCI_RCAR_GEN2
>  
>  config PCI_RCAR_GEN2_PCIE
>  	bool "Renesas R-Car PCIe controller"
> -	depends on ARCH_SHMOBILE || (ARM && COMPILE_TEST)
> +	depends on ARCH_RENESAS || (ARM && COMPILE_TEST)
>  	help
>  	  Say Y here if you want PCIe controller support on R-Car Gen2 SoCs.
>  
> -- 
> 2.7.0.rc3.207.g0ac5344
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-pci" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Bjorn Helgaas March 11, 2016, 6:13 p.m. UTC | #7
On Fri, Mar 11, 2016 at 10:49:11AM +0900, Simon Horman wrote:
> On Tue, Mar 08, 2016 at 12:36:50PM -0600, Bjorn Helgaas wrote:
> > On Thu, Feb 25, 2016 at 09:45:56AM +0900, Simon Horman wrote:
> > > Make use of ARCH_RENESAS in place of ARCH_SHMOBILE.
> > > 
> > > This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> > > ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> > > appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> > > 
> > > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> > > ---
> > >  drivers/pci/host/Kconfig | 4 ++--
> > >  1 file changed, 2 insertions(+), 2 deletions(-)
> > > 
> > >  Based on the next branch of the pci tree
> > > 
> > > diff --git a/drivers/pci/host/Kconfig b/drivers/pci/host/Kconfig
> > > index 75a605426538..dcf4d5a349ca 100644
> > > --- a/drivers/pci/host/Kconfig
> > > +++ b/drivers/pci/host/Kconfig
> > > @@ -41,7 +41,7 @@ config PCI_TEGRA
> > >  config PCI_RCAR_GEN2
> > >  	bool "Renesas R-Car Gen2 Internal PCI controller"
> > >  	depends on ARM
> > > -	depends on ARCH_SHMOBILE || COMPILE_TEST
> > > +	depends on ARCH_RENESAS || COMPILE_TEST
> > >  	help
> > >  	  Say Y here if you want internal PCI support on R-Car Gen2 SoC.
> > >  	  There are 3 internal PCI controllers available with a single
> > > @@ -49,7 +49,7 @@ config PCI_RCAR_GEN2
> > >  
> > >  config PCI_RCAR_GEN2_PCIE
> > >  	bool "Renesas R-Car PCIe controller"
> > > -	depends on ARCH_SHMOBILE || (ARM && COMPILE_TEST)
> > > +	depends on ARCH_RENESAS || (ARM && COMPILE_TEST)
> > 
> > I don't object to this, but I don't know what's happening with Phil's
> > question.  Is there another revision coming with a doc change and/or the
> > "s/Gen2//" change?
> 
> Sorry for not following up earlier. I have a slight preference to handle
> the Gen2 issue as a separate change. Could you consider picking up this
> patch as is?
> 
> With regards to the Gen2 change:
> 
> * I think its entirely reasonable to s/Gen2// in the help text but;
> * I think it would also be worth considering, as a follow-up change,
>   s/PCI_RCAR_GEN2/PCI_RCAR/ though I'm wary of breaking existing configs.

The Gen2 and PCI/PCIe text is definitely confusing.  It'd be nice to
clean it up somehow.

Bjorn
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/pci/host/Kconfig b/drivers/pci/host/Kconfig
index 75a605426538..dcf4d5a349ca 100644
--- a/drivers/pci/host/Kconfig
+++ b/drivers/pci/host/Kconfig
@@ -41,7 +41,7 @@  config PCI_TEGRA
 config PCI_RCAR_GEN2
 	bool "Renesas R-Car Gen2 Internal PCI controller"
 	depends on ARM
-	depends on ARCH_SHMOBILE || COMPILE_TEST
+	depends on ARCH_RENESAS || COMPILE_TEST
 	help
 	  Say Y here if you want internal PCI support on R-Car Gen2 SoC.
 	  There are 3 internal PCI controllers available with a single
@@ -49,7 +49,7 @@  config PCI_RCAR_GEN2
 
 config PCI_RCAR_GEN2_PCIE
 	bool "Renesas R-Car PCIe controller"
-	depends on ARCH_SHMOBILE || (ARM && COMPILE_TEST)
+	depends on ARCH_RENESAS || (ARM && COMPILE_TEST)
 	help
 	  Say Y here if you want PCIe controller support on R-Car Gen2 SoCs.