diff mbox

[3/4] Rename lto_section_names to match lto_get_section_name

Message ID 20100710114153.E00E9B24FE@basil.firstfloor.org
State New
Headers show

Commit Message

Andi Kleen July 10, 2010, 11:41 a.m. UTC
The lto_section_names array was out of sync with the names
used by lto_get_section_name. Fix the two to match.

2010-07-10   Andi Kleen <ak@linux.intel.com>

        * lto-section-in.c (lto_section_name): Synchronize names
	with lto_get_section_name.
diff mbox

Patch

diff --git a/gcc/lto-section-in.c b/gcc/lto-section-in.c
index 72f1d3d..c8c3d4a 100644
--- a/gcc/lto-section-in.c
+++ b/gcc/lto-section-in.c
@@ -50,13 +50,13 @@  const char *lto_section_name[LTO_N_SECTION_TYPES] =
 {
   "decls",
   "function_body",
-  "static_initializer",
+  "statics",
   "cgraph",
-  "varpool",
+  "vars",
   "refs",
-  "jump_funcs",
-  "ipa_pure_const",
-  "ipa_reference",
+  "jmpfuncs",
+  "pureconst",
+  "reference",
   "symtab",
   "opts",
   "cgraphopt"