mbox

[U-Boot] Pull request: u-boot-spi/master

Message ID 1449852786-17348-1-git-send-email-jteki@openedev.com
State Accepted
Delegated to: Tom Rini
Headers show

Pull-request

git://git.denx.de/u-boot-spi.git master

Message

Jagan Teki Dec. 11, 2015, 4:53 p.m. UTC
Hi Tom,

Please pull this PR.

thanks!
Jagan.

The following changes since commit 789fa275b3750e60c60cb3d18eabc9467892c257:

  x86: Remove HAVE_ACPI_RESUME (2015-12-09 17:44:56 +0800)

are available in the git repository at:

  git://git.denx.de/u-boot-spi.git master

for you to fetch changes up to 76de51a6da0411e1f3e80e1c9a2ef5bfa8e35571:

  spi: xilinx: Add new compatible strings (2015-12-11 22:12:24 +0530)

----------------------------------------------------------------
Jagan Teki (17):
      spi: Get spi-3wire from dts
      spi: ti_qspi: Fix SPI_3WIRE checking using mode
      sf: spi_flash_validate_params => spi_flash_scan
      sf: Move spi_flash_scan code to sf_ops
      sf: Move read_id code to sf_ops
      sf: probe: Code cleanup
      sf: Use static for file-scope functions
      sf: Fix Makefile
      sf: Use simple name for register access functions
      sf: Flash power up read-only based on idcode0
      sf: Remove unneeded header includes
      sf: Remove unneeded SST_BP and SST_WP
      sf: ops: Fix missing break on spansion read_bar
      sf: sf_probe: Remove spi_slave pointer argument
      sf: Use static for file-scope functions
      sf: Rename sf_ops.c to spi-flash.c
      mailmap: Update Jagan Teki's name and email address

Michal Simek (3):
      spi: zynq_spi: Add cadence compatible string
      spi: Kconfig: Fix correct target name for ZynqMP
      spi: xilinx: Add new compatible strings

Peng Fan (1):
      imx: mx7dsabresd: Add QSPI support

 .mailmap                                  |   6 +-
 board/freescale/mx7dsabresd/mx7dsabresd.c |  30 +++
 drivers/mtd/spi/Makefile                  |   6 +-
 drivers/mtd/spi/sf_internal.h             |  38 ++-
 drivers/mtd/spi/sf_probe.c                | 373 +--------------------------
 drivers/mtd/spi/{sf_ops.c => spi_flash.c} | 406 ++++++++++++++++++++++++++++--
 drivers/spi/Kconfig                       |   2 +-
 drivers/spi/spi-uclass.c                  |   2 +
 drivers/spi/ti_qspi.c                     |   2 +-
 drivers/spi/xilinx_spi.c                  |   3 +-
 drivers/spi/zynq_spi.c                    |   1 +
 include/configs/mx7dsabresd.h             |  15 ++
 12 files changed, 465 insertions(+), 419 deletions(-)
 rename drivers/mtd/spi/{sf_ops.c => spi_flash.c} (60%)

Comments

Tom Rini Dec. 12, 2015, 1:13 a.m. UTC | #1
On Fri, Dec 11, 2015 at 10:23:06PM +0530, Jagan Teki wrote:

> Hi Tom,
> 
> Please pull this PR.
> 
> thanks!
> Jagan.
> 
> The following changes since commit 789fa275b3750e60c60cb3d18eabc9467892c257:
> 
>   x86: Remove HAVE_ACPI_RESUME (2015-12-09 17:44:56 +0800)
> 
> are available in the git repository at:
> 
>   git://git.denx.de/u-boot-spi.git master
> 
> for you to fetch changes up to 76de51a6da0411e1f3e80e1c9a2ef5bfa8e35571:
> 
>   spi: xilinx: Add new compatible strings (2015-12-11 22:12:24 +0530)
> 

Applied to u-boot/master, thanks!