diff mbox

decnet: remove macro-local declarations

Message ID 1446718696-32505-1-git-send-email-Julia.Lawall@lip6.fr
State Deferred, archived
Delegated to: David Miller
Headers show

Commit Message

Julia Lawall Nov. 5, 2015, 10:18 a.m. UTC
Move the variable declarations from the for_nexthops macro to the
surrounding context, so that it is clear where these variables are
declared.  This also makes it possible to remove the endfor_nexthops macro.

This change adds new arguments to the macro for_nexthops.  They are ordered
such that a pointer to the referenced object comes first, the index in the
list comes next, and the list itself comes last, roughly in analogy with
the list_for_each macros.

Signed-off-by: Julia Lawall <Julia.Lawall@lip6.fr>

---

This patch takes care of a single file, where the macros are defined
locally.  If the basic transformation looks OK, I will change the other
files that either likewise define their own macros or use the macros in
net/mpls/internal.h.  The potentially affected files are:

net/decnet/dn_fib.c
net/ipv4/fib_semantics.c
net/mpls/af_mpls.c

 net/decnet/dn_table.c |   17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)


--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Comments

David Miller Nov. 5, 2015, 7:26 p.m. UTC | #1
From: Julia Lawall <Julia.Lawall@lip6.fr>
Date: Thu,  5 Nov 2015 11:18:16 +0100

> Move the variable declarations from the for_nexthops macro to the
> surrounding context, so that it is clear where these variables are
> declared.  This also makes it possible to remove the endfor_nexthops macro.
> 
> This change adds new arguments to the macro for_nexthops.  They are ordered
> such that a pointer to the referenced object comes first, the index in the
> list comes next, and the list itself comes last, roughly in analogy with
> the list_for_each macros.
> 
> Signed-off-by: Julia Lawall <Julia.Lawall@lip6.fr>
> 
> ---
> 
> This patch takes care of a single file, where the macros are defined
> locally.  If the basic transformation looks OK, I will change the other
> files that either likewise define their own macros or use the macros in
> net/mpls/internal.h.  The potentially affected files are:
 ...

This looks fine to me.

Please resubmit this when net-next opens back up, which should be
shortly after -rc1.

Thanks.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Julia Lawall Nov. 5, 2015, 7:38 p.m. UTC | #2
On Thu, 5 Nov 2015, David Miller wrote:

> From: Julia Lawall <Julia.Lawall@lip6.fr>
> Date: Thu,  5 Nov 2015 11:18:16 +0100
> 
> > Move the variable declarations from the for_nexthops macro to the
> > surrounding context, so that it is clear where these variables are
> > declared.  This also makes it possible to remove the endfor_nexthops macro.
> > 
> > This change adds new arguments to the macro for_nexthops.  They are ordered
> > such that a pointer to the referenced object comes first, the index in the
> > list comes next, and the list itself comes last, roughly in analogy with
> > the list_for_each macros.
> > 
> > Signed-off-by: Julia Lawall <Julia.Lawall@lip6.fr>
> > 
> > ---
> > 
> > This patch takes care of a single file, where the macros are defined
> > locally.  If the basic transformation looks OK, I will change the other
> > files that either likewise define their own macros or use the macros in
> > net/mpls/internal.h.  The potentially affected files are:
>  ...
> 
> This looks fine to me.
> 
> Please resubmit this when net-next opens back up, which should be
> shortly after -rc1.

OK, I'll do the others then too.

julia
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Julia Lawall Nov. 5, 2015, 8:08 p.m. UTC | #3
On Thu, 5 Nov 2015, David Miller wrote:

> From: Julia Lawall <Julia.Lawall@lip6.fr>
> Date: Thu,  5 Nov 2015 11:18:16 +0100
> 
> > Move the variable declarations from the for_nexthops macro to the
> > surrounding context, so that it is clear where these variables are
> > declared.  This also makes it possible to remove the endfor_nexthops macro.
> > 
> > This change adds new arguments to the macro for_nexthops.  They are ordered
> > such that a pointer to the referenced object comes first, the index in the
> > list comes next, and the list itself comes last, roughly in analogy with
> > the list_for_each macros.
> > 
> > Signed-off-by: Julia Lawall <Julia.Lawall@lip6.fr>
> > 
> > ---
> > 
> > This patch takes care of a single file, where the macros are defined
> > locally.  If the basic transformation looks OK, I will change the other
> > files that either likewise define their own macros or use the macros in
> > net/mpls/internal.h.  The potentially affected files are:
>  ...
> 
> This looks fine to me.

Would it be preferable to remove the macro entirely and inline the for 
loop header?

julia

> Please resubmit this when net-next opens back up, which should be
> shortly after -rc1.
> 
> Thanks.
> --
> To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> 
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
David Miller Nov. 5, 2015, 8:13 p.m. UTC | #4
From: Julia Lawall <julia.lawall@lip6.fr>
Date: Thu, 5 Nov 2015 21:08:17 +0100 (CET)

> On Thu, 5 Nov 2015, David Miller wrote:
> 
>> From: Julia Lawall <Julia.Lawall@lip6.fr>
>> Date: Thu,  5 Nov 2015 11:18:16 +0100
>> 
>> > Move the variable declarations from the for_nexthops macro to the
>> > surrounding context, so that it is clear where these variables are
>> > declared.  This also makes it possible to remove the endfor_nexthops macro.
>> > 
>> > This change adds new arguments to the macro for_nexthops.  They are ordered
>> > such that a pointer to the referenced object comes first, the index in the
>> > list comes next, and the list itself comes last, roughly in analogy with
>> > the list_for_each macros.
>> > 
>> > Signed-off-by: Julia Lawall <Julia.Lawall@lip6.fr>
>> > 
>> > ---
>> > 
>> > This patch takes care of a single file, where the macros are defined
>> > locally.  If the basic transformation looks OK, I will change the other
>> > files that either likewise define their own macros or use the macros in
>> > net/mpls/internal.h.  The potentially affected files are:
>>  ...
>> 
>> This looks fine to me.
> 
> Would it be preferable to remove the macro entirely and inline the for 
> loop header?

Could you show me an example of how this would look exactly?
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Joe Perches Nov. 5, 2015, 10:02 p.m. UTC | #5
On Thu, 2015-11-05 at 20:38 +0100, Julia Lawall wrote:
> On Thu, 5 Nov 2015, David Miller wrote:
> > From: Julia Lawall <Julia.Lawall@lip6.fr>
> > Date: Thu,  5 Nov 2015 11:18:16 +0100> 
> > > Move the variable declarations from the for_nexthops macro to the
> > > surrounding context, so that it is clear where these variables are
> > > declared.  This also makes it possible to remove the endfor_nexthops macro.
> > > 
> > > This change adds new arguments to the macro for_nexthops.  They are ordered
> > > such that a pointer to the referenced object comes first, the index in the
> > > list comes next, and the list itself comes last, roughly in analogy with
> > > the list_for_each macros.
[]
> > > This patch takes care of a single file, where the macros are defined
> > > locally.  If the basic transformation looks OK, I will change the other
> > > files that either likewise define their own macros or use the macros in
> > > net/mpls/internal.h.  The potentially affected files are:
> >  ...
> > 
> > This looks fine to me.
> > 
> > Please resubmit this when net-next opens back up, which should be
> > shortly after -rc1.
> 
> OK, I'll do the others then too.

If you do can you please parenthesize the macro arguments?

#define for_nexthops(nh, nhsel, fi) \
 	for (nhsel = 0, nh = (fi)->fib_nh; nhsel < (fi)->fib_nhs; (nh)++, (nhsel)++)
instead of
	for(nhsel = 0, nh = (fi)->fib_nh; nhsel < (fi)->fib_nhs; nh++, nhsel++)

And perhaps a renaming might be better

	s/for_nexthops/for_each_nexthop/
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Julia Lawall Nov. 5, 2015, 10:21 p.m. UTC | #6
On Thu, 5 Nov 2015, Joe Perches wrote:

> On Thu, 2015-11-05 at 20:38 +0100, Julia Lawall wrote:
> > On Thu, 5 Nov 2015, David Miller wrote:
> > > From: Julia Lawall <Julia.Lawall@lip6.fr>
> > > Date: Thu,  5 Nov 2015 11:18:16 +0100> 
> > > > Move the variable declarations from the for_nexthops macro to the
> > > > surrounding context, so that it is clear where these variables are
> > > > declared.  This also makes it possible to remove the endfor_nexthops macro.
> > > > 
> > > > This change adds new arguments to the macro for_nexthops.  They are ordered
> > > > such that a pointer to the referenced object comes first, the index in the
> > > > list comes next, and the list itself comes last, roughly in analogy with
> > > > the list_for_each macros.
> []
> > > > This patch takes care of a single file, where the macros are defined
> > > > locally.  If the basic transformation looks OK, I will change the other
> > > > files that either likewise define their own macros or use the macros in
> > > > net/mpls/internal.h.  The potentially affected files are:
> > >  ...
> > > 
> > > This looks fine to me.
> > > 
> > > Please resubmit this when net-next opens back up, which should be
> > > shortly after -rc1.
> > 
> > OK, I'll do the others then too.
> 
> If you do can you please parenthesize the macro arguments?
> 
> #define for_nexthops(nh, nhsel, fi) \
>  	for (nhsel = 0, nh = (fi)->fib_nh; nhsel < (fi)->fib_nhs; (nh)++, (nhsel)++)
> instead of
> 	for(nhsel = 0, nh = (fi)->fib_nh; nhsel < (fi)->fib_nhs; nh++, nhsel++)

OK

> And perhaps a renaming might be better
> 
> 	s/for_nexthops/for_each_nexthop/

OK

Thanks for the suggestions.

julia
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/net/decnet/dn_table.c b/net/decnet/dn_table.c
index 1540b50..3e20dbb 100644
--- a/net/decnet/dn_table.c
+++ b/net/decnet/dn_table.c
@@ -60,11 +60,9 @@  struct dn_hash
 
 #define dz_key_0(key)		((key).datum = 0)
 
-#define for_nexthops(fi) { int nhsel; const struct dn_fib_nh *nh;\
+#define for_nexthops(nh, nhsel, fi) \
 	for(nhsel = 0, nh = (fi)->fib_nh; nhsel < (fi)->fib_nhs; nh++, nhsel++)
 
-#define endfor_nexthops(fi) }
-
 #define DN_MAX_DIVISOR 1024
 #define DN_S_ZOMBIE 1
 #define DN_S_ACCESSED 2
@@ -226,8 +224,9 @@  static struct dn_zone *dn_new_zone(struct dn_hash *table, int z)
 
 static int dn_fib_nh_match(struct rtmsg *r, struct nlmsghdr *nlh, struct nlattr *attrs[], struct dn_fib_info *fi)
 {
+	const struct dn_fib_nh *nh;
 	struct rtnexthop *nhp;
-	int nhlen;
+	int nhlen, nhsel;
 
 	if (attrs[RTA_PRIORITY] &&
 	    nla_get_u32(attrs[RTA_PRIORITY]) != fi->fib_priority)
@@ -246,7 +245,7 @@  static int dn_fib_nh_match(struct rtmsg *r, struct nlmsghdr *nlh, struct nlattr
 	nhp = nla_data(attrs[RTA_MULTIPATH]);
 	nhlen = nla_len(attrs[RTA_MULTIPATH]);
 
-	for_nexthops(fi) {
+	for_nexthops(nh, nhsel, fi) {
 		int attrlen = nhlen - sizeof(struct rtnexthop);
 		__le16 gw;
 
@@ -264,7 +263,7 @@  static int dn_fib_nh_match(struct rtmsg *r, struct nlmsghdr *nlh, struct nlattr
 				return 1;
 		}
 		nhp = RTNH_NEXT(nhp);
-	} endfor_nexthops(fi);
+	}
 
 	return 0;
 }
@@ -345,11 +344,13 @@  static int dn_fib_dump_info(struct sk_buff *skb, u32 portid, u32 seq, int event,
 	if (fi->fib_nhs > 1) {
 		struct rtnexthop *nhp;
 		struct nlattr *mp_head;
+		const struct dn_fib_nh *nh;
+		int nhsel;
 
 		if (!(mp_head = nla_nest_start(skb, RTA_MULTIPATH)))
 			goto errout;
 
-		for_nexthops(fi) {
+		for_nexthops(nh, nhsel, fi) {
 			if (!(nhp = nla_reserve_nohdr(skb, sizeof(*nhp))))
 				goto errout;
 
@@ -362,7 +363,7 @@  static int dn_fib_dump_info(struct sk_buff *skb, u32 portid, u32 seq, int event,
 				goto errout;
 
 			nhp->rtnh_len = skb_tail_pointer(skb) - (unsigned char *)nhp;
-		} endfor_nexthops(fi);
+		}
 
 		nla_nest_end(skb, mp_head);
 	}