diff mbox

[U-Boot] lpc32xx: remove duplicated DMA_CLK_ENABLE bit definition

Message ID 1440634608-27203-1-git-send-email-vz@mleia.com
State Accepted
Delegated to: Tom Rini
Headers show

Commit Message

Vladimir Zapolskiy Aug. 27, 2015, 12:16 a.m. UTC
Because there is an originally defined CLK_DMA_ENABLE macro in clk.h,
no reason to add another DMA_CLK_ENABLE macro with the same value.

Remove DMA_CLK_ENABLE, since it does not follow naming convention from
the code, this implies renaming of DMA_CLK_ENABLE to CLK_DMA_ENABLE in
lpc32xx/devices.c file.

Signed-off-by: Vladimir Zapolskiy <vz@mleia.com>
---
The change fixes a missed review comment from https://patchwork.ozlabs.org/patch/505602/

 arch/arm/cpu/arm926ejs/lpc32xx/devices.c | 3 +--
 arch/arm/include/asm/arch-lpc32xx/clk.h  | 3 ---
 2 files changed, 1 insertion(+), 5 deletions(-)

Comments

LEMIEUX, SYLVAIN Aug. 27, 2015, 11:12 a.m. UTC | #1
> -----Original Message-----
> From: Vladimir Zapolskiy [mailto:vz@mleia.com]
> Sent: 26-Aug-15 8:17 PM
>
> Because there is an originally defined CLK_DMA_ENABLE macro in clk.h,
> no reason to add another DMA_CLK_ENABLE macro with the same value.
>
> Remove DMA_CLK_ENABLE, since it does not follow naming convention from
> the code, this implies renaming of DMA_CLK_ENABLE to CLK_DMA_ENABLE in
> lpc32xx/devices.c file.
>
> Signed-off-by: Vladimir Zapolskiy <vz@mleia.com>
> ---
> The change fixes a missed review comment from https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__patchwork.ozlabs.org_patch_505602_&d=BQIBAg&c=0YGvTs3tT-VMy8_v51yLDw&r=wQJtM_tLxuQC97M-
> Lmzkek8zkzOmmSH5aGpH9XICxMY&m=_h1D4ysIu0Z-R8-jYuIET-
> Eo2akhhC_vyMJLHs7y5Gw&s=Xik_VBujVWd4PbkiE5sARa0KwLkSLQs0w6wj1p2e7Cw&e=
>
>  arch/arm/cpu/arm926ejs/lpc32xx/devices.c | 3 +--
>  arch/arm/include/asm/arch-lpc32xx/clk.h  | 3 ---
>  2 files changed, 1 insertion(+), 5 deletions(-)
>
> diff --git a/arch/arm/cpu/arm926ejs/lpc32xx/devices.c b/arch/arm/cpu/arm926ejs/lpc32xx/devices.c
> index d9fa280..b1c3f8f 100644
> --- a/arch/arm/cpu/arm926ejs/lpc32xx/devices.c
> +++ b/arch/arm/cpu/arm926ejs/lpc32xx/devices.c
> @@ -44,8 +44,7 @@ void lpc32xx_uart_init(unsigned int uart_id)
>  void lpc32xx_dma_init(void)
>  {

[...]

Tested-by: Sylvain Lemieux <slemieux@tycoint.com>
Tom Rini Sept. 12, 2015, 12:47 p.m. UTC | #2
On Thu, Aug 27, 2015 at 03:16:48AM +0300, Vladimir Zapolskiy wrote:

> Because there is an originally defined CLK_DMA_ENABLE macro in clk.h,
> no reason to add another DMA_CLK_ENABLE macro with the same value.
> 
> Remove DMA_CLK_ENABLE, since it does not follow naming convention from
> the code, this implies renaming of DMA_CLK_ENABLE to CLK_DMA_ENABLE in
> lpc32xx/devices.c file.
> 
> Signed-off-by: Vladimir Zapolskiy <vz@mleia.com>
> Tested-by: Sylvain Lemieux <slemieux@tycoint.com>

Applied to u-boot/master, thanks!
diff mbox

Patch

diff --git a/arch/arm/cpu/arm926ejs/lpc32xx/devices.c b/arch/arm/cpu/arm926ejs/lpc32xx/devices.c
index d9fa280..b1c3f8f 100644
--- a/arch/arm/cpu/arm926ejs/lpc32xx/devices.c
+++ b/arch/arm/cpu/arm926ejs/lpc32xx/devices.c
@@ -44,8 +44,7 @@  void lpc32xx_uart_init(unsigned int uart_id)
 void lpc32xx_dma_init(void)
 {
 	/* Enable DMA interface */
-	writel(DMA_CLK_ENABLE, &clk->dmaclk_ctrl);
-
+	writel(CLK_DMA_ENABLE, &clk->dmaclk_ctrl);
 }
 
 void lpc32xx_mac_init(void)
diff --git a/arch/arm/include/asm/arch-lpc32xx/clk.h b/arch/arm/include/asm/arch-lpc32xx/clk.h
index d21310e..303ff1c 100644
--- a/arch/arm/include/asm/arch-lpc32xx/clk.h
+++ b/arch/arm/include/asm/arch-lpc32xx/clk.h
@@ -158,9 +158,6 @@  struct clk_pm_regs {
 #define CLK_NAND_SLC_SELECT		(1 << 2)
 #define CLK_NAND_MLC_INT		(1 << 5)
 
-/* DMA Clock Control Register bits */
-#define DMA_CLK_ENABLE			(1 << 0)
-
 /* SSP Clock Control Register bits */
 #define CLK_SSP0_ENABLE_CLOCK		(1 << 0)