diff mbox

[gomp4] Re: acc_on_device for device_type_host_nonshm

Message ID 556FE67D.6020601@mentor.com
State New
Headers show

Commit Message

Tom de Vries June 4, 2015, 5:47 a.m. UTC
On 28/05/15 15:16, Julian Brown wrote:
> On Thu, 28 May 2015 04:48:58 -0700
> "H.J. Lu" <hjl.tools@gmail.com> wrote:
>
>> On Thu, May 21, 2015 at 4:10 AM, Jakub Jelinek <jakub@redhat.com>
>> wrote:
>>> On Thu, May 21, 2015 at 01:02:12PM +0200, Thomas Schwinge wrote:
>>>> Hi!
>>>>
>>>> On Thu, 7 May 2015 19:32:26 +0100, Julian Brown
>>>> <julian@codesourcery.com> wrote:
>>>>> Here's a new version of the patch [...]
>>>>
>>>>> OK for trunk?
>>>>
>>>> Makes sense to me (with just a request to drop the testsuite
>>>> changes, see below), to get the existing regressions under
>>>> control.  Jakub?
>>>
>>> Ok for trunk.
>>>>
>>>>>      PR libgomp/65742
>>>>>
>>>>>      gcc/
>>>>>      * builtins.c (expand_builtin_acc_on_device): Don't use
>>>>> open-coded sequence for !ACCEL_COMPILER.
>>>>>
>>
>> It breaks bootstrap on x86:
>>
>> https://gcc.gnu.org/ml/gcc-regression/2015-05/msg00389.html
>>
>> I checked in this to fix it.
>
> Apologies, and thanks!
>

And backported it to gomp-4_0-branch.

Thanks,
- Tom
diff mbox

Patch

Mark parameters with ATTRIBUTE_UNUSED

2015-06-04  Tom de Vries  <tom@codesourcery.com>

	backport from trunk:
	2015-05-28  H.J. Lu  <hongjiu.lu@intel.com>

	* builtins.c (expand_builtin_acc_on_device): Mark parameters
	with ATTRIBUTE_UNUSED.
---
 gcc/builtins.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gcc/builtins.c b/gcc/builtins.c
index bfa9832..6574413 100644
--- a/gcc/builtins.c
+++ b/gcc/builtins.c
@@ -5915,7 +5915,8 @@  expand_stack_save (void)
    acceleration device (ACCEL_COMPILER conditional).  */
 
 static rtx
-expand_builtin_acc_on_device (tree exp, rtx target)
+expand_builtin_acc_on_device (tree exp ATTRIBUTE_UNUSED,
+			      rtx target ATTRIBUTE_UNUSED)
 {
 #ifdef ACCEL_COMPILER
   if (!validate_arglist (exp, INTEGER_TYPE, VOID_TYPE))
-- 
1.9.1