Patchwork non-existant config in kernel source (CONFIG_AHCI)

login
register
mail settings
Submitter Christoph Egger
Date Feb. 5, 2010, 3:26 p.m.
Message ID <20100205152635.GC7299@faui49.informatik.uni-erlangen.de>
Download mbox | patch
Permalink /patch/44647/
State Not Applicable
Delegated to: David Miller
Headers show

Comments

Christoph Egger - Feb. 5, 2010, 3:26 p.m.
On Fri, Feb 05, 2010 at 02:57:00PM +0100, Frans Pop wrote:
> Christoph Egger wrote:
> > --- a/drivers/ata/pata_marvell.c
> > +++ b/drivers/ata/pata_marvell.c
> > @@ -147,7 +147,7 @@ static int marvell_init_one (struct pci_dev *pdev,
> > 	if (pdev->device == 0x6101)
> >		ppi[1] = &ata_dummy_port_info;
> > 
> > -#if defined(CONFIG_AHCI) || defined(CONFIG_AHCI_MODULE)
> > +#if defined(CONFIG_SATA_AHCI) || defined(SATA_CONFIG_AHCI_MODULE)
> 
> Shouldn't the last be CONFIG_SATA_AHCI_MODULE ?

Right my fault. Updated patch below

-----
From 60136f94d9c97f9a788738e30731e25bd794322b Mon Sep 17 00:00:00 2001
From: Christoph Egger <siccegge@stud.informatik.uni-erlangen.de>
Date: Fri, 5 Feb 2010 13:26:33 +0100
Subject: [PATCH] CONFIG_AHCI is really CONFIG_SATA_AHCI

The marvell driver comtains a fallback to ahci for the sata ports
which is incorrectly checked as CONFIG_AHCI while the only AHCI config
item is actually called SATA_AHCI (which also sounds sensible
considering it's a fallback for the sata ports).

Signed-off-by: Christoph Egger <siccegge@stud.informatik.uni-erlangen.de>
---
 drivers/ata/pata_marvell.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)
Jeff Garzik - Feb. 13, 2010, 10:49 p.m.
On 02/05/2010 10:26 AM, Christoph Egger wrote:
> On Fri, Feb 05, 2010 at 02:57:00PM +0100, Frans Pop wrote:
>> Christoph Egger wrote:
>>> --- a/drivers/ata/pata_marvell.c
>>> +++ b/drivers/ata/pata_marvell.c
>>> @@ -147,7 +147,7 @@ static int marvell_init_one (struct pci_dev *pdev,
>>> 	if (pdev->device == 0x6101)
>>> 		ppi[1] =&ata_dummy_port_info;
>>>
>>> -#if defined(CONFIG_AHCI) || defined(CONFIG_AHCI_MODULE)
>>> +#if defined(CONFIG_SATA_AHCI) || defined(SATA_CONFIG_AHCI_MODULE)
>>
>> Shouldn't the last be CONFIG_SATA_AHCI_MODULE ?
>
> Right my fault. Updated patch below
>
> -----
>> From 60136f94d9c97f9a788738e30731e25bd794322b Mon Sep 17 00:00:00 2001
> From: Christoph Egger<siccegge@stud.informatik.uni-erlangen.de>
> Date: Fri, 5 Feb 2010 13:26:33 +0100
> Subject: [PATCH] CONFIG_AHCI is really CONFIG_SATA_AHCI
>
> The marvell driver comtains a fallback to ahci for the sata ports
> which is incorrectly checked as CONFIG_AHCI while the only AHCI config
> item is actually called SATA_AHCI (which also sounds sensible
> considering it's a fallback for the sata ports).
>
> Signed-off-by: Christoph Egger<siccegge@stud.informatik.uni-erlangen.de>
> ---
>   drivers/ata/pata_marvell.c |    2 +-
>   1 files changed, 1 insertions(+), 1 deletions(-)

applied


--
To unsubscribe from this list: send the line "unsubscribe linux-ide" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Patch

diff --git a/drivers/ata/pata_marvell.c b/drivers/ata/pata_marvell.c
index 950da39..eabd138 100644
--- a/drivers/ata/pata_marvell.c
+++ b/drivers/ata/pata_marvell.c
@@ -147,7 +147,7 @@  static int marvell_init_one (struct pci_dev *pdev, const struct pci_device_id *i
 	if (pdev->device == 0x6101)
 		ppi[1] = &ata_dummy_port_info;
 
-#if defined(CONFIG_AHCI) || defined(CONFIG_AHCI_MODULE)
+#if defined(CONFIG_SATA_AHCI) || defined(CONFIG_SATA_AHCI_MODULE)
 	if (!marvell_pata_active(pdev)) {
 		printk(KERN_INFO DRV_NAME ": PATA port not active, deferring to AHCI driver.\n");
 		return -ENODEV;