diff mbox

vpc: Implement bdrv_co_get_status()

Message ID 1423671788-31716-1-git-send-email-kwolf@redhat.com
State New
Headers show

Commit Message

Kevin Wolf Feb. 11, 2015, 4:23 p.m. UTC
This implements bdrv_co_get_status() for VHD images. This can
significantly speed up qemu-img convert operation because only with this
function implemented sparseness can be considered. (Before, converting a
1 TB empty image took several minutes for me, now it's instantaneous.)

Signed-off-by: Kevin Wolf <kwolf@redhat.com>
---
 block/vpc.c | 54 ++++++++++++++++++++++++++++++++++++++++++++++++++++--
 1 file changed, 52 insertions(+), 2 deletions(-)

Comments

Kevin Wolf Feb. 11, 2015, 4:33 p.m. UTC | #1
Am 11.02.2015 um 17:23 hat Kevin Wolf geschrieben:
> This implements bdrv_co_get_status() for VHD images. This can

s/bdrv_co_get_status/bdrv_co_get_block_status/, obviously (in the
subject as well).

> significantly speed up qemu-img convert operation because only with this
> function implemented sparseness can be considered. (Before, converting a
> 1 TB empty image took several minutes for me, now it's instantaneous.)
> 
> Signed-off-by: Kevin Wolf <kwolf@redhat.com>

Kevin
Max Reitz Feb. 11, 2015, 10:51 p.m. UTC | #2
On 2015-02-11 at 11:23, Kevin Wolf wrote:
> This implements bdrv_co_get_status() for VHD images. This can
> significantly speed up qemu-img convert operation because only with this
> function implemented sparseness can be considered. (Before, converting a
> 1 TB empty image took several minutes for me, now it's instantaneous.)
>
> Signed-off-by: Kevin Wolf <kwolf@redhat.com>
> ---
>   block/vpc.c | 54 ++++++++++++++++++++++++++++++++++++++++++++++++++++--
>   1 file changed, 52 insertions(+), 2 deletions(-)
>
> diff --git a/block/vpc.c b/block/vpc.c
> index 46803b1..379ff4a 100644
> --- a/block/vpc.c
> +++ b/block/vpc.c
> @@ -597,6 +597,55 @@ static coroutine_fn int vpc_co_write(BlockDriverState *bs, int64_t sector_num,
>       return ret;
>   }
>   
> +static int64_t coroutine_fn vpc_co_get_block_status(BlockDriverState *bs,
> +        int64_t sector_num, int nb_sectors, int *pnum)
> +{
> +    BDRVVPCState *s = bs->opaque;
> +    VHDFooter *footer =  (VHDFooter *) s->footer_buf;

Double space before the left parenthesis.

> +    int64_t start, offset;
> +    bool allocated;
> +    int n;
> +
> +    if (be32_to_cpu(footer->type) == VHD_FIXED) {
> +        *pnum = nb_sectors;
> +        return BDRV_BLOCK_RAW | BDRV_BLOCK_OFFSET_VALID | BDRV_BLOCK_DATA |
> +               (sector_num << BDRV_SECTOR_BITS);
> +    }
> +
> +    offset = get_sector_offset(bs, sector_num, 0);
> +
> +    *pnum = 1;
> +    start = offset;
> +    allocated = (offset != -1);
> +    nb_sectors--;
> +
> +    while (nb_sectors > 0) {
> +        offset = get_sector_offset(bs, sector_num, 0);

During the first iteration, this will is exactly the function call as 
the one before this loop.

> +
> +        if ((offset != -1) != allocated) {
> +            break;
> +        }
> +
> +        if (allocated && offset != start + (*pnum * 512)) {

Therefore, if allocated is true, this check will always fail because 
offset == start.

> +            break;
> +        }
> +
> +        /* All sectors in a block are contiguous (without using the bitmap) */
> +        n = ROUND_UP(sector_num + 1, s->block_size / 512) - sector_num;
> +        n = MIN(n, nb_sectors);

I think you can make use of this assumption even before calling 
get_sector_offset() in the first iteration.

Also, 512 is shorter than BDRV_SECTOR_SIZE and it's nice to get it on a 
single line, but I think not introducing another literal 512 in the code 
would be nicer; the same applies above in "*pnum * 512".

Max

> +
> +        *pnum += n;
> +        sector_num += n;
> +        nb_sectors -= n;
> +    }
> +
> +    if (allocated) {
> +        return BDRV_BLOCK_DATA | BDRV_BLOCK_OFFSET_VALID | start;
> +    } else {
> +        return 0;
> +    }
> +}
> +
>   /*
>    * Calculates the number of cylinders, heads and sectors per cylinder
>    * based on a given number of sectors. This is the algorithm described
> @@ -907,8 +956,9 @@ static BlockDriver bdrv_vpc = {
>       .bdrv_reopen_prepare    = vpc_reopen_prepare,
>       .bdrv_create            = vpc_create,
>   
> -    .bdrv_read              = vpc_co_read,
> -    .bdrv_write             = vpc_co_write,
> +    .bdrv_read                  = vpc_co_read,
> +    .bdrv_write                 = vpc_co_write,
> +    .bdrv_co_get_block_status   = vpc_co_get_block_status,
>   
>       .bdrv_get_info          = vpc_get_info,
>
Kevin Wolf Feb. 12, 2015, 9:28 a.m. UTC | #3
Am 11.02.2015 um 23:51 hat Max Reitz geschrieben:
> On 2015-02-11 at 11:23, Kevin Wolf wrote:
> >This implements bdrv_co_get_status() for VHD images. This can
> >significantly speed up qemu-img convert operation because only with this
> >function implemented sparseness can be considered. (Before, converting a
> >1 TB empty image took several minutes for me, now it's instantaneous.)
> >
> >Signed-off-by: Kevin Wolf <kwolf@redhat.com>
> >---
> >  block/vpc.c | 54 ++++++++++++++++++++++++++++++++++++++++++++++++++++--
> >  1 file changed, 52 insertions(+), 2 deletions(-)
> >
> >diff --git a/block/vpc.c b/block/vpc.c
> >index 46803b1..379ff4a 100644
> >--- a/block/vpc.c
> >+++ b/block/vpc.c
> >@@ -597,6 +597,55 @@ static coroutine_fn int vpc_co_write(BlockDriverState *bs, int64_t sector_num,
> >      return ret;
> >  }
> >+static int64_t coroutine_fn vpc_co_get_block_status(BlockDriverState *bs,
> >+        int64_t sector_num, int nb_sectors, int *pnum)
> >+{
> >+    BDRVVPCState *s = bs->opaque;
> >+    VHDFooter *footer =  (VHDFooter *) s->footer_buf;
> 
> Double space before the left parenthesis.

Fun. As it happens, I copied this line from elsewhere...

> >+    int64_t start, offset;
> >+    bool allocated;
> >+    int n;
> >+
> >+    if (be32_to_cpu(footer->type) == VHD_FIXED) {
> >+        *pnum = nb_sectors;
> >+        return BDRV_BLOCK_RAW | BDRV_BLOCK_OFFSET_VALID | BDRV_BLOCK_DATA |
> >+               (sector_num << BDRV_SECTOR_BITS);
> >+    }
> >+
> >+    offset = get_sector_offset(bs, sector_num, 0);
> >+
> >+    *pnum = 1;
> >+    start = offset;
> >+    allocated = (offset != -1);
> >+    nb_sectors--;
> >+
> >+    while (nb_sectors > 0) {
> >+        offset = get_sector_offset(bs, sector_num, 0);
> 
> During the first iteration, this will is exactly the function call
> as the one before this loop.
>
> >+
> >+        if ((offset != -1) != allocated) {
> >+            break;
> >+        }
> >+
> >+        if (allocated && offset != start + (*pnum * 512)) {
> 
> Therefore, if allocated is true, this check will always fail because
> offset == start.

Whoops, thanks for catching that. I'll fix it, even though it doesn't
seem to have any practicel consequences. VHD is a format braindead
enough that you never get two contiguous blocks anyway. There's always a
bitmap in between.

> >+            break;
> >+        }
> >+
> >+        /* All sectors in a block are contiguous (without using the bitmap) */
> >+        n = ROUND_UP(sector_num + 1, s->block_size / 512) - sector_num;
> >+        n = MIN(n, nb_sectors);
> 
> I think you can make use of this assumption even before calling
> get_sector_offset() in the first iteration.

Hm... Maybe I need to make it a do-while loop to get rid of some
duplication with the first iteration.

> Also, 512 is shorter than BDRV_SECTOR_SIZE and it's nice to get it
> on a single line, but I think not introducing another literal 512 in
> the code would be nicer; the same applies above in "*pnum * 512".

Fair enough.

Kevin
diff mbox

Patch

diff --git a/block/vpc.c b/block/vpc.c
index 46803b1..379ff4a 100644
--- a/block/vpc.c
+++ b/block/vpc.c
@@ -597,6 +597,55 @@  static coroutine_fn int vpc_co_write(BlockDriverState *bs, int64_t sector_num,
     return ret;
 }
 
+static int64_t coroutine_fn vpc_co_get_block_status(BlockDriverState *bs,
+        int64_t sector_num, int nb_sectors, int *pnum)
+{
+    BDRVVPCState *s = bs->opaque;
+    VHDFooter *footer =  (VHDFooter *) s->footer_buf;
+    int64_t start, offset;
+    bool allocated;
+    int n;
+
+    if (be32_to_cpu(footer->type) == VHD_FIXED) {
+        *pnum = nb_sectors;
+        return BDRV_BLOCK_RAW | BDRV_BLOCK_OFFSET_VALID | BDRV_BLOCK_DATA |
+               (sector_num << BDRV_SECTOR_BITS);
+    }
+
+    offset = get_sector_offset(bs, sector_num, 0);
+
+    *pnum = 1;
+    start = offset;
+    allocated = (offset != -1);
+    nb_sectors--;
+
+    while (nb_sectors > 0) {
+        offset = get_sector_offset(bs, sector_num, 0);
+
+        if ((offset != -1) != allocated) {
+            break;
+        }
+
+        if (allocated && offset != start + (*pnum * 512)) {
+            break;
+        }
+
+        /* All sectors in a block are contiguous (without using the bitmap) */
+        n = ROUND_UP(sector_num + 1, s->block_size / 512) - sector_num;
+        n = MIN(n, nb_sectors);
+
+        *pnum += n;
+        sector_num += n;
+        nb_sectors -= n;
+    }
+
+    if (allocated) {
+        return BDRV_BLOCK_DATA | BDRV_BLOCK_OFFSET_VALID | start;
+    } else {
+        return 0;
+    }
+}
+
 /*
  * Calculates the number of cylinders, heads and sectors per cylinder
  * based on a given number of sectors. This is the algorithm described
@@ -907,8 +956,9 @@  static BlockDriver bdrv_vpc = {
     .bdrv_reopen_prepare    = vpc_reopen_prepare,
     .bdrv_create            = vpc_create,
 
-    .bdrv_read              = vpc_co_read,
-    .bdrv_write             = vpc_co_write,
+    .bdrv_read                  = vpc_co_read,
+    .bdrv_write                 = vpc_co_write,
+    .bdrv_co_get_block_status   = vpc_co_get_block_status,
 
     .bdrv_get_info          = vpc_get_info,