Update autoconf version requirement in install.texi
diff mbox

Message ID Pine.LNX.4.64.1410312244370.25282@digraph.polyomino.org.uk
State New
Headers show

Commit Message

Joseph Myers Oct. 31, 2014, 10:46 p.m. UTC
On Fri, 31 Oct 2014, Roland McGrath wrote:

> That should have gone with the aclocal.m4 update.  Please add a comment to

(With the aclocal.m4 change two years ago to require an exact autoconf 
version, and then with the more recent increase of that version, that is.)

> aclocal.m4 reminding one to update install.texi to match.  (Or feel free to
> get crazy with a generated file of Texinfo macros!)

I've committed this patch.

2014-10-31  Joseph Myers  <joseph@codesourcery.com>

	* aclocal.m4 (GLIBC_AUTOCONF_VERSION): Mention need to update
	install.texi in comment.

Comments

Roland McGrath Nov. 1, 2014, 2:06 a.m. UTC | #1
> (With the aclocal.m4 change two years ago to require an exact autoconf 
> version, and then with the more recent increase of that version, that is.)

Phew, so it was your fault before it was mine!  Such a relief.
(We won't discuss how much entirely and completely my fault the
entire set of concepts leading to GLIBC_PROVIDES is.)

> > aclocal.m4 reminding one to update install.texi to match.  (Or feel free to
> > get crazy with a generated file of Texinfo macros!)
> 
> I've committed this patch.
> 
> 2014-10-31  Joseph Myers  <joseph@codesourcery.com>
> 
> 	* aclocal.m4 (GLIBC_AUTOCONF_VERSION): Mention need to update
> 	install.texi in comment.

OK, fine, be that way.  I've clearly failed to pass on to the community the
penchant for ludicrous over-scripting auto-generation mania that was the
hallmark of my authorship, so I'll have to stick around a few more years
and keep wearing you down.

Patch
diff mbox

diff --git a/aclocal.m4 b/aclocal.m4
index 23569b6..abc34d2 100644
--- a/aclocal.m4
+++ b/aclocal.m4
@@ -1,6 +1,7 @@ 
 dnl We require that everyone use exactly the same Autoconf version so that
 dnl the internal functions defined and used by the main configure script
-dnl match those expected by the fragments.
+dnl match those expected by the fragments.  When changing this version,
+dnl install.texi also needs to be updated.
 m4_define([GLIBC_AUTOCONF_VERSION], [2.69])
 m4_if(m4_defn([AC_AUTOCONF_VERSION]), GLIBC_AUTOCONF_VERSION, [],
       [m4_fatal(m4_flatten(