Remove bitrotten --enable-oldest-abi (bug 6652)
diff mbox

Message ID Pine.LNX.4.64.1409161706000.18320@digraph.polyomino.org.uk
State New
Headers show

Commit Message

Joseph Myers Sept. 16, 2014, 5:06 p.m. UTC
This patch removes the --enable-oldest-abi configure option, which has
long been bitrotten (as reported in bug 6652).  The principle of
removing this option was agreed in the thread starting at
<https://sourceware.org/ml/libc-alpha/2013-07/msg00174.html>.

Tested for x86_64 and x86 that the installed shared libraries other
than libc.so are unchanged by this patch and that libc.so disassembly
and symbol versions are unchanged (debug info changes because of
changed line numbers in csu/version.c).

(This patch is independent of my other pending shlib-versions-related
cleanup <https://sourceware.org/ml/libc-alpha/2014-09/msg00306.html>.)

2014-09-16  Joseph Myers  <joseph@codesourcery.com>

	[BZ #6652]
	* Makeconfig (soversions-default-setname): Remove variable.
	($(common-objpfx)soversions.i): Don't pass default_setname to
	soversions.awk.
	* Makerules ($(common-objpfx)abi-versions.h): Don't pass
	oldest_abi to abi-versions.awk.
	* config.h.in (GLIBC_OLDEST_ABI): Remove macro undefine.
	* config.make.in (oldest-abi): Remove variable.
	* configure.ac (--enable-oldest-abi): Remove configure option.
	* configure: Regenerated.
	* csu/version.c (banner) [GLIBC_OLDEST_ABI]: Remove conditional
	text.
	* scripts/abi-versions.awk: Do not handle oldest_abi variable.
	* scripts/soversions.awk: Do not handle default_setname variable.
	* sysdeps/mach/hurd/configure.ac: Do not handle oldest_abi
	variable.
	* sysdeps/mach/hurd/configure: Regenerated.
	* sysdeps/unix/sysv/linux/configure.ac: Do not handle oldest_abi
	variable.
	* sysdeps/unix/sysv/linux/configure: Regenerated.

Comments

Roland McGrath Sept. 16, 2014, 5:28 p.m. UTC | #1
Looks fine.

Patch
diff mbox

diff --git a/Makeconfig b/Makeconfig
index 0780788..fad2971 100644
--- a/Makeconfig
+++ b/Makeconfig
@@ -958,13 +958,9 @@  $(common-objpfx)shlib-versions.v.i: \
 		   $(subdir-srcdirs:=/shlib-versions)) \
 	$(..)shlib-versions
 
-soversions-default-setname = $(patsubst %, %,\
-					$(filter-out %_default,\
-						     $(oldest-abi:%=GLIBC_%)))
 $(common-objpfx)soversions.i: $(..)scripts/soversions.awk \
 			      $(common-objpfx)shlib-versions.v
-	$(AWK) -v default_setname='$(soversions-default-setname)' \
-	       -f $^ > $@T
+	$(AWK) -f $^ > $@T
 	mv -f $@T $@
 $(common-objpfx)soversions.mk: $(common-objpfx)soversions.i $(..)Makeconfig
 	(while read which lib number setname; do \
diff --git a/Makerules b/Makerules
index 6b30e8c..30c83ae 100644
--- a/Makerules
+++ b/Makerules
@@ -98,7 +98,7 @@  ifndef avoid-generated
 before-compile := $(common-objpfx)abi-versions.h $(before-compile)
 $(common-objpfx)abi-versions.h: $(..)scripts/abi-versions.awk \
 				$(common-objpfx)Versions.all
-	LC_ALL=C $(AWK) -v oldest_abi=$(oldest-abi) -f $^ > $@T
+	LC_ALL=C $(AWK) -f $^ > $@T
 	mv -f $@T $@
 
 $(common-objpfx)%.latest: $(common-objpfx)abi-versions.h
diff --git a/config.h.in b/config.h.in
index fcbe8ad..20c0825 100644
--- a/config.h.in
+++ b/config.h.in
@@ -54,9 +54,6 @@ 
    directive.  */
 #undef	HAVE_ASM_POPSECTION_DIRECTIVE
 
-/* Defined to the oldest ABI we support, like 2.1.  */
-#undef GLIBC_OLDEST_ABI
-
 /* Define if static NSS modules are wanted.  */
 #undef	DO_STATIC_NSS
 
diff --git a/config.make.in b/config.make.in
index 6bcab8a..4a781fd 100644
--- a/config.make.in
+++ b/config.make.in
@@ -68,7 +68,6 @@  output-format = @libc_cv_output_format@
 
 static-libgcc = @libc_cv_gcc_static_libgcc@
 
-oldest-abi = @oldest_abi@
 exceptions = @exceptions@
 multi-arch = @multi_arch@
 
diff --git a/configure b/configure
index ff5c730..28f2b44 100755
--- a/configure
+++ b/configure
@@ -653,7 +653,6 @@  force_install
 bindnow
 enable_lock_elision
 hardcoded_path_in_tests
-oldest_abi
 use_default_link
 sysheaders
 with_fp
@@ -737,7 +736,6 @@  with_default_link
 enable_sanity_checks
 enable_shared
 enable_profile
-enable_oldest_abi
 enable_hardcoded_path_in_tests
 enable_stackguard_randomization
 enable_lock_elision
@@ -1390,8 +1388,6 @@  Optional Features:
                           in special situations) [default=yes]
   --enable-shared         build shared library [default=yes if GNU ld]
   --enable-profile        build profiled library [default=no]
-  --enable-oldest-abi=ABI configure the oldest ABI supported [e.g. 2.2]
-                          [default=glibc default]
   --enable-hardcoded-path-in-tests
                           hardcode newly built glibc path in tests
                           [default=no]
@@ -3432,23 +3428,6 @@  else
 fi
 
 
-# Check whether --enable-oldest-abi was given.
-if test "${enable_oldest_abi+set}" = set; then :
-  enableval=$enable_oldest_abi; oldest_abi=$enableval
-else
-  oldest_abi=no
-fi
-
-if test "$oldest_abi" = yes || test "$oldest_abi" = no; then
-  oldest_abi=default
-else
-  cat >>confdefs.h <<_ACEOF
-#define GLIBC_OLDEST_ABI "$oldest_abi"
-_ACEOF
-
-fi
-
-
 # Check whether --enable-hardcoded-path-in-tests was given.
 if test "${enable_hardcoded_path_in_tests+set}" = set; then :
   enableval=$enable_hardcoded_path_in_tests; hardcoded_path_in_tests=$enableval
diff --git a/configure.ac b/configure.ac
index 794ffc2..82d0896 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,18 +151,6 @@  AC_ARG_ENABLE([profile],
 	      [profile=$enableval],
 	      [profile=no])
 
-AC_ARG_ENABLE([oldest-abi],
-	      AC_HELP_STRING([--enable-oldest-abi=ABI],
-			     [configure the oldest ABI supported @<:@e.g. 2.2@:>@ @<:@default=glibc default@:>@]),
-	      [oldest_abi=$enableval],
-	      [oldest_abi=no])
-if test "$oldest_abi" = yes || test "$oldest_abi" = no; then
-  oldest_abi=default
-else
-  AC_DEFINE_UNQUOTED(GLIBC_OLDEST_ABI, "$oldest_abi")
-fi
-AC_SUBST(oldest_abi)
-
 AC_ARG_ENABLE([hardcoded-path-in-tests],
 	      AC_HELP_STRING([--enable-hardcoded-path-in-tests],
 			     [hardcode newly built glibc path in tests @<:@default=no@:>@]),
diff --git a/csu/version.c b/csu/version.c
index b117b02..4238c2f 100644
--- a/csu/version.c
+++ b/csu/version.c
@@ -34,9 +34,6 @@  Compiled by GNU CC version "__VERSION__".\n"
 #ifdef LIBC_ABIS_STRING
 LIBC_ABIS_STRING
 #endif
-#ifdef GLIBC_OLDEST_ABI
-"The oldest ABI supported: " GLIBC_OLDEST_ABI ".\n"
-#endif
 "For bug reporting instructions, please see:\n\
 "REPORT_BUGS_TO".\n";
 
diff --git a/scripts/abi-versions.awk b/scripts/abi-versions.awk
index 06fa148..c369793 100644
--- a/scripts/abi-versions.awk
+++ b/scripts/abi-versions.awk
@@ -1,9 +1,6 @@ 
 # Script to generate <abi-versions.h> header file from Versions.all list.
 # See include/shlib-compat.h comments for explanation.
 
-# This script expects the following variables to be defined:
-# oldest_abi		the oldest ABI supported
-
 BEGIN {
   print "/* This file is automatically generated by abi-versions.awk.";
   print "   It defines symbols used by shlib-compat.h, which see.  */";
@@ -31,8 +28,6 @@  $2 == "=" {
   printf "#define ABI_%s_%s\tABI_%s_%s\n", libid, oldid, libid, newid;
   printf "#define VERSION_%s_%s\t%s\n", libid, oldid, new;
 
-  if ("GLIBC_" oldest_abi == old)
-    oldest_abi = "default";
   next;
 }
 
@@ -43,10 +38,6 @@  $2 == "=" {
 
   printf "#define ABI_%s_%s\t%d\t/* support %s */\n", libid, versid, ++n, vers;
   printf "#define VERSION_%s_%s\t%s\n", libid, versid, vers;
-  if ("GLIBC_" oldest_abi == vers)
-    start = 1;
-  if (start == 0 && oldest_abi != "default")
-    --n;
   next;
 }
 
diff --git a/scripts/soversions.awk b/scripts/soversions.awk
index dbc9059..247f061 100644
--- a/scripts/soversions.awk
+++ b/scripts/soversions.awk
@@ -27,7 +27,7 @@  END {
     if (lib in versions)
       set = versions[lib];
     else {
-      set = default_setname;
+      set = "";
       if (ndefault_set >= 1)
 	set = default_set[1];
     }
diff --git a/sysdeps/mach/hurd/configure b/sysdeps/mach/hurd/configure
index 21999f7..4248758 100644
--- a/sysdeps/mach/hurd/configure
+++ b/sysdeps/mach/hurd/configure
@@ -3,16 +3,6 @@ 
 $as_echo "#define NO_HIDDEN 1" >>confdefs.h
 
 
-case "$machine" in
-  i386*)
-    # The default oldest ABI is 2.2.6.
-    # We only need a "yes" here if the oldest ABI supported will be < 2.2.6.
-    if test "$oldest_abi" != default && test "$oldest_abi" \< "2.2.6"; then
-      libc_cv_gcc_unwind_find_fde=yes
-    fi
-    ;;
-esac
-
 
 { $as_echo "$as_me:${as_lineno-$LINENO}: checking Hurd header version" >&5
 $as_echo_n "checking Hurd header version... " >&6; }
diff --git a/sysdeps/mach/hurd/configure.ac b/sysdeps/mach/hurd/configure.ac
index 40b0743..b1f16a5 100644
--- a/sysdeps/mach/hurd/configure.ac
+++ b/sysdeps/mach/hurd/configure.ac
@@ -3,16 +3,6 @@  GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
 dnl We need this setting because of the need for PLT calls in ld.so.
 AC_DEFINE([NO_HIDDEN])
 
-case "$machine" in
-  i386*)
-    # The default oldest ABI is 2.2.6.
-    # We only need a "yes" here if the oldest ABI supported will be < 2.2.6.
-    if test "$oldest_abi" != default && test "$oldest_abi" \< "2.2.6"; then
-      libc_cv_gcc_unwind_find_fde=yes
-    fi
-    ;;
-esac
-
 AC_CACHE_CHECK(Hurd header version, libc_cv_hurd_version, [dnl
 AC_TRY_COMPILE(dnl
 [#include <hurd/version.h>], [
diff --git a/sysdeps/unix/sysv/linux/configure b/sysdeps/unix/sysv/linux/configure
index 7825ff6..ef9d425 100644
--- a/sysdeps/unix/sysv/linux/configure
+++ b/sysdeps/unix/sysv/linux/configure
@@ -148,12 +148,6 @@  fi
 
 
 
-# The result of the above test for the use of the FDE code is invalid if
-# the user overrides the decision about the minimum ABI.
-if test "$oldest_abi" != default && test "2.2.4" \< "$oldest_abi"; then
-  libc_cv_gcc_unwind_find_fde=no
-fi
-
 if test -n "$sysheaders"; then
   CPPFLAGS=$OLD_CPPFLAGS
 fi
diff --git a/sysdeps/unix/sysv/linux/configure.ac b/sysdeps/unix/sysv/linux/configure.ac
index f207c26..6738e2d 100644
--- a/sysdeps/unix/sysv/linux/configure.ac
+++ b/sysdeps/unix/sysv/linux/configure.ac
@@ -71,12 +71,6 @@  AC_CHECK_HEADER(linux/fanotify.h,
   [AC_DEFINE(HAVE_LINUX_FANOTIFY_H)], ,
   [/* No default includes.  */])
 
-# The result of the above test for the use of the FDE code is invalid if
-# the user overrides the decision about the minimum ABI.
-if test "$oldest_abi" != default && test "2.2.4" \< "$oldest_abi"; then
-  libc_cv_gcc_unwind_find_fde=no
-fi
-
 if test -n "$sysheaders"; then
   CPPFLAGS=$OLD_CPPFLAGS
 fi