[precise/lts-backport-trusty,2/2] UBUNTU: add linux-cloud-tools-lts-trusty recommends to linux-tools-lts-trusty
diff mbox

Message ID 1409335281-15180-4-git-send-email-apw@canonical.com
State New
Headers show

Commit Message

Andy Whitcroft Aug. 29, 2014, 6:01 p.m. UTC
Signed-off-by: Andy Whitcroft <apw@canonical.com>
---
 meta-source/debian/changelog         | 3 +++
 meta-source/debian/control.d/generic | 1 +
 2 files changed, 4 insertions(+)

Patch
diff mbox

diff --git a/meta-source/debian/changelog b/meta-source/debian/changelog
index 2f71430..7728d21 100644
--- a/meta-source/debian/changelog
+++ b/meta-source/debian/changelog
@@ -2,6 +2,9 @@  linux-meta-lts-trusty (3.13.0.35.31) UNRELEASED; urgency=low
 
   * added linux-cloud-tools-lts-generic to pull in the appropriate
     cloud tools on amd64 (LP: #1345059).
+  * added linux-cloud-tools-lts-generic as Recommends: on
+    linux-tools-lts-generic to simplify installation for legacy users
+    (LP: #1345059).
 
  -- Andy Whitcroft <apw@canonical.com>  Thu, 28 Aug 2014 17:17:48 +0100
 
diff --git a/meta-source/debian/control.d/generic b/meta-source/debian/control.d/generic
index c1cba78..20a3be2 100644
--- a/meta-source/debian/control.d/generic
+++ b/meta-source/debian/control.d/generic
@@ -22,6 +22,7 @@  Section: metapackages
 Priority: optional
 Provides: linux-tools
 Depends: ${misc:Depends}, linux-tools-${kernel-abi-version}-generic
+Recommends: linux-cloud-tools-generic-lts-trusty [amd64]
 Description: Generic Linux kernel tools
  This metapackage will always depend on the latest generic 14.04 LTS kernel tools
  available.