eglibc: Make configure accept make v3.9+

Submitted by Delta Tatham on Aug. 8, 2014, 7:15 p.m.

Details

Message ID 20140808191519.GA20991@fratler.de
State New
Headers show

Commit Message

Delta Tatham Aug. 8, 2014, 7:15 p.m.
eglibc configure threw an error in combination w/ make v4.0.
This patch extends the range of make-versions configure accepts.


Signed-off-by: Daniel Zauner aka Delta Tatham <delta.tatham@me.com>
---
 .../eglibc/2_18/01-configure-make-version.patch    | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 patches/eglibc/2_18/01-configure-make-version.patch

Patch hide | download patch | download mbox

diff --git a/patches/eglibc/2_18/01-configure-make-version.patch b/patches/eglibc/2_18/01-configure-make-version.patch
new file mode 100644
index 0000000..e8d46a5
--- /dev/null
+++ b/patches/eglibc/2_18/01-configure-make-version.patch
@@ -0,0 +1,22 @@ 
+--- a/configure.in	2014-08-08 20:04:48.839868771 +0200
++++ b/configure.in	2014-08-08 20:06:02.062724030 +0200
+@@ -989,7 +989,7 @@
+   critic_missing="$critic_missing gcc")
+ AC_CHECK_PROG_VER(MAKE, gnumake gmake make, --version,
+   [GNU Make[^0-9]*\([0-9][0-9.]*\)],
+-  [3.79* | 3.[89]*], critic_missing="$critic_missing make")
++  [3.79* | 3.[89]* | [4-9].* | [1-9][0-9]*], critic_missing="$critic_missing make")
+ 
+ AC_CHECK_PROG_VER(MSGFMT, gnumsgfmt gmsgfmt msgfmt, --version,
+   [GNU gettext.* \([0-9]*\.[0-9.]*\)],
+--- a/configure	2014-08-08 20:02:21.801175776 +0200
++++ b/configure	2014-08-08 20:04:30.264412865 +0200
+@@ -4772,7 +4772,7 @@
+   ac_prog_version=`$MAKE --version 2>&1 | sed -n 's/^.*GNU Make[^0-9]*\([0-9][0-9.]*\).*$/\1/p'`
+   case $ac_prog_version in
+     '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+-    3.79* | 3.[89]*)
++    3.79* | 3.[89]* | [4-9].* | [1-9][0-9]*)
+        ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+     *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+