[11/20,v3] package/libatasmart: needs libudev, not a udev daemon

Submitted by Yann E. MORIN on July 19, 2014, 1:56 p.m.

Details

Message ID ae8586b4ee9368f340c1ad6bd25577364428f249.1405777634.git.yann.morin.1998@free.fr
State Superseded
Headers show

Commit Message

Yann E. MORIN July 19, 2014, 1:56 p.m.
Do as the comment says: it's only libudev that is required.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Eric Le Bihan <eric.le.bihan.dev@free.fr>
---
 package/libatasmart/Config.in | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

Patch hide | download patch | download mbox

diff --git a/package/libatasmart/Config.in b/package/libatasmart/Config.in
index 9db3b09..e218c6d 100644
--- a/package/libatasmart/Config.in
+++ b/package/libatasmart/Config.in
@@ -1,11 +1,8 @@ 
 config BR2_PACKAGE_LIBATASMART
 	bool "libatasmart"
-	depends on BR2_PACKAGE_HAS_UDEV # libudev is configure dependency
+	depends on BR2_PACKAGE_HAS_LIBUDEV
 	help
 	  The libatasmart package is a disk reporting library.
 	  It only supports a subset of the ATA S.M.A.R.T. functionality.
 
 	  http://0pointer.de/blog/projects/being-smart.html
-
-comment "libatasmart requires udev to be enabled"
-	depends on !BR2_PACKAGE_HAS_UDEV