Patchwork [2/2] xf86-video-intel: Bump version to 2.99.912

login
register
mail settings
Submitter Ben Widawsky
Date July 18, 2014, 5:27 a.m.
Message ID <1405661249-6506-2-git-send-email-ben@bwidawsk.net>
Download mbox | patch
Permalink /patch/371343/
State Superseded
Headers show

Comments

Ben Widawsky - July 18, 2014, 5:27 a.m.
Warning: I've only built this. Not run it.

Cc: Bernd Kuhls <berndkuhls@hotmail.com>
Cc: Chris Wilson <chris@chris-wilson.co.uk>
Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
---
 package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Bernd Kuhls - July 18, 2014, 3:11 p.m.
Ben Widawsky <ben@bwidawsk.net> wrote in 
news:1405661249-6506-2-git-send-email-ben@bwidawsk.net:

> Warning: I've only built this. Not run it.
> 
> Cc: Bernd Kuhls <berndkuhls@hotmail.com>
> Cc: Chris Wilson <chris@chris-wilson.co.uk>
> Signed-off-by: Ben Widawsky <ben@bwidawsk.net>

Hi,

the OpenELEC team reverted this version bump last month, reason unknown:
https://github.com/OpenELEC/OpenELEC.tv/commit/8f4fd1a758da169c95816de4dc5c50
1fa268746c

Therefore I currently stayed away from this release, please see my patch to 
bump version to its predecessor 2.99.911[1]. I am awaiting the next release 
of this driver and will test again, so for today: NAK.

Regards, Bernd

[1] http://patchwork.ozlabs.org/patch/370975/
Ben Widawsky - July 20, 2014, 7:18 p.m.
Ping by request of patrickdp on IRC.

Note, I have a patch locally which applies to 2.99.912 (Chris' patch
only applied cleanly to master).

There are few options at this point:
1. Merge these two patches.
	This was tested before sending.
2. I can resend with the bump to 2.99.912 as the first patch, and then Chris' wiggled patch.
	I have this currently tested, and running.
3. Redo the patch for 2.99.907
	This is the most logical, but I haven't done it yet. It also
	requires two patches, one for .907, and one for .912 if update
	is desired there.
4. Wait until Chris releases 2.99.913 (or 3.0), and just bump to that.

On Thu, Jul 17, 2014 at 10:27:29PM -0700, Ben Widawsky wrote:
> Warning: I've only built this. Not run it.
> 
> Cc: Bernd Kuhls <berndkuhls@hotmail.com>
> Cc: Chris Wilson <chris@chris-wilson.co.uk>
> Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
> ---
>  package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk b/package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk
> index 787b8fa..82e6965 100644
> --- a/package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk
> +++ b/package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk
> @@ -4,7 +4,7 @@
>  #
>  ################################################################################
>  
> -XDRIVER_XF86_VIDEO_INTEL_VERSION = 2.99.907
> +XDRIVER_XF86_VIDEO_INTEL_VERSION = 2.99.912
>  XDRIVER_XF86_VIDEO_INTEL_SOURCE = xf86-video-intel-$(XDRIVER_XF86_VIDEO_INTEL_VERSION).tar.bz2
>  XDRIVER_XF86_VIDEO_INTEL_SITE = http://xorg.freedesktop.org/releases/individual/driver
>  XDRIVER_XF86_VIDEO_INTEL_LICENSE = MIT
> -- 
> 2.0.1
>
Bernd Kuhls - July 23, 2014, 6:31 p.m.
Bernd Kuhls <bernd.kuhls@t-online.de> wrote in 
news:XnsA36EAEF1EB0D1berndkuhlsPkbjNfxxIA@bernd-kuhls.de:

> Therefore I currently stayed away from this release, please see my patch to 
> bump version to its predecessor 2.99.911[1]. I am awaiting the next release 
> of this driver and will test again, so for today: NAK.

Hi,

I just tried 2.99.914 for a short test, the screen stayed black after two 
reboots, so I reverted back to 2.99.911. Currently I am lacking the time to 
debug, but I saw no obvious (dmesg, xorg.log) error messages.

Regards, Bernd
Bernd Kuhls - July 27, 2014, 8:20 p.m.
[posted and mailed]

Ben Widawsky <ben@bwidawsk.net> wrote in 
news:20140720191827.GA10208@bwidawsk.net:

> 4. Wait until Chris releases 2.99.913 (or 3.0), and just bump to that.

Hi,

after bisecting I found the patch responsible for the black screen:
http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?
id=f66e25def3431a900068cc1c23a6b1e8322ef046

Disabling __intel_open_device__pci solved the problem, I have yet to 
investigate the reason and maybe open a bugreport at freedesktop.org. After 
boot the screen stays black when starting Xorg for the first time, the second 
try works, although all kernel modules were loaded before...

So updating buildroot to 2.99.914 is ok for me now.

Regards, Bernd

Patch

diff --git a/package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk b/package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk
index 787b8fa..82e6965 100644
--- a/package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk
+++ b/package/x11r7/xdriver_xf86-video-intel/xdriver_xf86-video-intel.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-XDRIVER_XF86_VIDEO_INTEL_VERSION = 2.99.907
+XDRIVER_XF86_VIDEO_INTEL_VERSION = 2.99.912
 XDRIVER_XF86_VIDEO_INTEL_SOURCE = xf86-video-intel-$(XDRIVER_XF86_VIDEO_INTEL_VERSION).tar.bz2
 XDRIVER_XF86_VIDEO_INTEL_SITE = http://xorg.freedesktop.org/releases/individual/driver
 XDRIVER_XF86_VIDEO_INTEL_LICENSE = MIT