[1/1] UBUNTU: add -virtual flavour
diff mbox

Message ID 1402070990-4130-2-git-send-email-apw@canonical.com
State New
Headers show

Commit Message

Andy Whitcroft June 6, 2014, 4:09 p.m. UTC
Note that currently this flavour is a bit of a charade in that there
is no -extras split in the backports.  The main purpose is to drop the
unnecessary dependancy on the linux-firmware package.

Signed-off-by: Andy Whitcroft <apw@canonical.com>
---
 meta-source/debian/changelog         |  3 +++
 meta-source/debian/control.d/virtual | 37 ++++++++++++++++++++++++++++++++++++
 2 files changed, 40 insertions(+)
 create mode 100644 meta-source/debian/control.d/virtual

Comments

Brad Figg June 16, 2014, 4:32 p.m. UTC | #1
On 06/06/2014 09:09 AM, Andy Whitcroft wrote:
> Note that currently this flavour is a bit of a charade in that there
> is no -extras split in the backports.  The main purpose is to drop the
> unnecessary dependancy on the linux-firmware package.
> 
> Signed-off-by: Andy Whitcroft <apw@canonical.com>
> ---
>  meta-source/debian/changelog         |  3 +++
>  meta-source/debian/control.d/virtual | 37 ++++++++++++++++++++++++++++++++++++
>  2 files changed, 40 insertions(+)
>  create mode 100644 meta-source/debian/control.d/virtual
> 
> diff --git a/meta-source/debian/changelog b/meta-source/debian/changelog
> index a0bba93..ed6bba4 100644
> --- a/meta-source/debian/changelog
> +++ b/meta-source/debian/changelog
> @@ -3,6 +3,9 @@ linux-meta-lts-trusty (3.13.0.29.26) UNRELEASED; urgency=medium
>    * update meta package descriptions
>      Replace "13.10" with "14.04 LTS" in descriptions of Trusty packages.
>      -LP: #1324886
> +  * add a -virtual flavour pointing to the same packages as -generic
> +    but without the linux-firmware dependancies.
> +    - LP: #1327208
>  
>   -- Tim Gardner <tim.gardner@canonical.com>  Fri, 30 May 2014 14:36:40 +0200
>  
> diff --git a/meta-source/debian/control.d/virtual b/meta-source/debian/control.d/virtual
> new file mode 100644
> index 0000000..07186f8
> --- /dev/null
> +++ b/meta-source/debian/control.d/virtual
> @@ -0,0 +1,37 @@
> +Package: linux-headers-virtual-lts-trusty
> +Architecture: i386 amd64 armhf
> +Section: devel
> +Priority: optional
> +Depends: ${misc:Depends}, linux-headers-${kernel-abi-version}-generic
> +Description: Generic Linux kernel headers
> + This package will always depend on the latest virtual 14.04 LTS kernel headers
> + available.
> +
> +Package: linux-image-virtual-lts-trusty
> +Architecture: i386 amd64 armhf
> +Section: metapackages
> +Priority: optional
> +Depends: ${misc:Depends}, linux-image-${kernel-abi-version}-generic
> +Description: Generic Linux kernel image
> + This package will always depend on the latest virtual 14.04 LTS kernel image
> + available.
> +
> +Package: linux-tools-virtual-lts-trusty
> +Architecture: i386 amd64 armhf
> +Section: metapackages
> +Priority: optional
> +Provides: linux-tools
> +Depends: ${misc:Depends}, linux-tools-${kernel-abi-version}-generic
> +Description: Generic Linux kernel tools
> + This package will always depend on the latest virtual 14.04 LTS kernel tools
> + available.
> +
> +Package: linux-virtual-lts-trusty
> +Architecture: i386 amd64 armhf
> +Section: metapackages
> +Priority: optional
> +Depends: ${misc:Depends}, linux-image-virtual-lts-trusty, linux-headers-virtual-lts-trusty
> +Description: Generic Linux kernel image and headers
> + This package will always depend on the latest virtual 14.04 LTS kernel image
> + and headers packages available.
> +
>
Tim Gardner June 16, 2014, 4:56 p.m. UTC | #2
On 06/16/2014 10:32 AM, Brad Figg wrote:
> On 06/06/2014 09:09 AM, Andy Whitcroft wrote:
>> Note that currently this flavour is a bit of a charade in that there
>> is no -extras split in the backports.  The main purpose is to drop the
>> unnecessary dependancy on the linux-firmware package.
>>
>> Signed-off-by: Andy Whitcroft <apw@canonical.com>
>> ---
>>  meta-source/debian/changelog         |  3 +++
>>  meta-source/debian/control.d/virtual | 37 ++++++++++++++++++++++++++++++++++++
>>  2 files changed, 40 insertions(+)
>>  create mode 100644 meta-source/debian/control.d/virtual
>>
>> diff --git a/meta-source/debian/changelog b/meta-source/debian/changelog
>> index a0bba93..ed6bba4 100644
>> --- a/meta-source/debian/changelog
>> +++ b/meta-source/debian/changelog
>> @@ -3,6 +3,9 @@ linux-meta-lts-trusty (3.13.0.29.26) UNRELEASED; urgency=medium
>>    * update meta package descriptions
>>      Replace "13.10" with "14.04 LTS" in descriptions of Trusty packages.
>>      -LP: #1324886
>> +  * add a -virtual flavour pointing to the same packages as -generic
>> +    but without the linux-firmware dependancies.
>> +    - LP: #1327208
>>  
>>   -- Tim Gardner <tim.gardner@canonical.com>  Fri, 30 May 2014 14:36:40 +0200
>>  
>> diff --git a/meta-source/debian/control.d/virtual b/meta-source/debian/control.d/virtual
>> new file mode 100644
>> index 0000000..07186f8
>> --- /dev/null
>> +++ b/meta-source/debian/control.d/virtual
>> @@ -0,0 +1,37 @@
>> +Package: linux-headers-virtual-lts-trusty
>> +Architecture: i386 amd64 armhf
>> +Section: devel
>> +Priority: optional
>> +Depends: ${misc:Depends}, linux-headers-${kernel-abi-version}-generic
>> +Description: Generic Linux kernel headers
>> + This package will always depend on the latest virtual 14.04 LTS kernel headers
>> + available.
>> +
>> +Package: linux-image-virtual-lts-trusty
>> +Architecture: i386 amd64 armhf
>> +Section: metapackages
>> +Priority: optional
>> +Depends: ${misc:Depends}, linux-image-${kernel-abi-version}-generic
>> +Description: Generic Linux kernel image
>> + This package will always depend on the latest virtual 14.04 LTS kernel image
>> + available.
>> +
>> +Package: linux-tools-virtual-lts-trusty
>> +Architecture: i386 amd64 armhf
>> +Section: metapackages
>> +Priority: optional
>> +Provides: linux-tools
>> +Depends: ${misc:Depends}, linux-tools-${kernel-abi-version}-generic
>> +Description: Generic Linux kernel tools
>> + This package will always depend on the latest virtual 14.04 LTS kernel tools
>> + available.
>> +
>> +Package: linux-virtual-lts-trusty
>> +Architecture: i386 amd64 armhf
>> +Section: metapackages
>> +Priority: optional
>> +Depends: ${misc:Depends}, linux-image-virtual-lts-trusty, linux-headers-virtual-lts-trusty
>> +Description: Generic Linux kernel image and headers
>> + This package will always depend on the latest virtual 14.04 LTS kernel image
>> + and headers packages available.
>> +
>>
> 
> 

The bug that this meta-package patch was meant to solve was fixed in
another way. I think we really want to leave Precise as is, but should
perhaps consider an LTS virt/extras split for Trusty.

rtg

Patch
diff mbox

diff --git a/meta-source/debian/changelog b/meta-source/debian/changelog
index a0bba93..ed6bba4 100644
--- a/meta-source/debian/changelog
+++ b/meta-source/debian/changelog
@@ -3,6 +3,9 @@  linux-meta-lts-trusty (3.13.0.29.26) UNRELEASED; urgency=medium
   * update meta package descriptions
     Replace "13.10" with "14.04 LTS" in descriptions of Trusty packages.
     -LP: #1324886
+  * add a -virtual flavour pointing to the same packages as -generic
+    but without the linux-firmware dependancies.
+    - LP: #1327208
 
  -- Tim Gardner <tim.gardner@canonical.com>  Fri, 30 May 2014 14:36:40 +0200
 
diff --git a/meta-source/debian/control.d/virtual b/meta-source/debian/control.d/virtual
new file mode 100644
index 0000000..07186f8
--- /dev/null
+++ b/meta-source/debian/control.d/virtual
@@ -0,0 +1,37 @@ 
+Package: linux-headers-virtual-lts-trusty
+Architecture: i386 amd64 armhf
+Section: devel
+Priority: optional
+Depends: ${misc:Depends}, linux-headers-${kernel-abi-version}-generic
+Description: Generic Linux kernel headers
+ This package will always depend on the latest virtual 14.04 LTS kernel headers
+ available.
+
+Package: linux-image-virtual-lts-trusty
+Architecture: i386 amd64 armhf
+Section: metapackages
+Priority: optional
+Depends: ${misc:Depends}, linux-image-${kernel-abi-version}-generic
+Description: Generic Linux kernel image
+ This package will always depend on the latest virtual 14.04 LTS kernel image
+ available.
+
+Package: linux-tools-virtual-lts-trusty
+Architecture: i386 amd64 armhf
+Section: metapackages
+Priority: optional
+Provides: linux-tools
+Depends: ${misc:Depends}, linux-tools-${kernel-abi-version}-generic
+Description: Generic Linux kernel tools
+ This package will always depend on the latest virtual 14.04 LTS kernel tools
+ available.
+
+Package: linux-virtual-lts-trusty
+Architecture: i386 amd64 armhf
+Section: metapackages
+Priority: optional
+Depends: ${misc:Depends}, linux-image-virtual-lts-trusty, linux-headers-virtual-lts-trusty
+Description: Generic Linux kernel image and headers
+ This package will always depend on the latest virtual 14.04 LTS kernel image
+ and headers packages available.
+