diff mbox

[netnext-2.6] bonding: fix a parameter name in error message

Message ID 1254949168-12404-1-git-send-email-nicolas.2p.debian@free.fr
State Accepted, archived
Delegated to: David Miller
Headers show

Commit Message

Nicolas de Pesloüan Oct. 7, 2009, 8:59 p.m. UTC
When parsing module parameters, bond_check_params() erroneously use 'xor_mode'
as the name of a module parameter in an error message.

The right name for this parameter is 'xmit_hash_policy'.

Signed-off-by: Nicolas de Pesloüan <nicolas.2p.debian@free.fr>
---
 drivers/net/bonding/bond_main.c |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

Comments

David Miller Oct. 7, 2009, 9:10 p.m. UTC | #1
From: Nicolas de Pesloüan <nicolas.2p.debian@free.fr>
Date: Wed,  7 Oct 2009 22:59:27 +0200

> When parsing module parameters, bond_check_params() erroneously use 'xor_mode'
> as the name of a module parameter in an error message.
> 
> The right name for this parameter is 'xmit_hash_policy'.
> 
> Signed-off-by: Nicolas de Pesloüan <nicolas.2p.debian@free.fr>

Applied.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/net/bonding/bond_main.c b/drivers/net/bonding/bond_main.c
index 69c5b15..20dc5a2 100644
--- a/drivers/net/bonding/bond_main.c
+++ b/drivers/net/bonding/bond_main.c
@@ -4665,7 +4665,8 @@  static int bond_check_params(struct bond_params *params)
 		if ((bond_mode != BOND_MODE_XOR) &&
 		    (bond_mode != BOND_MODE_8023AD)) {
 			pr_info(DRV_NAME
-			       ": xor_mode param is irrelevant in mode %s\n",
+				": xmit_hash_policy param is irrelevant in"
+				" mode %s\n",
 			       bond_mode_name(bond_mode));
 		} else {
 			xmit_hashtype = bond_parse_parm(xmit_hash_policy,