diff mbox

[net-next-2.6] bonding: fix a parameter name in error message

Message ID 4ACA5303.1000101@free.fr
State Changes Requested, archived
Delegated to: David Miller
Headers show

Commit Message

Nicolas de Pesloüan Oct. 5, 2009, 8:11 p.m. UTC
When parsing module parameters, bond_check_params() erroneously use 'xor_mode'
as the name of a module parameter in an error message.

The right name for this parameter is 'xmit_hash_policy'.

Signed-off-by: Nicolas de Pesloüan <nicolas.2p.debian@free.fr>

---

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/net/bonding/bond_main.c b/drivers/net/bonding/bond_main.c
index 69c5b15..e061c86 100644
--- a/drivers/net/bonding/bond_main.c
+++ b/drivers/net/bonding/bond_main.c
@@ -4665,7 +4665,8 @@  static int bond_check_params(struct bond_params *params)
                 if ((bond_mode != BOND_MODE_XOR) &&
                     (bond_mode != BOND_MODE_8023AD)) {
                         pr_info(DRV_NAME
-                              ": xor_mode param is irrelevant in mode %s\n",
+                              ": xmit_hash_policy param is irrelevant in"
+                              " mode %s\n",
                                bond_mode_name(bond_mode));
                 } else {
                         xmit_hashtype = bond_parse_parm(xmit_hash_policy,