diff mbox

[1/3] xfstests: add helper for zero range support check

Message ID 20140421204023.GB960@wallace
State Not Applicable, archived
Headers show

Commit Message

Eric Whitney April 21, 2014, 8:40 p.m. UTC
Add a helper function to verify fallocate zero range support in a style
similar to _require_xfs_io_falloc_collapse(), etc.

Signed-off-by: Eric Whitney <enwlinux@gmail.com>
---
 common/rc | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Christoph Hellwig April 22, 2014, 6:28 a.m. UTC | #1
> +# check that xfs_io, kernel, and filesystem all support fallocate with zero
> +# range
> +_require_xfs_io_falloc_zero()
> +{
> +	_require_xfs_io_command "fzero"
> +}

I'd rather remove all the wrappers around _require_xfs_io_command, they
don't actually add any value.

--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Dave Chinner April 22, 2014, 9:14 a.m. UTC | #2
On Mon, Apr 21, 2014 at 11:28:16PM -0700, Christoph Hellwig wrote:
> > +# check that xfs_io, kernel, and filesystem all support fallocate with zero
> > +# range
> > +_require_xfs_io_falloc_zero()
> > +{
> > +	_require_xfs_io_command "fzero"
> > +}
> 
> I'd rather remove all the wrappers around _require_xfs_io_command, they
> don't actually add any value.

I don't really care either way, as long as all the checks are done
consistently. Send a patch to change them all... :)

Cheers,

Dave.
Christoph Hellwig April 22, 2014, 9:16 a.m. UTC | #3
On Tue, Apr 22, 2014 at 07:14:43PM +1000, Dave Chinner wrote:
> I don't really care either way, as long as all the checks are done
> consistently. Send a patch to change them all... :)

My flink test already avoids the wrapper :)

So how about we stop adding them for now at least.
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Lukas Czerner April 22, 2014, 9:28 a.m. UTC | #4
On Tue, 22 Apr 2014, Christoph Hellwig wrote:

> Date: Tue, 22 Apr 2014 02:16:20 -0700
> From: Christoph Hellwig <hch@infradead.org>
> To: Dave Chinner <david@fromorbit.com>
> Cc: Christoph Hellwig <hch@infradead.org>, linux-ext4@vger.kernel.org,
>     xfs@oss.sgi.com, Eric Whitney <enwlinux@gmail.com>
> Subject: Re: [PATCH 1/3] xfstests: add helper for zero range support check
> 
> On Tue, Apr 22, 2014 at 07:14:43PM +1000, Dave Chinner wrote:
> > I don't really care either way, as long as all the checks are done
> > consistently. Send a patch to change them all... :)
> 
> My flink test already avoids the wrapper :)
> 
> So how about we stop adding them for now at least.

I agree,

even though I screwed up when using _require_xfs_io_command with
fzero :) I think that we can avoid the wrappers and just use
_require_xfs_io_command() with the command name.

-Lukas

> 
> _______________________________________________
> xfs mailing list
> xfs@oss.sgi.com
> http://oss.sgi.com/mailman/listinfo/xfs
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Dave Chinner April 22, 2014, 9:46 a.m. UTC | #5
On Tue, Apr 22, 2014 at 11:28:31AM +0200, Lukáš Czerner wrote:
> On Tue, 22 Apr 2014, Christoph Hellwig wrote:
> 
> > Date: Tue, 22 Apr 2014 02:16:20 -0700
> > From: Christoph Hellwig <hch@infradead.org>
> > To: Dave Chinner <david@fromorbit.com>
> > Cc: Christoph Hellwig <hch@infradead.org>, linux-ext4@vger.kernel.org,
> >     xfs@oss.sgi.com, Eric Whitney <enwlinux@gmail.com>
> > Subject: Re: [PATCH 1/3] xfstests: add helper for zero range support check
> > 
> > On Tue, Apr 22, 2014 at 07:14:43PM +1000, Dave Chinner wrote:
> > > I don't really care either way, as long as all the checks are done
> > > consistently. Send a patch to change them all... :)
> > 
> > My flink test already avoids the wrapper :)
> > 
> > So how about we stop adding them for now at least.
> 
> I agree,
> 
> even though I screwed up when using _require_xfs_io_command with
> fzero :) I think that we can avoid the wrappers and just use
> _require_xfs_io_command() with the command name.

Send patches ;)

Cheers,

Dave.
diff mbox

Patch

diff --git a/common/rc b/common/rc
index acf419b..bcda96a 100644
--- a/common/rc
+++ b/common/rc
@@ -1375,6 +1375,13 @@  _require_xfs_io_falloc_collapse()
 	_require_xfs_io_command "fcollapse"
 }
 
+# check that xfs_io, kernel, and filesystem all support fallocate with zero
+# range
+_require_xfs_io_falloc_zero()
+{
+	_require_xfs_io_command "fzero"
+}
+
 # check that xfs_io, kernel and filesystem support fiemap
 _require_xfs_io_fiemap()
 {