diff mbox

vlc: avoid that AUTORECONF renames configure's arguments

Message ID 1393529854-27070-1-git-send-email-arnout@mind.be
State Accepted
Headers show

Commit Message

Arnout Vandecappelle Feb. 27, 2014, 7:37 p.m. UTC
VLC defines two autoconf functions which are also defined by our own
pkg.m4 from pkgconf. Unfortunately, they are defined in a different way:
VLC adds --enable- options, but pkg.m4 adds --with- options. To make
sure we use VLC's definition, rename these two functions from
PKG_WITH_MODULES to VLC_PKG_WITH_MODULES and from PKG_HAVE_WITH_MODULES
to VLC_PKG_HAVE_WITH_MODULES.

Note that the second function (PKG_HAVE_WITH_MODULES) is in fact
defined in exactly the same way by VLC and pkgconf, but this might no
longer be the case when either pkgconf or VLC is updated. Therefore,
that one is renamed as well.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
I propose to apply this to next but not to master - Simon's patch 02004773
has been applied to master and fixes it as well. However, that means that
02004773 has to be reverted when next is merged into master.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/vlc/vlc.mk | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comments

Simon Dawson Feb. 27, 2014, 8:09 p.m. UTC | #1
On 27 February 2014 19:37, Arnout Vandecappelle (Essensium/Mind)
<arnout@mind.be> wrote:
> VLC defines two autoconf functions which are also defined by our own
> pkg.m4 from pkgconf. Unfortunately, they are defined in a different way:
> VLC adds --enable- options, but pkg.m4 adds --with- options. To make
> sure we use VLC's definition, rename these two functions from
> PKG_WITH_MODULES to VLC_PKG_WITH_MODULES and from PKG_HAVE_WITH_MODULES
> to VLC_PKG_HAVE_WITH_MODULES.
>
> Note that the second function (PKG_HAVE_WITH_MODULES) is in fact
> defined in exactly the same way by VLC and pkgconf, but this might no
> longer be the case when either pkgconf or VLC is updated. Therefore,
> that one is renamed as well.
>
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
> I propose to apply this to next but not to master - Simon's patch 02004773
> has been applied to master and fixes it as well. However, that means that
> 02004773 has to be reverted when next is merged into master.
>
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
>  package/vlc/vlc.mk | 11 +++++++++++
>  1 file changed, 11 insertions(+)
>
> diff --git a/package/vlc/vlc.mk b/package/vlc/vlc.mk
> index 923439d..5727193 100644
> --- a/package/vlc/vlc.mk
> +++ b/package/vlc/vlc.mk
> @@ -12,6 +12,17 @@ VLC_LICENSE_FILES = COPYING COPYING.LIB
>  VLC_DEPENDENCIES = host-pkgconf
>  VLC_AUTORECONF = YES
>
> +# VLC defines two autoconf functions which are also defined by our own pkg.m4
> +# from pkgconf. Unfortunately, they are defined in a different way: VLC adds
> +# --enable- options, but pkg.m4 adds --with- options. To make sure we use
> +# VLC's definition, rename these two functions.
> +define VLC_OVERRIDE_PKG_M4
> +       $(SED) 's/PKG_WITH_MODULES/VLC_PKG_WITH_MODULES/g' \
> +               -e 's/PKG_HAVE_WITH_MODULES/VLC_PKG_HAVE_WITH_MODULES/g' \
> +               $(@D)/configure.ac $(@D)/m4/with_pkg.m4
> +endef
> +VLC_POST_PATCH_HOOKS += VLC_OVERRIDE_PKG_M4
> +
>  VLC_CONF_OPT += \
>         --disable-a52 \
>         --disable-shout \
> --
> 1.9.0

Nice lateral thinking; and I like that we now have explicit commentary
in the package makefile, to document the weirdness.

Acked-by: Simon Dawson <spdawson@gmail.com>
Tested-by: Simon Dawson <spdawson@gmail.com>
Thomas Petazzoni March 1, 2014, 1:54 p.m. UTC | #2
Arnout,

On Thu, 27 Feb 2014 20:37:34 +0100, Arnout Vandecappelle
(Essensium/Mind) wrote:
> VLC defines two autoconf functions which are also defined by our own
> pkg.m4 from pkgconf. Unfortunately, they are defined in a different way:
> VLC adds --enable- options, but pkg.m4 adds --with- options. To make
> sure we use VLC's definition, rename these two functions from
> PKG_WITH_MODULES to VLC_PKG_WITH_MODULES and from PKG_HAVE_WITH_MODULES
> to VLC_PKG_HAVE_WITH_MODULES.
> 
> Note that the second function (PKG_HAVE_WITH_MODULES) is in fact
> defined in exactly the same way by VLC and pkgconf, but this might no
> longer be the case when either pkgconf or VLC is updated. Therefore,
> that one is renamed as well.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
> I propose to apply this to next but not to master - Simon's patch 02004773
> has been applied to master and fixes it as well. However, that means that
> 02004773 has to be reverted when next is merged into master.

Thanks, patch applied, after reverting 02004773. Please let me know if
the revert was correct, as there was a minor conflict with some udev
related changes.

Thanks,

Thomas
Arnout Vandecappelle March 3, 2014, 6:42 a.m. UTC | #3
On 01/03/14 14:54, Thomas Petazzoni wrote:
> Arnout,
> 
> On Thu, 27 Feb 2014 20:37:34 +0100, Arnout Vandecappelle
> (Essensium/Mind) wrote:
>> VLC defines two autoconf functions which are also defined by our own
>> pkg.m4 from pkgconf. Unfortunately, they are defined in a different way:
>> VLC adds --enable- options, but pkg.m4 adds --with- options. To make
>> sure we use VLC's definition, rename these two functions from
>> PKG_WITH_MODULES to VLC_PKG_WITH_MODULES and from PKG_HAVE_WITH_MODULES
>> to VLC_PKG_HAVE_WITH_MODULES.
>>
>> Note that the second function (PKG_HAVE_WITH_MODULES) is in fact
>> defined in exactly the same way by VLC and pkgconf, but this might no
>> longer be the case when either pkgconf or VLC is updated. Therefore,
>> that one is renamed as well.
>>
>> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
>> ---
>> I propose to apply this to next but not to master - Simon's patch 02004773
>> has been applied to master and fixes it as well. However, that means that
>> 02004773 has to be reverted when next is merged into master.
> 
> Thanks, patch applied, after reverting 02004773. Please let me know if
> the revert was correct, as there was a minor conflict with some udev
> related changes.

 Looks good to me. Autobuilders will tell us if it's not.

 Regards,
 Arnout
diff mbox

Patch

diff --git a/package/vlc/vlc.mk b/package/vlc/vlc.mk
index 923439d..5727193 100644
--- a/package/vlc/vlc.mk
+++ b/package/vlc/vlc.mk
@@ -12,6 +12,17 @@  VLC_LICENSE_FILES = COPYING COPYING.LIB
 VLC_DEPENDENCIES = host-pkgconf
 VLC_AUTORECONF = YES
 
+# VLC defines two autoconf functions which are also defined by our own pkg.m4
+# from pkgconf. Unfortunately, they are defined in a different way: VLC adds
+# --enable- options, but pkg.m4 adds --with- options. To make sure we use
+# VLC's definition, rename these two functions.
+define VLC_OVERRIDE_PKG_M4
+	$(SED) 's/PKG_WITH_MODULES/VLC_PKG_WITH_MODULES/g' \
+		-e 's/PKG_HAVE_WITH_MODULES/VLC_PKG_HAVE_WITH_MODULES/g' \
+		$(@D)/configure.ac $(@D)/m4/with_pkg.m4
+endef
+VLC_POST_PATCH_HOOKS += VLC_OVERRIDE_PKG_M4
+
 VLC_CONF_OPT += \
 	--disable-a52 \
 	--disable-shout \