Patchwork [5/9] rsxx: Use pci_enable_msix_range() instead of pci_enable_msix()

login
register
mail settings
Submitter Alexander Gordeev
Date Feb. 19, 2014, 8:58 a.m.
Message ID <884e8e236ae1e7223230ee0de75f2f01817140cf.1392799751.git.agordeev@redhat.com>
Download mbox | patch
Permalink /patch/321786/
State Not Applicable
Headers show

Comments

Alexander Gordeev - Feb. 19, 2014, 8:58 a.m.
As result of deprecation of MSI-X/MSI enablement functions
pci_enable_msix() and pci_enable_msi_block() all drivers
using these two interfaces need to be updated to use the
new pci_enable_msi_range() and pci_enable_msix_range()
interfaces.

Signed-off-by: Alexander Gordeev <agordeev@redhat.com>
Cc: Joshua Morris <josh.h.morris@us.ibm.com>
Cc: Philip Kelleher <pjk1939@linux.vnet.ibm.com>
Cc: linux-pci@vger.kernel.org
---
 drivers/block/rsxx/core.c |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/drivers/block/rsxx/core.c b/drivers/block/rsxx/core.c
index a8de2ee..76c8124 100644
--- a/drivers/block/rsxx/core.c
+++ b/drivers/block/rsxx/core.c
@@ -880,8 +880,8 @@  static int rsxx_pci_probe(struct pci_dev *dev,
 	spin_unlock_irq(&card->irq_lock);
 
 	if (!force_legacy) {
-		st = pci_enable_msi(dev);
-		if (st)
+		st = pci_enable_msi_range(dev, 1, 1);
+		if (st < 0)
 			dev_warn(CARD_TO_DEV(card),
 				"Failed to enable MSI\n");
 	}