Patchwork [1/4] luajit: refactor without dont-strip.patch

login
register
mail settings
Submitter Francois Perrad
Date Jan. 23, 2014, 8:28 a.m.
Message ID <1390465713-12600-1-git-send-email-francois.perrad@gadz.org>
Download mbox | patch
Permalink /patch/313470/
State Superseded, archived
Headers show

Comments

Francois Perrad - Jan. 23, 2014, 8:28 a.m.
the variable TARGET_STRIP does the job

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/luajit/luajit-03-dont-strip.patch |   23 -----------------------
 package/luajit/luajit.mk                  |    2 +-
 2 files changed, 1 insertion(+), 24 deletions(-)
 delete mode 100644 package/luajit/luajit-03-dont-strip.patch
Thomas Petazzoni - Feb. 27, 2014, 10:59 p.m.
Dear Francois Perrad,

On Thu, 23 Jan 2014 09:28:30 +0100, Francois Perrad wrote:
> the variable TARGET_STRIP does the job
> 
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  package/luajit/luajit-03-dont-strip.patch |   23 -----------------------
>  package/luajit/luajit.mk                  |    2 +-
>  2 files changed, 1 insertion(+), 24 deletions(-)
>  delete mode 100644 package/luajit/luajit-03-dont-strip.patch

Looks good to me. Just a question below.


> +		TARGET_STRIP=@: \

Any reason to use @: instead of just : ?

Also, personally, I would probably prefer TARGET_STRIP=true. I know
it's the same, but I find the usage of ':' a bit hard to read.

Thomas
Francois Perrad - Feb. 28, 2014, 12:40 a.m.
2014-02-27 23:59 GMT+01:00 Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>:
> Dear Francois Perrad,
>
> On Thu, 23 Jan 2014 09:28:30 +0100, Francois Perrad wrote:
>> the variable TARGET_STRIP does the job
>>
>> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
>> ---
>>  package/luajit/luajit-03-dont-strip.patch |   23 -----------------------
>>  package/luajit/luajit.mk                  |    2 +-
>>  2 files changed, 1 insertion(+), 24 deletions(-)
>>  delete mode 100644 package/luajit/luajit-03-dont-strip.patch
>
> Looks good to me. Just a question below.
>
>
>> +             TARGET_STRIP=@: \
>
> Any reason to use @: instead of just : ?
>

I've seen this value in the Makefile at
http://repo.or.cz/w/luajit-2.0.git/blob/HEAD:/src/Makefile#l354
so I copy/paste it.

Fran├žois

> Also, personally, I would probably prefer TARGET_STRIP=true. I know
> it's the same, but I find the usage of ':' a bit hard to read.
>
> Thomas
> --
> Thomas Petazzoni, CTO, Free Electrons
> Embedded Linux, Kernel and Android engineering
> http://free-electrons.com
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot

Patch

diff --git a/package/luajit/luajit-03-dont-strip.patch b/package/luajit/luajit-03-dont-strip.patch
deleted file mode 100644
index 66bdadf..0000000
--- a/package/luajit/luajit-03-dont-strip.patch
+++ /dev/null
@@ -1,23 +0,0 @@ 
-Don't strip the library and binary
-
-This allows Buildroot to do it if needed, but only if needed.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/src/Makefile
-===================================================================
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -665,12 +665,10 @@
- $(LUAJIT_SO): $(LJVMCORE_O)
- 	$(E) "DYNLINK   $@"
- 	$(Q)$(TARGET_LD) $(TARGET_ASHLDFLAGS) -o $@ $(LJVMCORE_DYNO) $(TARGET_ALIBS)
--	$(Q)$(TARGET_STRIP) $@
- 
- $(LUAJIT_T): $(TARGET_O) $(LUAJIT_O) $(TARGET_DEP)
- 	$(E) "LINK      $@"
- 	$(Q)$(TARGET_LD) $(TARGET_ALDFLAGS) -o $@ $(LUAJIT_O) -lluajit -L. $(TARGET_ALIBS)
--	$(Q)$(TARGET_STRIP) $@
- 	$(E) "OK        Successfully built LuaJIT"
- 
- ##############################################################################
diff --git a/package/luajit/luajit.mk b/package/luajit/luajit.mk
index 529d3c2..186b3fd 100644
--- a/package/luajit/luajit.mk
+++ b/package/luajit/luajit.mk
@@ -37,7 +37,7 @@  define LUAJIT_BUILD_CMDS
 		DYNAMIC_CC="$(TARGET_CC) -fPIC" \
 		TARGET_LD="$(TARGET_CC)" \
 		TARGET_AR="$(TARGET_AR) rcus" \
-		TARGET_STRIP="$(TARGET_STRIP)" \
+		TARGET_STRIP=@: \
 		TARGET_CFLAGS="$(TARGET_CFLAGS)" \
 		TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
 		HOST_CC="$(LUAJIT_HOST_CC)" \