[053/131] libusb-compat: Add backwards compatibility. Remove in next major release

Submitted by christian.braunersorensen@prevas.dk on Jan. 14, 2014, 12:33 p.m.

Details

Message ID 9fc8e9948ad41393f6c17bafcdd273239bbef7aa.1389702652.git.christian.braunersorensen@prevas.dk
State Accepted
Delegated to: Esben Haabendal
Headers show

Commit Message

christian.braunersorensen@prevas.dk Jan. 14, 2014, 12:33 p.m.
From: Christian Sørensen <christian.braunersorensen@prevas.dk>

Signed-off-by: Christian Sørensen <christian.braunersorensen@prevas.dk>
---
 recipes/libusb/libusb-compat_0.1.5.oe | 5 +++++
 1 file changed, 5 insertions(+)

Patch hide | download patch | download mbox

diff --git a/recipes/libusb/libusb-compat_0.1.5.oe b/recipes/libusb/libusb-compat_0.1.5.oe
index fdaf0ac..ebe2f5f 100644
--- a/recipes/libusb/libusb-compat_0.1.5.oe
+++ b/recipes/libusb/libusb-compat_0.1.5.oe
@@ -17,3 +17,8 @@  DEPENDS_${PN} += "libusb-1.0 libpthread"
 
 LIBRARY_NAME = "libusb-0.1"
 LIBRARY_VERSION = "4"
+
+#To be removed in next base master release!
+PROVIDES_${PN} += "libusb0"
+PROVIDES_${PN}-dev += "libusb0-dev"
+PROVIDES_${PN}[qa] += "allow-missing-soname:libusb0"