Patchwork docs: qcow2 compat=1.1 is now the default

login
register
mail settings
Submitter Stefan Hajnoczi
Date Jan. 6, 2014, 4:39 a.m.
Message ID <1388983141-19178-1-git-send-email-stefanha@redhat.com>
Download mbox | patch
Permalink /patch/307103/
State New
Headers show

Comments

Stefan Hajnoczi - Jan. 6, 2014, 4:39 a.m.
Commit 9117b47717ad208b12786ce88eacb013f9b3dd1c ("qcow2: Change default
for new images to compat=1.1") changed the default qcow2 image format
version but forgot to update qemu-doc.texi and qemu-img.texi.

Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
---
 qemu-doc.texi | 8 ++++----
 qemu-img.texi | 8 ++++----
 2 files changed, 8 insertions(+), 8 deletions(-)
Eric Blake - Jan. 6, 2014, 1:17 p.m.
On 01/05/2014 09:39 PM, Stefan Hajnoczi wrote:
> Commit 9117b47717ad208b12786ce88eacb013f9b3dd1c ("qcow2: Change default
> for new images to compat=1.1") changed the default qcow2 image format
> version but forgot to update qemu-doc.texi and qemu-img.texi.
> 
> Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
> ---
>  qemu-doc.texi | 8 ++++----
>  qemu-img.texi | 8 ++++----
>  2 files changed, 8 insertions(+), 8 deletions(-)

Reviewed-by: Eric Blake <eblake@redhat.com>
Kevin Wolf - Jan. 7, 2014, 5:09 p.m.
Am 06.01.2014 um 14:17 hat Eric Blake geschrieben:
> On 01/05/2014 09:39 PM, Stefan Hajnoczi wrote:
> > Commit 9117b47717ad208b12786ce88eacb013f9b3dd1c ("qcow2: Change default
> > for new images to compat=1.1") changed the default qcow2 image format
> > version but forgot to update qemu-doc.texi and qemu-img.texi.
> > 
> > Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
> > ---
> >  qemu-doc.texi | 8 ++++----
> >  qemu-img.texi | 8 ++++----
> >  2 files changed, 8 insertions(+), 8 deletions(-)
> 
> Reviewed-by: Eric Blake <eblake@redhat.com>

Thanks, applied to the block branch.

Kevin

Patch

diff --git a/qemu-doc.texi b/qemu-doc.texi
index 185dd47..94681e1 100644
--- a/qemu-doc.texi
+++ b/qemu-doc.texi
@@ -536,11 +536,11 @@  support of multiple VM snapshots.
 Supported options:
 @table @code
 @item compat
-Determines the qcow2 version to use. @code{compat=0.10} uses the traditional
-image format that can be read by any QEMU since 0.10 (this is the default).
+Determines the qcow2 version to use. @code{compat=0.10} uses the
+traditional image format that can be read by any QEMU since 0.10.
 @code{compat=1.1} enables image format extensions that only QEMU 1.1 and
-newer understand. Amongst others, this includes zero clusters, which allow
-efficient copy-on-read for sparse images.
+newer understand (this is the default). Amongst others, this includes
+zero clusters, which allow efficient copy-on-read for sparse images.
 
 @item backing_file
 File name of a base image (see @option{create} subcommand)
diff --git a/qemu-img.texi b/qemu-img.texi
index be31191..62ed58c 100644
--- a/qemu-img.texi
+++ b/qemu-img.texi
@@ -391,11 +391,11 @@  support of multiple VM snapshots.
 Supported options:
 @table @code
 @item compat
-Determines the qcow2 version to use. @code{compat=0.10} uses the traditional
-image format that can be read by any QEMU since 0.10 (this is the default).
+Determines the qcow2 version to use. @code{compat=0.10} uses the
+traditional image format that can be read by any QEMU since 0.10.
 @code{compat=1.1} enables image format extensions that only QEMU 1.1 and
-newer understand. Amongst others, this includes zero clusters, which allow
-efficient copy-on-read for sparse images.
+newer understand (this is the default). Amongst others, this includes zero
+clusters, which allow efficient copy-on-read for sparse images.
 
 @item backing_file
 File name of a base image (see @option{create} subcommand)