Patchwork [1/1] UBUNTU: [Debian] Improve tools version message

login
register
mail settings
Submitter Andy Whitcroft
Date Dec. 5, 2013, 6:14 p.m.
Message ID <1386267244-9366-1-git-send-email-apw@canonical.com>
Download mbox | patch
Permalink /patch/297344/
State New
Headers show

Comments

Andy Whitcroft - Dec. 5, 2013, 6:14 p.m.
Signed-off-by: Andy Whitcroft <apw@canonical.com>
---
 debian/tools/generic | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
Tim Gardner - Dec. 5, 2013, 6:26 p.m.
Works for me.
Tim Gardner - Dec. 9, 2013, 2:49 p.m.
On 12/05/2013 11:26 AM, Tim Gardner wrote:
> Works for me.
>

Patch

diff --git a/debian/tools/generic b/debian/tools/generic
index 4aa5649..dd43210 100644
--- a/debian/tools/generic
+++ b/debian/tools/generic
@@ -26,5 +26,12 @@  fi
 
 # Give them a hint as to what to install.
 echo "`basename $0` not found for kernel $version" >&2
-echo "You may need to install linux-tools-$version-$flavour" >&2
+if dpkg --compare-versions "$full_version" lt "3.11.0"; then
+	flavour=''
+else
+	flavour="-$flavour"
+fi
+echo "You may need to install linux-tools-$version$flavour for this kernel." >&2
+echo "You may also wish to install linux-tools$flavour or" >&2
+echo "linux-image$flavour-lts-<series> to keep up to date." >&2
 exit 2