Bug#727756: qemu: Broken -smb with latest SAMBA package. (Unsupported security=share option)

Submitted by Michael Büsch on Nov. 1, 2013, 9:54 a.m.

Details

Message ID 20131101105432.5f45f689@wiggum
State New
Headers show

Commit Message

Michael Büsch Nov. 1, 2013, 9:54 a.m.
On Fri, 01 Nov 2013 13:32:49 +0400
Michael Tokarev <mjt@tls.msk.ru> wrote:

> That looks right.  Are you okay adding your Signed-off-by to the patch
> you initially submitted?  If yes, I'll make a formal patch submission
> upstream.

Here you go.

Patch hide | download patch | download mbox

From: Michael Buesch <m@bues.ch>
Subject: [PATCH] qemu/slirp: Fix SMB security configuration on newer samba versions

The smb.conf automatically generated by qemu's -smb option fails on current
samba, because smbd rejects the security=share option with the following warning:

>   WARNING: Ignoring invalid value 'share' for parameter 'security'  

Which makes it fall back to security=user without guest login.
This results in being unable to login to the samba server from the guest OS.

This fixes it by selecting 'user' explicitly and mapping
unknown users to guest logins.

Signed-off-by: Michael Buesch <m@bues.ch>

---

Index: qemu-1.6.0+dfsg/net/slirp.c
===================================================================
--- qemu-1.6.0+dfsg.orig/net/slirp.c
+++ qemu-1.6.0+dfsg/net/slirp.c
@@ -529,7 +529,8 @@  static int slirp_smb(SlirpState* s, cons
             "state directory=%s\n"
             "log file=%s/log.smbd\n"
             "smb passwd file=%s/smbpasswd\n"
-            "security = share\n"
+            "security = user\n"
+            "map to guest = Bad User\n"
             "[qemu]\n"
             "path=%s\n"
             "read only=no\n"