poppler: needs thread support
diff mbox

Message ID 1381734892.13723.0.camel@phoenix
State Accepted
Commit 5e0613aa8eadf16383410eb764f10ca99e549fb8
Headers show

Commit Message

Axel Lin Oct. 14, 2013, 7:14 a.m. UTC
Fix:
http://autobuild.buildroot.net/results/daa/daa18f112ddd08644b4149025899cea2b511a9da/

Signed-off-by: Axel Lin <axel.lin@ingics.com>
---
 package/poppler/Config.in | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Oct. 14, 2013, 11:50 a.m. UTC | #1
>>>>> "Axel" == Axel Lin <axel.lin@ingics.com> writes:

 Axel> Fix:
 Axel> http://autobuild.buildroot.net/results/daa/daa18f112ddd08644b4149025899cea2b511a9da/

Committed, thanks.

Patch
diff mbox

diff --git a/package/poppler/Config.in b/package/poppler/Config.in
index 6a9e1fd..876601e 100644
--- a/package/poppler/Config.in
+++ b/package/poppler/Config.in
@@ -1,6 +1,7 @@ 
 config BR2_PACKAGE_POPPLER
 	bool "poppler"
 	depends on BR2_INSTALL_LIBSTDCPP
+	depends on BR2_TOOLCHAIN_HAS_THREADS
 	select BR2_PACKAGE_FONTCONFIG
 	select BR2_PACKAGE_XLIB_LIBX11 if BR2_PACKAGE_XORG7
 	select BR2_PACKAGE_XLIB_LIBXEXT if BR2_PACKAGE_XORG7
@@ -9,5 +10,5 @@  config BR2_PACKAGE_POPPLER
 
 	   http://poppler.freedesktop.org/
 
-comment "poppler requires a toolchain with C++ support enabled"
-	depends on !BR2_INSTALL_LIBSTDCPP
+comment "poppler requires a toolchain with C++ and thread support enabled"
+	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS