Patchwork [04/12] package/uclibc: ARM OABI is no longer supported

login
register
mail settings
Submitter Yann E. MORIN
Date July 6, 2013, 8:48 p.m.
Message ID <e6a7a3fba7677d056f6b81acdd2b067374a686e0.1373143368.git.yann.morin.1998@free.fr>
Download mbox | patch
Permalink /patch/257306/
State Accepted
Commit d854bd531e67b37929203c4a33acf907c9b88eb1
Headers show

Comments

Yann E. MORIN - July 6, 2013, 8:48 p.m.
From: "Yann E. MORIN" <yann.morin.1998@free.fr>

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/uclibc/Config.in | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Patch

diff --git a/package/uclibc/Config.in b/package/uclibc/Config.in
index e508342..b9917a7 100644
--- a/package/uclibc/Config.in
+++ b/package/uclibc/Config.in
@@ -90,7 +90,7 @@  config BR2_TOOLCHAIN_BUILDROOT_LOCALE
 
 choice
 	prompt "Thread library implementation"
-	default BR2_PTHREADS_NATIVE if !BR2_ARM_OABI && !(BR2_avr32 || BR2_xtensa)
+	default BR2_PTHREADS_NATIVE if !(BR2_avr32 || BR2_xtensa)
 	default BR2_PTHREADS_OLD
 	help
 	  Use this option to select the thread library implementation
@@ -114,7 +114,6 @@  choice
 	config BR2_PTHREADS_NATIVE
 		bool "Native POSIX Threading (NPTL)"
 		select BR2_TOOLCHAIN_HAS_THREADS
-		depends on !BR2_ARM_OABI
 		depends on !BR2_x86_i386
 		depends on !BR2_avr32
 		depends on !BR2_xtensa
@@ -186,7 +185,6 @@  config BR2_UCLIBC_ARM_TYPE
 config BR2_UCLIBC_ARM_ABI
 	string
 	depends on BR2_UCLIBC_TARGET_ARCH = "arm"
-	default OABI if BR2_ARM_OABI
 	default EABI if BR2_ARM_EABI
 
 config BR2_UCLIBC_ARM_BX