Patchwork cc/gcc: update Linaro GCC revisions for 2013.06

login
register
mail settings
Submitter Marcelo Gutierrez
Date June 29, 2013, 6:39 p.m.
Message ID <CANmu-OOKQJT9_2nyMu1jNAu+yLneW4hZ_mJw7Aw_OesTq1T6wA@mail.gmail.com>
Download mbox | patch
Permalink /patch/255755/
State Not Applicable
Headers show

Comments

Marcelo Gutierrez - June 29, 2013, 6:39 p.m.
Did you try to compile "linaro-4.7-2013.06-1"? Because I did, and  I'm
getting this issue:
https://bugs.launchpad.net/gcc-linaro/+bug/1129013

Linaro-4.7-2013.06 works fine.





>
> # HG changeset patch
> # User "Michael Hope <michaelh@juju.net.nz>"
> # Date 1372451034 -7200
> # Node ID 83e33862f7641c2ad3267a0d17e9680be3825039
> # Parent  2685dfa9de14fbe356ba76cb201bf5c039cf6860
> cc/gcc: update Linaro GCC revisions for 2013.06
>
> Update Linaro GCC with the latest available revisions.
>
> Also updates Linaro GCC 4.6 to the final version.
>
> Signed-off-by: "Michael Hope" <michaelh@juju.net.nz>
>
> diff -r 2685dfa9de14 -r 83e33862f764 config/cc/gcc.in
> --- a/config/cc/gcc.in	Thu May 23 17:51:15 2013 +0200
> +++ b/config/cc/gcc.in	Fri Jun 28 22:23:54 2013 +0200
> @@ -38,7 +38,7 @@
>
>  config CC_V_linaro_4_8
>      bool
> -    prompt "linaro-4.8-2013.04"
> +    prompt "linaro-4.8-2013.06-1"
>      depends on CC_GCC_SHOW_LINARO
>      select CC_GCC_4_8
>
> @@ -49,7 +49,7 @@
>
>  config CC_V_linaro_4_7
>      bool
> -    prompt "linaro-4.7-2013.04"
> +    prompt "linaro-4.7-2013.06-1"
>      depends on CC_GCC_SHOW_LINARO
>      select CC_GCC_4_7
>
> @@ -75,7 +75,7 @@
>
>  config CC_V_linaro_4_6
>      bool
> -    prompt "linaro-4.6-2013.04"
> +    prompt "linaro-4.6-2013.05"
>      depends on CC_GCC_SHOW_LINARO
>      select CC_GCC_4_6
>
> @@ -440,14 +440,14 @@
>      string
>  # Don't remove next line
>  # CT_INSERT_VERSION_STRING_BELOW
> -    default "linaro-4.8-2013.04" if CC_V_linaro_4_8
> +    default "linaro-4.8-2013.06-1" if CC_V_linaro_4_8
>      default "4.8.0" if CC_V_4_8_0
> -    default "linaro-4.7-2013.04" if CC_V_linaro_4_7
> +    default "linaro-4.7-2013.06-1" if CC_V_linaro_4_7
>      default "4.7.3" if CC_V_4_7_3
>      default "4.7.2" if CC_V_4_7_2
>      default "4.7.1" if CC_V_4_7_1
>      default "4.7.0" if CC_V_4_7_0
> -    default "linaro-4.6-2013.04" if CC_V_linaro_4_6
> +    default "linaro-4.6-2013.05" if CC_V_linaro_4_6
>      default "4.6.4" if CC_V_4_6_4
>      default "4.6.3" if CC_V_4_6_3
>      default "4.6.2" if CC_V_4_6_2

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Patch

diff -r 2685dfa9de14 -r 83e33862f764 config/cc/gcc.in
--- a/config/cc/gcc.in	Thu May 23 17:51:15 2013 +0200
+++ b/config/cc/gcc.in	Fri Jun 28 22:23:54 2013 +0200
@@ -38,7 +38,7 @@ 

 config CC_V_linaro_4_8
     bool
-    prompt "linaro-4.8-2013.04"
+   prompt "linaro-4.8-2013.06-1"
     depends on CC_GCC_SHOW_LINARO
     select CC_GCC_4_8

@@ -49,7 +49,7 @@ 

 config CC_V_linaro_4_7
     bool
-    prompt "linaro-4.7-2013.04"
+   prompt "linaro-4.7-2013.06"
     depends on CC_GCC_SHOW_LINARO
     select CC_GCC_4_7

@@ -75,7 +75,7 @@ 

 config CC_V_linaro_4_6
     bool
-    prompt "linaro-4.6-2013.04"
+   prompt "linaro-4.6-2013.05"
     depends on CC_GCC_SHOW_LINARO
     select CC_GCC_4_6

@@ -440,14 +440,14 @@ 
     string
 # Don't remove next line
 # CT_INSERT_VERSION_STRING_BELOW
-    default "linaro-4.8-2013.04" if CC_V_linaro_4_8
+   default "linaro-4.8-2013.06-1" if CC_V_linaro_4_8
     default "4.8.0" if CC_V_4_8_0
-    default "linaro-4.7-2013.04" if CC_V_linaro_4_7
+   default "linaro-4.7-2013.06" if CC_V_linaro_4_7
     default "4.7.3" if CC_V_4_7_3
     default "4.7.2" if CC_V_4_7_2
     default "4.7.1" if CC_V_4_7_1
     default "4.7.0" if CC_V_4_7_0
-    default "linaro-4.6-2013.04" if CC_V_linaro_4_6
+   default "linaro-4.6-2013.05" if CC_V_linaro_4_6
     default "4.6.4" if CC_V_4_6_4
     default "4.6.3" if CC_V_4_6_3
     default "4.6.2" if CC_V_4_6_2