Patchwork [v2] pulseaudio : bump to version 4.0

login
register
mail settings
Submitter Jeremy Rosen
Date June 10, 2013, 7:56 a.m.
Message ID <1370850974-7849-1-git-send-email-jeremy.rosen@openwide.fr>
Download mbox | patch
Permalink /patch/250187/
State Accepted
Headers show

Comments

Jeremy Rosen - June 10, 2013, 7:56 a.m.
removes a patch that was integrated upstream

Signed-off-by: Jérémy Rosen <jeremy.rosen@openwide.fr>
--
v2 : add license information
     remove dependency on gtk2 since upstream only supports gtk3
---
 .../pulseaudio-compat-with-json-c-0.11.patch       |   26 --------------------
 package/multimedia/pulseaudio/pulseaudio.mk        |   15 +++--------
 2 files changed, 3 insertions(+), 38 deletions(-)
 delete mode 100644 package/multimedia/pulseaudio/pulseaudio-compat-with-json-c-0.11.patch
Peter Korsgaard - June 10, 2013, 12:35 p.m.
>>>>> "Jérémy" == Jérémy Rosen <jeremy.rosen@openwide.fr> writes:

 Jérémy> removes a patch that was integrated upstream
 Jérémy> Signed-off-by: Jérémy Rosen <jeremy.rosen@openwide.fr>
 Jérémy> --
 Jérémy> v2 : add license information
 Jérémy>      remove dependency on gtk2 since upstream only supports gtk3
 Jérémy> ---
 Jérémy>  .../pulseaudio-compat-with-json-c-0.11.patch       |   26 --------------------
 Jérémy>  package/multimedia/pulseaudio/pulseaudio.mk        |   15 +++--------
 Jérémy>  2 files changed, 3 insertions(+), 38 deletions(-)
 Jérémy>  delete mode 100644 package/multimedia/pulseaudio/pulseaudio-compat-with-json-c-0.11.patch

 Jérémy> diff --git a/package/multimedia/pulseaudio/pulseaudio-compat-with-json-c-0.11.patch b/package/multimedia/pulseaudio/pulseaudio-compat-with-json-c-0.11.patch
 Jérémy> deleted file mode 100644
 Jérémy> index 86efdfd..0000000
 Jérémy> --- a/package/multimedia/pulseaudio/pulseaudio-compat-with-json-c-0.11.patch
 Jérémy> +++ /dev/null
 Jérémy> @@ -1,26 +0,0 @@
 Jérémy> -From 759c0bc6f990240287a14fa6dec029ecea581463 Mon Sep 17 00:00:00 2001
 Jérémy> -From: Arun Raghavan <arun.raghavan@collabora.co.uk>
 Jérémy> -Date: Sat, 27 Apr 2013 03:27:05 +0000
 Jérémy> -Subject: build-sys: json-c changed everything :(
 Jérémy> -
 Jérémy> -json-c 0.11 ships a pkg-config file with a different name, and changes
 Jérémy> -the name of its library as well.
 Jérémy> ----
 Jérémy> -(limited to 'configure.ac')
 Jérémy> -
 Jérémy> -diff --git a/configure.ac b/configure.ac
 Jérémy> -index c8161a4..b1bd21a 100644
 Jérémy> ---- a/configure.ac
 Jérémy> -+++ b/configure.ac
 Jérémy> -@@ -624,7 +624,8 @@ AM_CONDITIONAL([HAVE_TESTS], [test "x$HAVE_LIBCHECK" = x1])
 Jérémy> - 
 Jérémy> - #### json parsing ####
 Jérémy> - 
 Jérémy> --PKG_CHECK_MODULES(LIBJSON, [ json >= 0.9 ])
 Jérémy> -+PKG_CHECK_MODULES(LIBJSON, [ json-c >= 0.11 ], [],
 Jérémy> -+		  [PKG_CHECK_MODULES(LIBJSON, [ json >= 0.9 ])])
 Jérémy> - AC_SUBST(LIBJSON_CFLAGS)
 Jérémy> - AC_SUBST(LIBJSON_LIBS)
 Jérémy> - 
 Jérémy> ---
 Jérémy> -cgit v0.9.0.2-2-gbebe
 Jérémy> diff --git a/package/multimedia/pulseaudio/pulseaudio.mk b/package/multimedia/pulseaudio/pulseaudio.mk
 Jérémy> index c789fc8..24a4ef4 100644
 Jérémy> --- a/package/multimedia/pulseaudio/pulseaudio.mk
 Jérémy> +++ b/package/multimedia/pulseaudio/pulseaudio.mk
 Jérémy> @@ -4,9 +4,11 @@
 Jérémy>  #
 Jérémy>  ################################################################################
 
 Jérémy> -PULSEAUDIO_VERSION = 3.0
 Jérémy> +PULSEAUDIO_VERSION = 4.0
 Jérémy>  PULSEAUDIO_SITE = http://freedesktop.org/software/pulseaudio/releases/
 Jérémy>  PULSEAUDIO_INSTALL_STAGING = YES
 Jérémy> +PULSEAUDIO_LICENSE = LGPLv2.1+ (specific license for modules, see LICENSE file)
 Jérémy> +PULSEAUDIO_LICENSE_FILES = LICENSE GPL LGPL 

You have a trailing space here. Committed with that fixed, thanks.
Jeremy Rosen - June 10, 2013, 12:38 p.m.
> 
> You have a trailing space here. Committed with that fixed, thanks.
> 
> --
> Bye, Peter Korsgaard
> 

darn...

someday i'll manage to have a correct patch on the first try :P

thx for applying

Patch

diff --git a/package/multimedia/pulseaudio/pulseaudio-compat-with-json-c-0.11.patch b/package/multimedia/pulseaudio/pulseaudio-compat-with-json-c-0.11.patch
deleted file mode 100644
index 86efdfd..0000000
--- a/package/multimedia/pulseaudio/pulseaudio-compat-with-json-c-0.11.patch
+++ /dev/null
@@ -1,26 +0,0 @@ 
-From 759c0bc6f990240287a14fa6dec029ecea581463 Mon Sep 17 00:00:00 2001
-From: Arun Raghavan <arun.raghavan@collabora.co.uk>
-Date: Sat, 27 Apr 2013 03:27:05 +0000
-Subject: build-sys: json-c changed everything :(
-
-json-c 0.11 ships a pkg-config file with a different name, and changes
-the name of its library as well.
----
-(limited to 'configure.ac')
-
-diff --git a/configure.ac b/configure.ac
-index c8161a4..b1bd21a 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -624,7 +624,8 @@ AM_CONDITIONAL([HAVE_TESTS], [test "x$HAVE_LIBCHECK" = x1])
- 
- #### json parsing ####
- 
--PKG_CHECK_MODULES(LIBJSON, [ json >= 0.9 ])
-+PKG_CHECK_MODULES(LIBJSON, [ json-c >= 0.11 ], [],
-+		  [PKG_CHECK_MODULES(LIBJSON, [ json >= 0.9 ])])
- AC_SUBST(LIBJSON_CFLAGS)
- AC_SUBST(LIBJSON_LIBS)
- 
---
-cgit v0.9.0.2-2-gbebe
diff --git a/package/multimedia/pulseaudio/pulseaudio.mk b/package/multimedia/pulseaudio/pulseaudio.mk
index c789fc8..24a4ef4 100644
--- a/package/multimedia/pulseaudio/pulseaudio.mk
+++ b/package/multimedia/pulseaudio/pulseaudio.mk
@@ -4,9 +4,11 @@ 
 #
 ################################################################################
 
-PULSEAUDIO_VERSION = 3.0
+PULSEAUDIO_VERSION = 4.0
 PULSEAUDIO_SITE = http://freedesktop.org/software/pulseaudio/releases/
 PULSEAUDIO_INSTALL_STAGING = YES
+PULSEAUDIO_LICENSE = LGPLv2.1+ (specific license for modules, see LICENSE file)
+PULSEAUDIO_LICENSE_FILES = LICENSE GPL LGPL 
 PULSEAUDIO_CONF_OPT = \
 	--localstatedir=/var \
 	--disable-default-build-tests \
@@ -21,7 +23,6 @@  PULSEAUDIO_DEPENDENCIES = \
 	$(if $(BR2_PACKAGE_LIBSAMPLERATE),libsamplerate) \
 	$(if $(BR2_PACKAGE_ALSA_LIB),alsa-lib) \
 	$(if $(BR2_PACKAGE_LIBGLIB2),libglib2) \
-	$(if $(BR2_PACKAGE_LIBGTK2),libgtk2) \
 	$(if $(BR2_PACKAGE_AVAHI_DAEMON),avahi) \
 	$(if $(BR2_PACKAGE_DBUS),dbus) \
 	$(if $(BR2_PACKAGE_BLUEZ_UTILS),bluez_utils) \
@@ -31,11 +32,6 @@  PULSEAUDIO_DEPENDENCIES = \
 	$(if $(BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING),webrtc-audio-processing) \
 	$(if $(BR2_PACKAGE_SYSTEMD),systemd)
 
-# One patch touches configure.ac. We unconditionnally need libglib2
-# because configure.ac uses AM_GLIB_GNU_GETTEXT. This unconditionnal
-# dependency can be removed once the patch is removed.
-PULSEAUDIO_AUTORECONF = YES
-PULSEAUDIO_DEPENDENCIES += libglib2
 
 ifeq ($(BR2_PACKAGE_ORC),y)
 PULSEAUDIO_DEPENDENCIES += orc
@@ -66,11 +62,6 @@  ifneq ($(BR2_PACKAGE_ALSA_LIB_PCM)$(BR2_PACKAGE_ALSA_LIB_MIXER),yy)
 PULSEAUDIO_CONF_OPT += --disable-alsa
 endif
 
-# gtk support needs x backend
-ifneq ($(BR2_PACKAGE_LIBGTK2)$(BR2_PACKAGE_XORG),yy)
-PULSEAUDIO_CONF_OPT += --disable-gtk2
-endif
-
 ifeq ($(BR2_PACKAGE_LIBXCB)$(BR2_PACKAGE_XLIB_LIBSM)$(BR2_PACKAGE_XLIB_LIBXTST),yyy)
 PULSEAUDIO_DEPENDENCIES += libxcb xlib_libSM xlib_libXtst