Patchwork [PULL,16/26] qemu-io: Use the qemu version for -V

login
register
mail settings
Submitter Stefan Hajnoczi
Date June 7, 2013, 11:58 a.m.
Message ID <1370606325-10680-17-git-send-email-stefanha@redhat.com>
Download mbox | patch
Permalink /patch/249674/
State New
Headers show

Comments

Stefan Hajnoczi - June 7, 2013, 11:58 a.m.
From: Kevin Wolf <kwolf@redhat.com>

Always printing 0.0.1 and never updating the version number wasn't very
useful. qemu-io is released with qemu, so using the same version number
makes most sense.

Signed-off-by: Kevin Wolf <kwolf@redhat.com>
Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
---
 qemu-io.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Patch

diff --git a/qemu-io.c b/qemu-io.c
index 514edcb..cb9def5 100644
--- a/qemu-io.c
+++ b/qemu-io.c
@@ -19,8 +19,6 @@ 
 #include "block/block_int.h"
 #include "trace/control.h"
 
-#define VERSION	"0.0.1"
-
 #define CMD_NOFILE_OK   0x01
 
 char *progname;
@@ -380,7 +378,7 @@  int main(int argc, char **argv)
             }
             break;
         case 'V':
-            printf("%s version %s\n", progname, VERSION);
+            printf("%s version %s\n", progname, QEMU_VERSION);
             exit(0);
         case 'h':
             usage(progname);