Patchwork [v4,6/8] blockdev: add DriveBackup transaction

login
register
mail settings
Submitter Stefan Hajnoczi
Date May 16, 2013, 8:36 a.m.
Message ID <1368693379-8434-7-git-send-email-stefanha@redhat.com>
Download mbox | patch
Permalink /patch/244250/
State New
Headers show

Comments

Stefan Hajnoczi - May 16, 2013, 8:36 a.m.
This patch adds a transactional version of the drive-backup QMP command.
It allows atomic snapshots of multiple drives along with automatic
cleanup if there is a failure to start one of the backup jobs.

Note that QMP events are emitted for block job completion/cancellation
and the block job will be listed by query-block-jobs.

@DriveBackup

@device: the name of the device whose writes should be mirrored.

@target: the target of the new image. If the file exists, or if it
         is a device, the existing file/device will be used as the new
         destination.  If it does not exist, a new file will be created.

@format: #optional the format of the new destination, default is to
         probe if @mode is 'existing', else the format of the source

@mode: #optional whether and how QEMU should create a new image, default is
       'absolute-paths'.

@speed: #optional the maximum speed, in bytes per second

Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
---
 blockdev.c       | 53 +++++++++++++++++++++++++++++++++++++++++++++++++++++
 qapi-schema.json | 26 +++++++++++++++++++++++++-
 2 files changed, 78 insertions(+), 1 deletion(-)
Eric Blake - May 16, 2013, 7:21 p.m.
On 05/16/2013 02:36 AM, Stefan Hajnoczi wrote:
> This patch adds a transactional version of the drive-backup QMP command.
> It allows atomic snapshots of multiple drives along with automatic
> cleanup if there is a failure to start one of the backup jobs.
> 
> Note that QMP events are emitted for block job completion/cancellation
> and the block job will be listed by query-block-jobs.
> 
> @DriveBackup
> 
> @device: the name of the device whose writes should be mirrored.
> 
> @target: the target of the new image. If the file exists, or if it
>          is a device, the existing file/device will be used as the new
>          destination.  If it does not exist, a new file will be created.
> 
> @format: #optional the format of the new destination, default is to
>          probe if @mode is 'existing', else the format of the source
> 
> @mode: #optional whether and how QEMU should create a new image, default is
>        'absolute-paths'.
> 
> @speed: #optional the maximum speed, in bytes per second
> 
> Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
> ---
>  blockdev.c       | 53 +++++++++++++++++++++++++++++++++++++++++++++++++++++
>  qapi-schema.json | 26 +++++++++++++++++++++++++-
>  2 files changed, 78 insertions(+), 1 deletion(-)

Reviewed-by: Eric Blake <eblake@redhat.com>

Hmm, I wonder if we can simplify patch 3/8, by hoisting the DriveBackup
definition into that patch, and writing:

{ 'command': 'drive-backup',
  'data': 'DriveBackup' }

instead of the current open-coding repetition of the arguments for the
standalone command in comparison to the transaction action.  So far, all
uses of { 'command':'str', 'data':{...} } in the qapi-schema.json use a
direct object instead of a named type, but if we could fix the qapi code
generation to honor dictionary types in place of an open-coded type, it
might make our interface file more compact.

> +
> +static void drive_backup_commit(BlkTransactionState *common)
> +{
> +    /* Block job has started, nothing to do here */
> +}

Given this implementation, should we modify the extensible transaction
series to allow for a NULL commit callback, and merely insist only that
at least one of commit/abort is non-NULL (rather than the current
insistence that commit is mandatory and abort is optional)?
Stefan Hajnoczi - May 17, 2013, 7:02 a.m.
On Thu, May 16, 2013 at 01:21:19PM -0600, Eric Blake wrote:
> On 05/16/2013 02:36 AM, Stefan Hajnoczi wrote:
> > This patch adds a transactional version of the drive-backup QMP command.
> > It allows atomic snapshots of multiple drives along with automatic
> > cleanup if there is a failure to start one of the backup jobs.
> > 
> > Note that QMP events are emitted for block job completion/cancellation
> > and the block job will be listed by query-block-jobs.
> > 
> > @DriveBackup
> > 
> > @device: the name of the device whose writes should be mirrored.
> > 
> > @target: the target of the new image. If the file exists, or if it
> >          is a device, the existing file/device will be used as the new
> >          destination.  If it does not exist, a new file will be created.
> > 
> > @format: #optional the format of the new destination, default is to
> >          probe if @mode is 'existing', else the format of the source
> > 
> > @mode: #optional whether and how QEMU should create a new image, default is
> >        'absolute-paths'.
> > 
> > @speed: #optional the maximum speed, in bytes per second
> > 
> > Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
> > ---
> >  blockdev.c       | 53 +++++++++++++++++++++++++++++++++++++++++++++++++++++
> >  qapi-schema.json | 26 +++++++++++++++++++++++++-
> >  2 files changed, 78 insertions(+), 1 deletion(-)
> 
> Reviewed-by: Eric Blake <eblake@redhat.com>
> 
> Hmm, I wonder if we can simplify patch 3/8, by hoisting the DriveBackup
> definition into that patch, and writing:
> 
> { 'command': 'drive-backup',
>   'data': 'DriveBackup' }
> 
> instead of the current open-coding repetition of the arguments for the
> standalone command in comparison to the transaction action.  So far, all
> uses of { 'command':'str', 'data':{...} } in the qapi-schema.json use a
> direct object instead of a named type, but if we could fix the qapi code
> generation to honor dictionary types in place of an open-coded type, it
> might make our interface file more compact.

That would be nice.  The only thing to watch out for is a situation
where the transaction takes additional arguments that the regular
command does not.  But in most cases that would not be necessary.

> > +
> > +static void drive_backup_commit(BlkTransactionState *common)
> > +{
> > +    /* Block job has started, nothing to do here */
> > +}
> 
> Given this implementation, should we modify the extensible transaction
> series to allow for a NULL commit callback, and merely insist only that
> at least one of commit/abort is non-NULL (rather than the current
> insistence that commit is mandatory and abort is optional)?

If I need to respin I'll do that.

Patch

diff --git a/blockdev.c b/blockdev.c
index b6109da..c386bb6 100644
--- a/blockdev.c
+++ b/blockdev.c
@@ -926,6 +926,53 @@  static void external_snapshot_abort(BlkTransactionState *common)
     }
 }
 
+typedef struct DriveBackupState {
+    BlkTransactionState common;
+    BlockDriverState *bs;
+    BlockJob *job;
+} DriveBackupState;
+
+static void drive_backup_prepare(BlkTransactionState *common, Error **errp)
+{
+    DriveBackupState *state = DO_UPCAST(DriveBackupState, common, common);
+    DriveBackup *backup;
+    Error *local_err = NULL;
+
+    assert(common->action->kind == TRANSACTION_ACTION_KIND_DRIVE_BACKUP);
+    backup = common->action->drive_backup;
+
+    qmp_drive_backup(backup->device, backup->target,
+                     backup->has_format, backup->format,
+                     backup->has_mode, backup->mode,
+                     backup->has_speed, backup->speed,
+                     &local_err);
+    if (error_is_set(&local_err)) {
+        error_propagate(errp, local_err);
+        state->bs = NULL;
+        state->job = NULL;
+        return;
+    }
+
+    state->bs = bdrv_find(backup->device);
+    state->job = state->bs->job;
+}
+
+static void drive_backup_commit(BlkTransactionState *common)
+{
+    /* Block job has started, nothing to do here */
+}
+
+static void drive_backup_abort(BlkTransactionState *common)
+{
+    DriveBackupState *state = DO_UPCAST(DriveBackupState, common, common);
+    BlockDriverState *bs = state->bs;
+
+    /* Only cancel if it's the job we started */
+    if (bs && bs->job && bs->job == state->job) {
+        block_job_cancel_sync(bs->job);
+    }
+}
+
 static const BdrvActionOps actions[] = {
     [TRANSACTION_ACTION_KIND_BLOCKDEV_SNAPSHOT_SYNC] = {
         .instance_size = sizeof(ExternalSnapshotState),
@@ -933,6 +980,12 @@  static const BdrvActionOps actions[] = {
         .commit   = external_snapshot_commit,
         .abort = external_snapshot_abort,
     },
+    [TRANSACTION_ACTION_KIND_DRIVE_BACKUP] = {
+        .instance_size = sizeof(DriveBackupState),
+        .prepare = drive_backup_prepare,
+        .commit = drive_backup_commit,
+        .abort = drive_backup_abort,
+    },
 };
 
 /*
diff --git a/qapi-schema.json b/qapi-schema.json
index e716522..114ae50 100644
--- a/qapi-schema.json
+++ b/qapi-schema.json
@@ -1609,6 +1609,29 @@ 
             '*mode': 'NewImageMode' } }
 
 ##
+# @DriveBackup
+#
+# @device: the name of the device whose writes should be mirrored.
+#
+# @target: the target of the new image. If the file exists, or if it
+#          is a device, the existing file/device will be used as the new
+#          destination.  If it does not exist, a new file will be created.
+#
+# @format: #optional the format of the new destination, default is to
+#          probe if @mode is 'existing', else the format of the source
+#
+# @mode: #optional whether and how QEMU should create a new image, default is
+#        'absolute-paths'.
+#
+# @speed: #optional the maximum speed, in bytes per second
+#
+# Since: 1.6
+##
+{ 'type': 'DriveBackup',
+  'data': { 'device': 'str', 'target': 'str', '*format': 'str',
+            '*mode': 'NewImageMode', '*speed': 'int' } }
+
+##
 # @TransactionAction
 #
 # A discriminated record of operations that can be performed with
@@ -1616,7 +1639,8 @@ 
 ##
 { 'union': 'TransactionAction',
   'data': {
-       'blockdev-snapshot-sync': 'BlockdevSnapshot'
+       'blockdev-snapshot-sync': 'BlockdevSnapshot',
+       'drive-backup': 'DriveBackup'
    } }
 
 ##