Patchwork [1/2] depend on native make-3.81 to avoid problems caused by newer versions

login
register
mail settings
Submitter Kim Højgaard-Hansen
Date May 15, 2013, 7:38 a.m.
Message ID <b44517a95d589adca3dac117008f6cc38ce0095e.1368602311.git.kimrhh@exherbo.org>
Download mbox | patch
Permalink /patch/243921/
State Accepted
Delegated to: Esben Haabendal
Headers show

Comments

Kim Højgaard-Hansen - May 15, 2013, 7:38 a.m.
---
 recipes/crosstool-ng/crosstool-ng_1.17.0.oe | 4 ++++
 1 file changed, 4 insertions(+)

Patch

diff --git a/recipes/crosstool-ng/crosstool-ng_1.17.0.oe b/recipes/crosstool-ng/crosstool-ng_1.17.0.oe
index 4dd702a..c0d4da3 100644
--- a/recipes/crosstool-ng/crosstool-ng_1.17.0.oe
+++ b/recipes/crosstool-ng/crosstool-ng_1.17.0.oe
@@ -18,6 +18,10 @@  SRC_URI += "file://eglibc-2_16-typedef-caddr.patch"
 SRC_URI += "file://uclibceabi-instead-of-uclibcgnueabi.patch"
 SRC_URI += "file://uclibc-target-cflags-fixup.patch"
 
+#We have to use make_3.81 for now, since 3.82 makes at least
+#glibc install fail, trying to install headers to /
+DEPENDS += "native:make_3.81"
+
 # For some odd reason, ct-NG configure scripts end up setting make path
 # to just "make" and not the full path.  And even more odd, this breaks
 # build by (oddest of all) GMP configure hang in conftest.make execution.