Patchwork memory: Replace open-coded memory_region_is_romd

login
register
mail settings
Submitter Jan Kiszka
Date May 6, 2013, 4:07 p.m.
Message ID <5187D529.7010502@siemens.com>
Download mbox | patch
Permalink /patch/241715/
State New
Headers show

Comments

Jan Kiszka - May 6, 2013, 4:07 p.m.
Improves readability.

Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
---
 translate-all.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)
Paolo Bonzini - May 6, 2013, 4:26 p.m.
Il 06/05/2013 18:07, Jan Kiszka ha scritto:
> Improves readability.
> 
> Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
> ---
>  translate-all.c |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/translate-all.c b/translate-all.c
> index da93608..0d84b0d 100644
> --- a/translate-all.c
> +++ b/translate-all.c
> @@ -1359,7 +1359,7 @@ void tb_invalidate_phys_addr(hwaddr addr)
>      section = phys_page_find(address_space_memory.dispatch,
>                               addr >> TARGET_PAGE_BITS);
>      if (!(memory_region_is_ram(section->mr)
> -          || (section->mr->rom_device && section->mr->readable))) {
> +          || memory_region_is_romd(section->mr))) {
>          return;
>      }
>      ram_addr = (memory_region_get_ram_addr(section->mr) & TARGET_PAGE_MASK)
> 

Not trivial enough for qemu-trivial, let's open a memory branch for 1.6.

Any volunteers for co-maintaining it? :)

Paolo
Peter Maydell - May 6, 2013, 4:42 p.m.
On 6 May 2013 17:26, Paolo Bonzini <pbonzini@redhat.com> wrote:
> Il 06/05/2013 18:07, Jan Kiszka ha scritto:
>> Improves readability.
>>
>> Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
>> ---
>>  translate-all.c |    2 +-
>>  1 files changed, 1 insertions(+), 1 deletions(-)
>>
>> diff --git a/translate-all.c b/translate-all.c
>> index da93608..0d84b0d 100644
>> --- a/translate-all.c
>> +++ b/translate-all.c
>> @@ -1359,7 +1359,7 @@ void tb_invalidate_phys_addr(hwaddr addr)
>>      section = phys_page_find(address_space_memory.dispatch,
>>                               addr >> TARGET_PAGE_BITS);
>>      if (!(memory_region_is_ram(section->mr)
>> -          || (section->mr->rom_device && section->mr->readable))) {
>> +          || memory_region_is_romd(section->mr))) {
>>          return;
>>      }
>>      ram_addr = (memory_region_get_ram_addr(section->mr) & TARGET_PAGE_MASK)
>>
>
> Not trivial enough for qemu-trivial, let's open a memory branch for 1.6.

Well, I wouldn't necessarily put it in 1.5 this close to
hardfreeze, but it looks fine for qemu-trivial to me.
In particular you can comprehend the patch and confirm its
correctness without having to have any larger understanding
of the memory system.

Reviewed-by: Peter Maydell <peter.maydell@linaro.org>

-- PMM
Jan Kiszka - May 7, 2013, 2:17 p.m.
On 2013-05-06 18:26, Paolo Bonzini wrote:
> Il 06/05/2013 18:07, Jan Kiszka ha scritto:
>> Improves readability.
>>
>> Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
>> ---
>>  translate-all.c |    2 +-
>>  1 files changed, 1 insertions(+), 1 deletions(-)
>>
>> diff --git a/translate-all.c b/translate-all.c
>> index da93608..0d84b0d 100644
>> --- a/translate-all.c
>> +++ b/translate-all.c
>> @@ -1359,7 +1359,7 @@ void tb_invalidate_phys_addr(hwaddr addr)
>>      section = phys_page_find(address_space_memory.dispatch,
>>                               addr >> TARGET_PAGE_BITS);
>>      if (!(memory_region_is_ram(section->mr)
>> -          || (section->mr->rom_device && section->mr->readable))) {
>> +          || memory_region_is_romd(section->mr))) {
>>          return;
>>      }
>>      ram_addr = (memory_region_get_ram_addr(section->mr) & TARGET_PAGE_MASK)
>>
> 
> Not trivial enough for qemu-trivial, let's open a memory branch for 1.6.

Great, thanks.

> 
> Any volunteers for co-maintaining it? :)

Raising my hand, but not without remarking that I have some bandwidth
issue ATM. But I will try my best.

Jan
Paolo Bonzini - May 7, 2013, 2:35 p.m.
Il 07/05/2013 16:17, Jan Kiszka ha scritto:
> On 2013-05-06 18:26, Paolo Bonzini wrote:
>> Il 06/05/2013 18:07, Jan Kiszka ha scritto:
>>> Improves readability.
>>>
>>> Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
>>> ---
>>>  translate-all.c |    2 +-
>>>  1 files changed, 1 insertions(+), 1 deletions(-)
>>>
>>> diff --git a/translate-all.c b/translate-all.c
>>> index da93608..0d84b0d 100644
>>> --- a/translate-all.c
>>> +++ b/translate-all.c
>>> @@ -1359,7 +1359,7 @@ void tb_invalidate_phys_addr(hwaddr addr)
>>>      section = phys_page_find(address_space_memory.dispatch,
>>>                               addr >> TARGET_PAGE_BITS);
>>>      if (!(memory_region_is_ram(section->mr)
>>> -          || (section->mr->rom_device && section->mr->readable))) {
>>> +          || memory_region_is_romd(section->mr))) {
>>>          return;
>>>      }
>>>      ram_addr = (memory_region_get_ram_addr(section->mr) & TARGET_PAGE_MASK)
>>>
>>
>> Not trivial enough for qemu-trivial, let's open a memory branch for 1.6.
> 
> Great, thanks.
> 
>>
>> Any volunteers for co-maintaining it? :)
> 
> Raising my hand, but not without remarking that I have some bandwidth
> issue ATM. But I will try my best.

Ok, the model we've been using for migration is that there is a pool of
people that send pull requests without being official maintainers---the
contract with Anthony is simply that patches are well reviewed.

For now I've repurposed my iommu branch as the WIP 1.6 memory branch;
It can still be rebased, but the changes should be small at this point.
 I will pass the ball after sending the first 1.6 pull request.

Paolo

Patch

diff --git a/translate-all.c b/translate-all.c
index da93608..0d84b0d 100644
--- a/translate-all.c
+++ b/translate-all.c
@@ -1359,7 +1359,7 @@  void tb_invalidate_phys_addr(hwaddr addr)
     section = phys_page_find(address_space_memory.dispatch,
                              addr >> TARGET_PAGE_BITS);
     if (!(memory_region_is_ram(section->mr)
-          || (section->mr->rom_device && section->mr->readable))) {
+          || memory_region_is_romd(section->mr))) {
         return;
     }
     ram_addr = (memory_region_get_ram_addr(section->mr) & TARGET_PAGE_MASK)