qtuio: depends on QT4

Submitted by Stephan Hoffmann on March 30, 2013, 4:55 p.m.

Details

Message ID 1364662519-2385-1-git-send-email-sho@relinux.de
State Changes Requested
Headers show

Commit Message

Stephan Hoffmann March 30, 2013, 4:55 p.m.
Fixes: http://autobuild.buildroot.net/results/e6501a7a487ec3a02463ad0f3aa60168883fa369/

Signed-off-by: Stephan Hoffmann <sho@relinux.de>
---
 package/qtuio/Config.in |    4 +++-
 1 files changed, 3 insertions(+), 1 deletions(-)

Comments

Arnout Vandecappelle April 4, 2013, 11:52 a.m.
On 30/03/13 17:55, Stephan Hoffmann wrote:
> Fixes: http://autobuild.buildroot.net/results/e6501a7a487ec3a02463ad0f3aa60168883fa369/
>
> Signed-off-by: Stephan Hoffmann <sho@relinux.de>
> ---
>   package/qtuio/Config.in |    4 +++-
>   1 files changed, 3 insertions(+), 1 deletions(-)
>
> diff --git a/package/qtuio/Config.in b/package/qtuio/Config.in
> index 19499fd..590b2de 100644
> --- a/package/qtuio/Config.in
> +++ b/package/qtuio/Config.in
> @@ -1,6 +1,6 @@
>   config BR2_PACKAGE_QTUIO
>   	bool "qtuio"
> -	depends on BR2_PACKAGE_QT_GUI_MODULE
> +	depends on BR2_PACKAGE_QT_GUI_MODULE && !BR2_PACKAGE_QT5

  Thomas has a patch pending which makes qt4 and qt5 mutually exclusive 
(because any qt package will fail if both are installed, because of 
inconsistencies in the qmake configurations). So this change should be 
redundant.

>   	help
>   	  Implementation of an interface connecting TUIO messages
>   	  and QT events
> @@ -16,3 +16,5 @@ config BR2_QTUIO_EXAMPLES
>   comment "qtuio depends on QT gui module"
>   	depends on !BR2_PACKAGE_QT_GUI_MODULE
>
> +comment "qtuio requires QT4"
> +	depends on BR2_PACKAGE_QT5

  This one may still be useful though.


  Regards,
  Arnout

>

Patch hide | download patch | download mbox

diff --git a/package/qtuio/Config.in b/package/qtuio/Config.in
index 19499fd..590b2de 100644
--- a/package/qtuio/Config.in
+++ b/package/qtuio/Config.in
@@ -1,6 +1,6 @@ 
 config BR2_PACKAGE_QTUIO
 	bool "qtuio"
-	depends on BR2_PACKAGE_QT_GUI_MODULE
+	depends on BR2_PACKAGE_QT_GUI_MODULE && !BR2_PACKAGE_QT5
 	help
 	  Implementation of an interface connecting TUIO messages
 	  and QT events
@@ -16,3 +16,5 @@  config BR2_QTUIO_EXAMPLES
 comment "qtuio depends on QT gui module"
 	depends on !BR2_PACKAGE_QT_GUI_MODULE
 
+comment "qtuio requires QT4"
+	depends on BR2_PACKAGE_QT5