Patchwork xtables-addons: build against 3.8.y

login
register
mail settings
Submitter holger@eitzenberger.org
Date March 12, 2013, 8:18 a.m.
Message ID <20130312081812.GB11508@imap.eitzenberger.org>
Download mbox | patch
Permalink /patch/226832/
State Not Applicable
Headers show

Comments

holger@eitzenberger.org - March 12, 2013, 8:18 a.m.
Hi Jan,

I see that xtables-addons 1.47.1 do not build against kernel 3.8.2,
because of ipv6_find_hdr() having moved to <net/ipv6.h>.  And this
include is missing from xt_SYSREQ.c:

extensions/xt_SYSRQ.c: In function 'sysrq_tg6':
extensions/xt_SYSRQ.c:251: xt_SYSRQ.c:251: error: implicit declaration \
	of function 'ipv6_find_ hdr'

The attached patch fixes that.

Please check.

 /Holger
Jan Engelhardt - March 12, 2013, 12:42 p.m.
On Tuesday 2013-03-12 09:18, Holger Eitzenberger wrote:

>Hi Jan,
>
>I see that xtables-addons 1.47.1 do not build against kernel 3.8.2,
>because of ipv6_find_hdr() having moved to <net/ipv6.h>.  And this
>include is missing from xt_SYSREQ.c:

Support for 3.8 is available in xt-a 2.1.
--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Patch

xt_SYSRQ: include <net/ipv6.h>

ipv6_find_hdr() has moved to <net/ipv6.h> since kernel
v3.8.  It is necessary to include this header as well.

Signed-off-by: Holger Eitzenberger <holger@eitzenberger.org>

Index: xtables-addons-1.47.1/extensions/xt_SYSRQ.c
===================================================================
--- xtables-addons-1.47.1.orig/extensions/xt_SYSRQ.c
+++ xtables-addons-1.47.1/extensions/xt_SYSRQ.c
@@ -24,6 +24,7 @@ 
 #include <linux/crypto.h>
 #include <linux/scatterlist.h>
 #include <net/ip.h>
+#include <net/ipv6.h>
 #include "compat_xtables.h"
 
 #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 19) && \