configure: Require at least spice-protocol-0.12.3

Submitted by Michal Privoznik on March 1, 2013, 7:43 a.m.

Details

Message ID 302ae9628718b0c4ae10528ec97e88a6000b6099.1362123798.git.mprivozn@redhat.com
State New
Headers show

Commit Message

Michal Privoznik March 1, 2013, 7:43 a.m.
As of 5a49d3e9 we assume SPICE_PORT_EVENT_BREAK to be defined.
However, it is defined not in 0.12.2 what we require now, but in
0.12.3.  Therefore in order to prevent build failure we must
adjust our minimal requirements.
---
 configure | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Stefan Hajnoczi March 4, 2013, 10:51 a.m.
On Fri, Mar 01, 2013 at 08:43:18AM +0100, Michal Privoznik wrote:
> As of 5a49d3e9 we assume SPICE_PORT_EVENT_BREAK to be defined.
> However, it is defined not in 0.12.2 what we require now, but in
> 0.12.3.  Therefore in order to prevent build failure we must
> adjust our minimal requirements.
> ---
>  configure | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Thanks, applied to the trivial patches tree:
https://github.com/stefanha/qemu/commits/trivial-patches

Stefan

Patch hide | download patch | download mbox

diff --git a/configure b/configure
index 8df7db1..696e84d 100755
--- a/configure
+++ b/configure
@@ -2867,7 +2867,7 @@  EOF
   spice_cflags=$($pkg_config --cflags spice-protocol spice-server 2>/dev/null)
   spice_libs=$($pkg_config --libs spice-protocol spice-server 2>/dev/null)
   if $pkg_config --atleast-version=0.12.0 spice-server >/dev/null 2>&1 && \
-     $pkg_config --atleast-version=0.12.2 spice-protocol > /dev/null 2>&1 && \
+     $pkg_config --atleast-version=0.12.3 spice-protocol > /dev/null 2>&1 && \
      compile_prog "$spice_cflags" "$spice_libs" ; then
     spice="yes"
     libs_softmmu="$libs_softmmu $spice_libs"