Patchwork [1/2] ARM: Tegra: Add clock entry for smp_twd clock

login
register
mail settings
Submitter Prashant Gaikwad
Date Feb. 28, 2013, 7:43 a.m.
Message ID <1362037381-4730-1-git-send-email-pgaikwad@nvidia.com>
Download mbox | patch
Permalink /patch/223785/
State Superseded, archived
Headers show

Comments

Prashant Gaikwad - Feb. 28, 2013, 7:43 a.m.
As DT support for clocks and smp_twd is enabled, add clock entry
for smp_twd clock to DT.

Signed-off-by: Prashant Gaikwad <pgaikwad@nvidia.com>
---
 arch/arm/boot/dts/tegra20.dtsi |    1 +
 arch/arm/boot/dts/tegra30.dtsi |    1 +
 2 files changed, 2 insertions(+), 0 deletions(-)
Stephen Warren - Feb. 28, 2013, 6:18 p.m.
On 02/28/2013 12:43 AM, Prashant Gaikwad wrote:
> As DT support for clocks and smp_twd is enabled, add clock entry
> for smp_twd clock to DT.

Is this a cleanup for 3.10, or a bug-fix for 3.9? Perhaps it solves the
"twd: clock not found" bug I reported?
--
To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Thierry Reding - Feb. 28, 2013, 8:04 p.m.
On Thu, Feb 28, 2013 at 11:18:01AM -0700, Stephen Warren wrote:
> On 02/28/2013 12:43 AM, Prashant Gaikwad wrote:
> > As DT support for clocks and smp_twd is enabled, add clock entry
> > for smp_twd clock to DT.
> 
> Is this a cleanup for 3.10, or a bug-fix for 3.9? Perhaps it solves the
> "twd: clock not found" bug I reported?

Yes. This is pretty much identical to the patch I sent a few days ago
before your patch that fixed the clock drivers to match the devicetree
binding documentation.

The "clock not found" is exactly what this fixes.

Thierry
Stephen Warren - March 1, 2013, 6:25 p.m.
On 02/28/2013 01:04 PM, Thierry Reding wrote:
> On Thu, Feb 28, 2013 at 11:18:01AM -0700, Stephen Warren wrote:
>> On 02/28/2013 12:43 AM, Prashant Gaikwad wrote:
>>> As DT support for clocks and smp_twd is enabled, add clock
>>> entry for smp_twd clock to DT.
>> 
>> Is this a cleanup for 3.10, or a bug-fix for 3.9? Perhaps it
>> solves the "twd: clock not found" bug I reported?
> 
> Yes. This is pretty much identical to the patch I sent a few days
> ago before your patch that fixed the clock drivers to match the
> devicetree binding documentation.
> 
> The "clock not found" is exactly what this fixes.

OK. I'll forward these patches to arm-soc as fixes for 3.9 then. I
tested them and they work for me, on top of Linus' latest master.
--
To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Patch

diff --git a/arch/arm/boot/dts/tegra20.dtsi b/arch/arm/boot/dts/tegra20.dtsi
index 9a42893..48d00a0 100644
--- a/arch/arm/boot/dts/tegra20.dtsi
+++ b/arch/arm/boot/dts/tegra20.dtsi
@@ -118,6 +118,7 @@ 
 		compatible = "arm,cortex-a9-twd-timer";
 		reg = <0x50040600 0x20>;
 		interrupts = <1 13 0x304>;
+		clocks = <&tegra_car 132>;
 	};
 
 	intc: interrupt-controller {
diff --git a/arch/arm/boot/dts/tegra30.dtsi b/arch/arm/boot/dts/tegra30.dtsi
index 767803e..9d87a3f 100644
--- a/arch/arm/boot/dts/tegra30.dtsi
+++ b/arch/arm/boot/dts/tegra30.dtsi
@@ -119,6 +119,7 @@ 
 		compatible = "arm,cortex-a9-twd-timer";
 		reg = <0x50040600 0x20>;
 		interrupts = <1 13 0xf04>;
+		clocks = <&tegra_car 214>;
 	};
 
 	intc: interrupt-controller {