Patchwork [1/2] require gtk 2.20+

login
register
mail settings
Submitter Gerd Hoffmann
Date Feb. 25, 2013, 9:03 a.m.
Message ID <1361783023-10082-3-git-send-email-kraxel@redhat.com>
Download mbox | patch
Permalink /patch/222884/
State New
Headers show

Comments

Gerd Hoffmann - Feb. 25, 2013, 9:03 a.m.
The gtk code uses gtk_widget_get_realized which is available in 2.20+
only, so make this the minimum accepted versions.  Fixes build failures
on RHEL-6 (which ships 2.18) by not building gtk support there.

Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
---
 configure |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/configure b/configure
index 0dadd31..a6b0c02 100755
--- a/configure
+++ b/configure
@@ -1644,7 +1644,7 @@  fi
 # GTK probe
 
 if test "$gtk" != "no"; then
-    if $pkg_config gtk+-2.0 --modversion >/dev/null 2>/dev/null && \
+    if $pkg_config gtk+-2.0 --atleast-version=2.20 >/dev/null 2>/dev/null && \
        $pkg_config vte --modversion >/dev/null 2>/dev/null; then
 	gtk_cflags=`$pkg_config --cflags gtk+-2.0 2>/dev/null`
 	gtk_libs=`$pkg_config --libs gtk+-2.0 2>/dev/null`