Patchwork Enable INTEL_HDA on the Nexus 7

login
register
mail settings
Submitter Jani Monoses
Date Jan. 24, 2013, 11:07 a.m.
Message ID <kdr4lv$rif$1@ger.gmane.org>
Download mbox | patch
Permalink /patch/215314/
State New
Headers show

Comments

Jani Monoses - Jan. 24, 2013, 11:07 a.m.
Hi,
on the Nexus 7 sound only works after issuing a suspend first.
No idea why, but enabling HDA (as Android has on the same device) fixes it.

Jani
Oliver Grawert - Jan. 25, 2013, 2:56 p.m.
hi,
Am Donnerstag, den 24.01.2013, 13:07 +0200 schrieb Jani Monoses:
> Hi,
> on the Nexus 7 sound only works after issuing a suspend first.
> No idea why, but enabling HDA (as Android has on the same device) fixes it.

doesnt seem to have any effect for me, sound still only works after a
suspend/resume cycle. 

could you provide a testbuild of a kernel package we could hand around
to see if thats possibly model specific or so ?

ciao
	oli
Jani Monoses - Jan. 25, 2013, 5:19 p.m.
On 01/25/2013 04:56 PM, Oliver Grawert wrote:
> hi,
> Am Donnerstag, den 24.01.2013, 13:07 +0200 schrieb Jani Monoses:
>> Hi,
>> on the Nexus 7 sound only works after issuing a suspend first.
>> No idea why, but enabling HDA (as Android has on the same device) fixes it.
>
> doesnt seem to have any effect for me, sound still only works after a
> suspend/resume cycle.
>
> could you provide a testbuild of a kernel package we could hand around
> to see if thats possibly model specific or so ?

Please try this one. It works for me if I turn on the volume first - it 
boots muted for me.

http://people.canonical.com/~jani/linux-image-3.1.10-8-nexus7_3.1.10-8.21_armhf.deb

The only change from the raring kernel is the patch from this thread.

Jani
Jani Monoses - Jan. 25, 2013, 5:52 p.m.
On Thu, 24 Jan 2013 13:07:46 +0200, Jani Monoses wrote:

> Hi,
> on the Nexus 7 sound only works after issuing a suspend first.
> No idea why, but enabling HDA (as Android has on the same device) fixes
> it.
> 

Ok as Oliver suspected this was a red herring. My sound now works with 
the stock kernel too. So never mind this patch.

Jani

Patch

From c5779607211eba25e3749ac7bfb3e625589636c0 Mon Sep 17 00:00:00 2001
From: Jani Monoses <jani@ubuntu.com>
Date: Thu, 24 Jan 2013 12:57:39 +0200
Subject: [PATCH] UBUNTU: [Config] Without HDA enabled sound does not work
 until a completed suspend/resume cycle. 
 CONFIG_SND_HDA_INTEL=y 
 CONFIG_SND_HDA_PLATFORM_DRIVER=y 
 CONFIG_SND_HDA_PLATFORM_NVIDIA_TEGRA=y

BugLink: https://bugs.launchpad.net/ubuntu-nexus7/+bug/1068804/

Signed-off-by: Jani Monoses <jani@ubuntu.com>
---
 debian.linaro/config/config.common.ubuntu | 23 ++++++++++++++++++++++-
 1 file changed, 22 insertions(+), 1 deletion(-)

diff --git a/debian.linaro/config/config.common.ubuntu b/debian.linaro/config/config.common.ubuntu
index 3aea047..029098d 100644
--- a/debian.linaro/config/config.common.ubuntu
+++ b/debian.linaro/config/config.common.ubuntu
@@ -2183,7 +2183,27 @@  CONFIG_SND_DYNAMIC_MINORS=y
 # CONFIG_SND_FM801 is not set
 # CONFIG_SND_GINA20 is not set
 # CONFIG_SND_GINA24 is not set
-# CONFIG_SND_HDA_INTEL is not set
+# CONFIG_SND_HDA_CODEC_ANALOG is not set
+# CONFIG_SND_HDA_CODEC_CA0110 is not set
+# CONFIG_SND_HDA_CODEC_CA0132 is not set
+# CONFIG_SND_HDA_CODEC_CIRRUS is not set
+# CONFIG_SND_HDA_CODEC_CMEDIA is not set
+# CONFIG_SND_HDA_CODEC_CONEXANT is not set
+# CONFIG_SND_HDA_CODEC_HDMI is not set
+# CONFIG_SND_HDA_CODEC_REALTEK is not set
+# CONFIG_SND_HDA_CODEC_SI3054 is not set
+# CONFIG_SND_HDA_CODEC_SIGMATEL is not set
+# CONFIG_SND_HDA_CODEC_VIA is not set
+# CONFIG_SND_HDA_GENERIC is not set
+# CONFIG_SND_HDA_HWDEP is not set
+# CONFIG_SND_HDA_INPUT_BEEP is not set
+# CONFIG_SND_HDA_INPUT_JACK is not set
+CONFIG_SND_HDA_INTEL=y
+# CONFIG_SND_HDA_PATCH_LOADER is not set
+CONFIG_SND_HDA_PLATFORM_DRIVER=y
+CONFIG_SND_HDA_PLATFORM_NVIDIA_TEGRA=y
+# CONFIG_SND_HDA_POWER_SAVE is not set
+CONFIG_SND_HDA_PREALLOC_SIZE=64
 # CONFIG_SND_HDSP is not set
 # CONFIG_SND_HDSPM is not set
 # CONFIG_SND_HRTIMER is not set
@@ -2260,6 +2280,7 @@  CONFIG_SND_VERBOSE_PROCFS=y
 # CONFIG_SND_VIA82XX is not set
 # CONFIG_SND_VIA82XX_MODEM is not set
 # CONFIG_SND_VIRTUOSO is not set
+CONFIG_SND_VMASTER=y
 # CONFIG_SND_VX222 is not set
 # CONFIG_SND_YMFPCI is not set
 # CONFIG_SOC_CAMERA is not set
-- 
1.8.0