Patchwork Build fixes for old Linuxes

login
register
mail settings
Submitter Jan Engelhardt
Date Jan. 15, 2013, 6:20 p.m.
Message ID <1358274002-6042-1-git-send-email-jengelh@inai.de>
Download mbox
Permalink /patch/212287/
State Not Applicable
Headers show

Pull-request

git://git.inai.de/iptables old-linux

Comments

Jan Engelhardt - Jan. 15, 2013, 6:20 p.m.
With this, iptables-1.4.17a (current git state) is tested to compile
and, to the degree covered by this patchset, to function under
Linux 2.4.27/glibc-2.3.2/Debian-3.1.

===
The following changes since commit 983196ceb4d3bb7b6d3cf6da18bb6d5a5eafb347:

  doc: document the -4 and -6 options (2013-01-07 02:26:16 +0100)

are available in the git repository at:

  git://git.inai.de/iptables old-linux

for you to fetch changes up to 1071ec54e6d7af406fe34afea1ce2c3e49ee1914:

  parser: workaround glibc-2.3.2 bug 358 (2013-01-15 19:16:55 +0100)

----------------------------------------------------------------
Jan Engelhardt (2):
      build: fix libiptc build failure on old linux-glibc-devel headers
      parser: workaround glibc-2.3.2 bug 358

 libiptc/linux_list.h   |    4 ++--
 libiptc/linux_stddef.h |    4 ++--
 libxtables/xtoptions.c |   14 ++++++++++++++
 3 files changed, 18 insertions(+), 4 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Pablo Neira - Jan. 18, 2013, 12:44 a.m.
On Tue, Jan 15, 2013 at 07:20:00PM +0100, Jan Engelhardt wrote:
> 
> With this, iptables-1.4.17a (current git state) is tested to compile
> and, to the degree covered by this patchset, to function under
> Linux 2.4.27/glibc-2.3.2/Debian-3.1.
> 
> ===
> The following changes since commit 983196ceb4d3bb7b6d3cf6da18bb6d5a5eafb347:
> 
>   doc: document the -4 and -6 options (2013-01-07 02:26:16 +0100)
> 
> are available in the git repository at:
> 
>   git://git.inai.de/iptables old-linux
> 
> for you to fetch changes up to 1071ec54e6d7af406fe34afea1ce2c3e49ee1914:
> 
>   parser: workaround glibc-2.3.2 bug 358 (2013-01-15 19:16:55 +0100)
> 
> ----------------------------------------------------------------
> Jan Engelhardt (2):
>       build: fix libiptc build failure on old linux-glibc-devel headers
>       parser: workaround glibc-2.3.2 bug 358

Helping users is a noble thing from your side. However, that glibc
branch [1] and that debian release [2] are not maintained anymore.

[1] http://sourceware.org/glibc/wiki/Release
[2] http://www.debian.org/releases/sarge/

Sorry, I'm not taking this.
--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Jan Engelhardt - Jan. 18, 2013, 1:29 a.m.
On Friday 2013-01-18 01:44, Pablo Neira Ayuso wrote:
>On Tue, Jan 15, 2013 at 07:20:00PM +0100, Jan Engelhardt wrote:
>> 
>> With this, iptables-1.4.17a (current git state) is tested to compile
>> and, to the degree covered by this patchset, to function under
>> Linux 2.4.27/glibc-2.3.2/Debian-3.1.
>
>Helping users is a noble thing from your side. However, that glibc
>branch [1] and that debian release [2] are not maintained anymore.

I kinda thought so. Was fun to look at it though.

So, what is the minimum {kernel, userspace} configuration that
we should require from users and which to put into INSTALL?
Do we still care about 2.4.x?
--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Pablo Neira - Jan. 18, 2013, 2:06 a.m.
On Fri, Jan 18, 2013 at 02:29:43AM +0100, Jan Engelhardt wrote:
[...]
> So, what is the minimum {kernel, userspace} configuration that
> we should require from users and which to put into INSTALL?
> Do we still care about 2.4.x?

As long as it is maintained, 2.4.x matters. Same thing with maintained
third party library dependencies.
--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Jan Engelhardt - Jan. 21, 2013, 4:29 p.m.
On Friday 2013-01-18 03:06, Pablo Neira Ayuso wrote:

>On Fri, Jan 18, 2013 at 02:29:43AM +0100, Jan Engelhardt wrote:
>[...]
>> So, what is the minimum {kernel, userspace} configuration that
>> we should require from users and which to put into INSTALL?
>> Do we still care about 2.4.x?
>
>As long as it is maintained, 2.4.x matters. Same thing with maintained
>third party library dependencies.
>
Then the first patch should be applied.

--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html