Patchwork [2/2] arptables: bump to version 0.0.4

login
register
mail settings
Submitter Gustavo Zacarias
Date Jan. 12, 2013, 11:37 a.m.
Message ID <1357990675-12863-2-git-send-email-gustavo@zacarias.com.ar>
Download mbox | patch
Permalink /patch/211491/
State Superseded
Headers show

Comments

Gustavo Zacarias - Jan. 12, 2013, 11:37 a.m.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/arptables/arptables.mk | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
Thomas Petazzoni - Jan. 12, 2013, 11:58 a.m.
Dear Gustavo Zacarias,

On Sat, 12 Jan 2013 08:37:55 -0300, Gustavo Zacarias wrote:

> -ARPTABLES_VERSION = 0.0.3
> -ARPTABLES_VERSION_MINOR = 4
> -ARPTABLES_SOURCE = arptables-v$(ARPTABLES_VERSION)-$(ARPTABLES_VERSION_MINOR).tar.gz
> +ARPTABLES_VERSION = 0.0.4
> +ARPTABLES_SOURCE = arptables-v$(ARPTABLES_VERSION).tar.gz
>  ARPTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/arptables/arptables-v$(ARPTABLES_VERSION)

Could you add LICENSE and LICENSE_FILES while you're at it? :-)

Thanks!

Thomas
Gustavo Zacarias - Jan. 12, 2013, 12:07 p.m.
On 01/12/2013 08:58 AM, Thomas Petazzoni wrote:

> Could you add LICENSE and LICENSE_FILES while you're at it? :-)

Unfortunately it's not clear cut which license it's placed on.
Presumably it's GPL since a quick search says:

arptables-v0.0.4 $ find . -type f -exec grep --with-filename GPL {} \;
./libarptc/libarptc.c:/* (C)1999 Paul ``Rusty'' Russell - Placed under
the GNU GPL (See
./libarptc/libarptc_incl.c:/* (C)1999 Paul ``Rusty'' Russell - Placed
under the GNU GPL (See
./include/linux/netfilter_arp.h: * (C)2002 Rusty Russell IBM -- This
code is GPL.

But there's nothing else indicating so, and no detail as to which
version of the GPL (presumably v2 because of the date, but no license
files included).
Should we go with v2 or just leave it be for the license experts?
Regards.
Thomas Petazzoni - Jan. 12, 2013, 12:10 p.m.
Dear Gustavo Zacarias,

On Sat, 12 Jan 2013 09:07:14 -0300, Gustavo Zacarias wrote:

> > Could you add LICENSE and LICENSE_FILES while you're at it? :-)
> 
> Unfortunately it's not clear cut which license it's placed on.
> Presumably it's GPL since a quick search says:
> 
> arptables-v0.0.4 $ find . -type f -exec grep --with-filename GPL {} \;
> ./libarptc/libarptc.c:/* (C)1999 Paul ``Rusty'' Russell - Placed under
> the GNU GPL (See
> ./libarptc/libarptc_incl.c:/* (C)1999 Paul ``Rusty'' Russell - Placed
> under the GNU GPL (See
> ./include/linux/netfilter_arp.h: * (C)2002 Rusty Russell IBM -- This
> code is GPL.
> 
> But there's nothing else indicating so, and no detail as to which
> version of the GPL (presumably v2 because of the date, but no license
> files included).
> Should we go with v2 or just leave it be for the license experts?

Another option is to contact the authors and ask them to clarify the
licensing? It's not like Rusty Russell is MIA :-)

Thomas
Gustavo Zacarias - Jan. 12, 2013, 12:16 p.m.
On 01/12/2013 09:10 AM, Thomas Petazzoni wrote:

> Another option is to contact the authors and ask them to clarify the
> licensing? It's not like Rusty Russell is MIA :-)

Looking at extensions/arpt_CLASSIFY.c it specifies v2+ so i think it's
safe to assume this given that as you pointed out on IRC Debian also
classifies it so.
Patch forthcoming.
Regards.

Patch

diff --git a/package/arptables/arptables.mk b/package/arptables/arptables.mk
index dac5ca4..5a9986b 100644
--- a/package/arptables/arptables.mk
+++ b/package/arptables/arptables.mk
@@ -4,9 +4,8 @@ 
 #
 #############################################################
 
-ARPTABLES_VERSION = 0.0.3
-ARPTABLES_VERSION_MINOR = 4
-ARPTABLES_SOURCE = arptables-v$(ARPTABLES_VERSION)-$(ARPTABLES_VERSION_MINOR).tar.gz
+ARPTABLES_VERSION = 0.0.4
+ARPTABLES_SOURCE = arptables-v$(ARPTABLES_VERSION).tar.gz
 ARPTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/arptables/arptables-v$(ARPTABLES_VERSION)
 
 define ARPTABLES_BUILD_CMDS