libelementary: depends on libethumb

Submitted by Arnout Vandecappelle on Jan. 11, 2013, 11:45 p.m.

Details

Message ID 1357947928-10549-1-git-send-email-arnout@mind.be
State Accepted
Commit 051058f52ae701928829b2304df4507892b44cfc
Headers show

Commit Message

Arnout Vandecappelle Jan. 11, 2013, 11:45 p.m.
From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>

This was exposed because I still had an old libethumb in my staging
directory so it was detected by configure, but because of the missing
dependency it was still the (incompatible) version from before the
1.7.4 bump.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/efl/libelementary/libelementary.mk |    7 +++++++
 1 file changed, 7 insertions(+)

Comments

Peter Korsgaard Jan. 12, 2013, 7:59 p.m.
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 Arnout> From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
 Arnout> This was exposed because I still had an old libethumb in my staging
 Arnout> directory so it was detected by configure, but because of the missing
 Arnout> dependency it was still the (incompatible) version from before the
 Arnout> 1.7.4 bump.

Committed, thanks.

Patch hide | download patch | download mbox

diff --git a/package/efl/libelementary/libelementary.mk b/package/efl/libelementary/libelementary.mk
index 81289ff..f63f0dc 100644
--- a/package/efl/libelementary/libelementary.mk
+++ b/package/efl/libelementary/libelementary.mk
@@ -18,4 +18,11 @@  LIBELEMENTARY_DEPENDENCIES = libeina libevas libecore libedje host-libedje \
 LIBELEMENTARY_CONF_OPT = --with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc \
 			 --with-eet-eet=$(HOST_DIR)/usr/bin/eet
 
+ifeq ($(BR2_PACKAGE_LIBETHUMB),y)
+LIBELEMENTARY_DEPENDENCIES += libethumb
+LIBELEMENTARY_CONF_OPT += --enable-ethumb
+else
+LIBELEMENTARY_CONF_OPT += --disable-ethumb
+endif
+
 $(eval $(autotools-package))