Patchwork [2/2] liblinebreak: new package

login
register
mail settings
Submitter Mikhail Boiko
Date Dec. 23, 2012, 9:39 p.m.
Message ID <CAOWBBJxG=-FBHe42_tm6RymLzgCTHy4vA6D5f25jvjJwuAYrmg@mail.gmail.com>
Download mbox | patch
Permalink /patch/207993/
State Changes Requested
Headers show

Comments

Mikhail Boiko - Dec. 23, 2012, 9:39 p.m.
---
 package/Config.in                    |    1 +
 package/liblinebreak/Config.in       |   10 ++++++++++
 package/liblinebreak/liblinebreak.mk |   14 ++++++++++++++
 3 files changed, 25 insertions(+)
 create mode 100644 package/liblinebreak/Config.in
 create mode 100644 package/liblinebreak/liblinebreak.mk

+$(eval $(autotools-package))
Yann E. MORIN - Dec. 23, 2012, 9:51 p.m.
Mikhail, All,

On Sunday 23 December 2012 Mikhail Boiko wrote:
> ---

SoB line.

[--SNIP--]
> diff --git a/package/liblinebreak/Config.in b/package/liblinebreak/Config.in
> new file mode 100644
> index 0000000..2787fe3
> --- /dev/null
> +++ b/package/liblinebreak/Config.in
> @@ -0,0 +1,10 @@
> +config BR2_PACKAGE_LIBLINEBREAK
> + bool "liblinebreak"
> + help
> +
> +  Liblinebreak is an implementation of the line breaking
> +  algorithm as described in Unicode 6.0.0 Standard. It
> +  breaks lines that contain Unicode characters. It is
> +  designed to be used in a generic text renderer.
> +
> +  http://vimgadgets.sourceforge.net/liblinebreak/

Ditto your other package: use leading TABs.

> diff --git a/package/liblinebreak/liblinebreak.mk b/package/liblinebreak/
> liblinebreak.mk
> new file mode 100644
> index 0000000..aaa6e33
> --- /dev/null
> +++ b/package/liblinebreak/liblinebreak.mk
> @@ -0,0 +1,14 @@
> +#############################################################
> +#
> +# liblinebreak
> +#
> +#############################################################
> +
> +LIBLINEBREAK_VERSION = 2.1
> +LIBLINEBREAK_SOURCE = liblinebreak-$(LIBLINEBREAK_VERSION).tar.gz

Not needed, that's the default.

> +LIBLINEBREAK_SITE =
> http://downloads.sourceforge.net/project/vimgadgets/liblinebreak/$(LIBLINEBREAK_VERSION)
> +LIBLINEBREAK_INSTALL_STAGING = YES
> +LIBLINEBREAK_CONF_OPT = --disable-docs

Ditto your other package: --disable-docs not needed.

> +LIBLINEBREAK_DEPENDENCIES = host-pkgconf
> +
> +$(eval $(autotools-package))

Regards,
Yann E. MORIN.
Peter Korsgaard - Jan. 3, 2013, 11:40 p.m.
>>>>> "Mikhail" == Mikhail Boiko <mikhailboiko85@gmail.com> writes:

 Mikhail> +++ b/package/liblinebreak/liblinebreak.mk
 Mikhail> @@ -0,0 +1,14 @@
 Mikhail> +#############################################################
 Mikhail> +#
 Mikhail> +# liblinebreak
 Mikhail> +#
 Mikhail> +#############################################################
 Mikhail> +
 Mikhail> +LIBLINEBREAK_VERSION = 2.1
 Mikhail> +LIBLINEBREAK_SOURCE = liblinebreak-$(LIBLINEBREAK_VERSION).tar.gz
 Mikhail> +LIBLINEBREAK_SITE = http://downloads.sourceforge.net/project/vimgadgets/
 Mikhail> liblinebreak/$(LIBLINEBREAK_VERSION)
 Mikhail> +LIBLINEBREAK_INSTALL_STAGING = YES
 Mikhail> +LIBLINEBREAK_CONF_OPT = --disable-docs
 Mikhail> +LIBLINEBREAK_DEPENDENCIES = host-pkgconf

Next to Yanns comments I also wonder if it doesn't need E.G. wchar
support in the toolchain.

You depend on host-pkgconf but nothing else, which seems a bit odd.
pkgconf is normally used to find other dependencies.

Care to resend with these things fixed?

Patch

diff --git a/package/Config.in b/package/Config.in
index 4d45577..6572edc 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -497,6 +497,7 @@  source "package/libevent/Config.in"
 source "package/libev/Config.in"
 source "package/libffi/Config.in"
 source "package/libfribidi/Config.in"
+source "package/liblinebreak/Config.in"
 source "package/gsl/Config.in"
 source "package/libglib2/Config.in"
 source "package/libical/Config.in"
diff --git a/package/liblinebreak/Config.in b/package/liblinebreak/Config.in
new file mode 100644
index 0000000..2787fe3
--- /dev/null
+++ b/package/liblinebreak/Config.in
@@ -0,0 +1,10 @@ 
+config BR2_PACKAGE_LIBLINEBREAK
+ bool "liblinebreak"
+ help
+
+  Liblinebreak is an implementation of the line breaking
+  algorithm as described in Unicode 6.0.0 Standard. It
+  breaks lines that contain Unicode characters. It is
+  designed to be used in a generic text renderer.
+
+  http://vimgadgets.sourceforge.net/liblinebreak/
diff --git a/package/liblinebreak/liblinebreak.mk b/package/liblinebreak/
liblinebreak.mk
new file mode 100644
index 0000000..aaa6e33
--- /dev/null
+++ b/package/liblinebreak/liblinebreak.mk
@@ -0,0 +1,14 @@ 
+#############################################################
+#
+# liblinebreak
+#
+#############################################################
+
+LIBLINEBREAK_VERSION = 2.1
+LIBLINEBREAK_SOURCE = liblinebreak-$(LIBLINEBREAK_VERSION).tar.gz
+LIBLINEBREAK_SITE =
http://downloads.sourceforge.net/project/vimgadgets/liblinebreak/$(LIBLINEBREAK_VERSION)
+LIBLINEBREAK_INSTALL_STAGING = YES
+LIBLINEBREAK_CONF_OPT = --disable-docs
+LIBLINEBREAK_DEPENDENCIES = host-pkgconf
+