Patchwork [06/33] sylpheed: fix build disabling gpgme support

login
register
mail settings
Submitter Samuel Martin
Date Nov. 22, 2012, 12:17 a.m.
Message ID <1353543503-8952-7-git-send-email-s.martin49@gmail.com>
Download mbox | patch
Permalink /patch/200900/
State Rejected
Headers show

Comments

Samuel Martin - Nov. 22, 2012, 12:17 a.m.
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
 package/sylpheed/sylpheed.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Peter Korsgaard - Nov. 23, 2012, 9:10 a.m.
>>>>> "Samuel" == Samuel Martin <s.martin49@gmail.com> writes:

 Samuel> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
 Samuel> ---
 Samuel>  package/sylpheed/sylpheed.mk | 2 +-
 Samuel>  1 file changed, 1 insertion(+), 1 deletion(-)

 Samuel> diff --git a/package/sylpheed/sylpheed.mk b/package/sylpheed/sylpheed.mk
 Samuel> index cf55c90..3ac2e1e 100644
 Samuel> --- a/package/sylpheed/sylpheed.mk
 Samuel> +++ b/package/sylpheed/sylpheed.mk
 Samuel> @@ -9,7 +9,7 @@ SYLPHEED_VERSION = $(SYLPHEED_VERSION_MAJOR).$(SYLPHEED_VERSION_MINOR)
 Samuel>  SYLPHEED_SOURCE = sylpheed-$(SYLPHEED_VERSION).tar.bz2
 Samuel>  SYLPHEED_SITE = http://sylpheed.sraoss.jp/sylpheed/v$(SYLPHEED_VERSION_MAJOR)
 
 Samuel> -SYLPHEED_CONF_OPT = --disable-gtkspell
 Samuel> +SYLPHEED_CONF_OPT = --disable-gtkspell --disable-gpgme

Why? Does it pick up libgpgme from the host?

It would be good if you could write a bit more detailed commit messages.

 
 Samuel>  SYLPHEED_DEPENDENCIES = host-pkgconf libgtk2
 
 Samuel> -- 
 Samuel> 1.8.0

 Samuel> _______________________________________________
 Samuel> buildroot mailing list
 Samuel> buildroot@busybox.net
 Samuel> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard - May 6, 2013, 8:01 a.m.
>>>>> "Peter" == Peter Korsgaard <jacmet@uclibc.org> writes:

 Samuel> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
 Samuel> ---
 Samuel> package/sylpheed/sylpheed.mk | 2 +-
 Samuel> 1 file changed, 1 insertion(+), 1 deletion(-)

 Samuel> diff --git a/package/sylpheed/sylpheed.mk b/package/sylpheed/sylpheed.mk
 Samuel> index cf55c90..3ac2e1e 100644
 Samuel> --- a/package/sylpheed/sylpheed.mk
 Samuel> +++ b/package/sylpheed/sylpheed.mk
 Samuel> @@ -9,7 +9,7 @@ SYLPHEED_VERSION = $(SYLPHEED_VERSION_MAJOR).$(SYLPHEED_VERSION_MINOR)
 Samuel> SYLPHEED_SOURCE = sylpheed-$(SYLPHEED_VERSION).tar.bz2
 Samuel> SYLPHEED_SITE = http://sylpheed.sraoss.jp/sylpheed/v$(SYLPHEED_VERSION_MAJOR)
 
 Samuel> -SYLPHEED_CONF_OPT = --disable-gtkspell
 Samuel> +SYLPHEED_CONF_OPT = --disable-gtkspell --disable-gpgme

 Peter> Why? Does it pick up libgpgme from the host?

 Peter> It would be good if you could write a bit more detailed commit
 Peter> messages.

Samuel, I don't think you ever replied to this. Can the patch be dropped
or is it still needed?
Samuel Martin - May 6, 2013, 10:02 a.m.
Hi Peter, all,

2013/5/6 Peter Korsgaard <jacmet@sunsite.dk>:
>>>>>> "Peter" == Peter Korsgaard <jacmet@uclibc.org> writes:
>
>  Samuel> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
[...]>  Samuel> -SYLPHEED_CONF_OPT = --disable-gtkspell
>  Samuel> +SYLPHEED_CONF_OPT = --disable-gtkspell --disable-gpgme
>
>  Peter> Why? Does it pick up libgpgme from the host?
iirc, it does, but i'm not sure.

>
>  Peter> It would be good if you could write a bit more detailed commit
>  Peter> messages.
>
> Samuel, I don't think you ever replied to this. Can the patch be dropped
> or is it still needed?
Right. You can drop it for now.

If i trigger the problem again, I'll resend it.
Also, iirc, someone posted some patch about libgpgme, but i haven't
tried it yet.

Regards,

Patch

diff --git a/package/sylpheed/sylpheed.mk b/package/sylpheed/sylpheed.mk
index cf55c90..3ac2e1e 100644
--- a/package/sylpheed/sylpheed.mk
+++ b/package/sylpheed/sylpheed.mk
@@ -9,7 +9,7 @@  SYLPHEED_VERSION = $(SYLPHEED_VERSION_MAJOR).$(SYLPHEED_VERSION_MINOR)
 SYLPHEED_SOURCE = sylpheed-$(SYLPHEED_VERSION).tar.bz2
 SYLPHEED_SITE = http://sylpheed.sraoss.jp/sylpheed/v$(SYLPHEED_VERSION_MAJOR)
 
-SYLPHEED_CONF_OPT = --disable-gtkspell
+SYLPHEED_CONF_OPT = --disable-gtkspell --disable-gpgme
 
 SYLPHEED_DEPENDENCIES = host-pkgconf libgtk2