Patchwork boost: bump to version 1.52.0

login
register
mail settings
Submitter Victor Hiairrassary
Date Nov. 6, 2012, 5:53 p.m.
Message ID <1352224420-14184-1-git-send-email-victor.hiairrassary.ml@gmail.com>
Download mbox | patch
Permalink /patch/197508/
State Superseded
Headers show

Comments

Victor Hiairrassary - Nov. 6, 2012, 5:53 p.m.
From: mecanix <victor.hiairrassary.ml@gmail.com>

---
 package/boost/Config.in | 4 ++++
 package/boost/boost.mk  | 4 ++--
 2 files changed, 6 insertions(+), 2 deletions(-)
Victor Hiairrassary - Nov. 7, 2012, 10:41 a.m.
Hi,

This is the first time I send a patch to an open source project! The next patch bump boost version to 1.52.0.

For that, I needed to add dependance on BR2_LARGEFILE and exclude the new context lib.

Thanks for buildroot! :)


Le 6 nov. 2012 à 18:53, Victor Hiairrassary <victor.hiairrassary.ml@gmail.com> a écrit :

> From: mecanix <victor.hiairrassary.ml@gmail.com>
> 
> ---
> package/boost/Config.in | 4 ++++
> package/boost/boost.mk  | 4 ++--
> 2 files changed, 6 insertions(+), 2 deletions(-)
> 
> diff --git a/package/boost/Config.in b/package/boost/Config.in
> index 8798367..58e62a0 100644
> --- a/package/boost/Config.in
> +++ b/package/boost/Config.in
> @@ -1,9 +1,13 @@
> comment "boost requires a toolchain with C++ support enabled"
>    depends on !BR2_INSTALL_LIBSTDCPP
> 
> +comment "boost requires a toolchain with large file support enabled"
> +    depends on !BR2_LARGEFILE
> +
> config BR2_PACKAGE_BOOST
>    bool "boost"
>    depends on BR2_INSTALL_LIBSTDCPP
> +    depends on BR2_LARGEFILE
>    select BR2_PACKAGE_BZIP2
>    select BR2_PACKAGE_ZLIB
>    help
> diff --git a/package/boost/boost.mk b/package/boost/boost.mk
> index 64856bc..005c7ca 100644
> --- a/package/boost/boost.mk
> +++ b/package/boost/boost.mk
> @@ -4,7 +4,7 @@
> #
> #############################################################
> 
> -BOOST_VERSION = 1.49.0
> +BOOST_VERSION = 1.52.0
> BOOST_FILE_VERSION = $(subst .,_,$(BOOST_VERSION))
> BOOST_SOURCE = boost_$(BOOST_FILE_VERSION).tar.bz2
> BOOST_SITE = http://downloads.sourceforge.net/project/boost/boost/$(BOOST_VERSION)
> @@ -15,7 +15,7 @@ TARGET_CC_VERSION = $(shell $(TARGET_CC) -dumpversion)
> BOOST_DEPENDENCIES = bzip2 zlib
> 
> BOOST_FLAGS =
> -BOOST_WITHOUT_FLAGS = python
> +BOOST_WITHOUT_FLAGS = python context
> 
> BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
> BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)
> -- 
> 1.8.0
>
Arnout Vandecappelle - Dec. 11, 2012, 11:49 p.m.
On 06/11/12 18:53, Victor Hiairrassary wrote:
> From: mecanix<victor.hiairrassary.ml@gmail.com>

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
  (x86_64 Sourcery toolchain)

  It also fixes a build failure for me.

  Add a Signed-off-by line for yourself.  This is a short way for you to
assert that you are entitled to contribute the patch under buildroot's
GPL license.  See  http://elinux.org/Developer_Certificate_Of_Origin
for more details.


  Regards,
  Arnout
Peter Korsgaard - Dec. 12, 2012, 5:58 a.m.
>>>>> "Arnout" == Arnout Vandecappelle <arnout@mind.be> writes:

 Arnout> On 06/11/12 18:53, Victor Hiairrassary wrote:
 >> From: mecanix<victor.hiairrassary.ml@gmail.com>

 Arnout> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
 Arnout> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
 Arnout>  (x86_64 Sourcery toolchain)

 Arnout>  It also fixes a build failure for me.

 Arnout>  Add a Signed-off-by line for yourself.  This is a short way for you to
 Arnout> assert that you are entitled to contribute the patch under buildroot's
 Arnout> GPL license.  See  http://elinux.org/Developer_Certificate_Of_Origin
 Arnout> for more details.

Yes, please resend with your Signed-off-by: and I'll commit - Thanks.

Patch

diff --git a/package/boost/Config.in b/package/boost/Config.in
index 8798367..58e62a0 100644
--- a/package/boost/Config.in
+++ b/package/boost/Config.in
@@ -1,9 +1,13 @@ 
 comment "boost requires a toolchain with C++ support enabled"
 	depends on !BR2_INSTALL_LIBSTDCPP
 
+comment "boost requires a toolchain with large file support enabled"
+	depends on !BR2_LARGEFILE
+
 config BR2_PACKAGE_BOOST
 	bool "boost"
 	depends on BR2_INSTALL_LIBSTDCPP
+	depends on BR2_LARGEFILE
 	select BR2_PACKAGE_BZIP2
 	select BR2_PACKAGE_ZLIB
 	help
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 64856bc..005c7ca 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -4,7 +4,7 @@ 
 #
 #############################################################
 
-BOOST_VERSION = 1.49.0
+BOOST_VERSION = 1.52.0
 BOOST_FILE_VERSION = $(subst .,_,$(BOOST_VERSION))
 BOOST_SOURCE = boost_$(BOOST_FILE_VERSION).tar.bz2
 BOOST_SITE = http://downloads.sourceforge.net/project/boost/boost/$(BOOST_VERSION)
@@ -15,7 +15,7 @@  TARGET_CC_VERSION = $(shell $(TARGET_CC) -dumpversion)
 BOOST_DEPENDENCIES = bzip2 zlib
 
 BOOST_FLAGS =
-BOOST_WITHOUT_FLAGS = python
+BOOST_WITHOUT_FLAGS = python context
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)