Patchwork libseccomp: require version 1.0.0

login
register
mail settings
Submitter Blue Swirl
Date Nov. 3, 2012, 3:44 p.m.
Message ID <ca6867dfc9e12d5bbd88a18e2402c63714fe5c01.1351957436.git.blauwirbel@gmail.com>
Download mbox | patch
Permalink /patch/196850/
State New
Headers show

Comments

Blue Swirl - Nov. 3, 2012, 3:44 p.m.
Debian Wheezy has version 0.1.0 which is not compatible, avoid it.

Signed-off-by: Blue Swirl <blauwirbel@gmail.com>
---
 configure |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)
Doug Goldstein - Nov. 3, 2012, 5:48 p.m.
On Sat, Nov 3, 2012 at 10:44 AM, Blue Swirl <blauwirbel@gmail.com> wrote:
> Debian Wheezy has version 0.1.0 which is not compatible, avoid it.
>
> Signed-off-by: Blue Swirl <blauwirbel@gmail.com>
> ---
>  configure |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/configure b/configure
> index 8e70cbb..b6948f7 100755
> --- a/configure
> +++ b/configure
> @@ -1383,7 +1383,7 @@ fi
>  # libseccomp check
>
>  if test "$seccomp" != "no" ; then
> -    if $pkg_config libseccomp --modversion >/dev/null 2>&1; then
> +    if $pkg_config --atleast-version=1.0.0 libseccomp --modversion >/dev/null 2>&1; then
>          LIBS=`$pkg_config --libs libseccomp`
>         seccomp="yes"
>      else
> --
> 1.7.2.5
>
>

I can confirm this will fix the compile issue when you've got
libseccomp 0.1.0, so ACK from a non-maintainer.

Patch

diff --git a/configure b/configure
index 8e70cbb..b6948f7 100755
--- a/configure
+++ b/configure
@@ -1383,7 +1383,7 @@  fi
 # libseccomp check
 
 if test "$seccomp" != "no" ; then
-    if $pkg_config libseccomp --modversion >/dev/null 2>&1; then
+    if $pkg_config --atleast-version=1.0.0 libseccomp --modversion >/dev/null 2>&1; then
         LIBS=`$pkg_config --libs libseccomp`
 	seccomp="yes"
     else