Patchwork [3,9/9] libsoup: Remove redundant dependency on gettext

login
register
mail settings
Submitter Arnout Vandecappelle
Date Nov. 1, 2012, 2:36 p.m.
Message ID <20121101143621.8550.4383.stgit@localhost>
Download mbox | patch
Permalink /patch/196239/
State Accepted
Headers show

Comments

Arnout Vandecappelle - Nov. 1, 2012, 2:36 p.m.
From: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

libsoup doesn't use intl stuff directly, but uses gi18n.  libglib2
already has all required dependencies on gettext.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/libsoup/Config.in  |    1 -
 package/libsoup/libsoup.mk |    2 +-
 2 files changed, 1 insertion(+), 2 deletions(-)

Patch

diff --git a/package/libsoup/Config.in b/package/libsoup/Config.in
index 57b425f..b79108e 100644
--- a/package/libsoup/Config.in
+++ b/package/libsoup/Config.in
@@ -3,7 +3,6 @@  config BR2_PACKAGE_LIBSOUP
 	depends on BR2_USE_WCHAR # glib2 and gnutls
 	select BR2_PACKAGE_LIBXML2
 	select BR2_PACKAGE_LIBGLIB2
-	select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
 	help
 	  libsoup is an HTTP client/server library. It uses GObject
 	  and the GLib main loop, to integrate well with GNOME
diff --git a/package/libsoup/libsoup.mk b/package/libsoup/libsoup.mk
index 2f173df..2a2d8bf 100644
--- a/package/libsoup/libsoup.mk
+++ b/package/libsoup/libsoup.mk
@@ -19,7 +19,7 @@  endif
 
 LIBSOUP_CONF_OPT = --disable-glibtest --without-gnome
 
-LIBSOUP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-pkgconf host-libglib2 libglib2 libxml2
+LIBSOUP_DEPENDENCIES = host-pkgconf host-libglib2 libglib2 libxml2
 
 ifeq ($(BR2_PACKAGE_LIBSOUP_SSL),y)
 LIBSOUP_DEPENDENCIES += glib-networking