From patchwork Thu Oct 25 12:51:33 2012 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Gerd Hoffmann X-Patchwork-Id: 194133 Return-Path: X-Original-To: incoming@patchwork.ozlabs.org Delivered-To: patchwork-incoming@bilbo.ozlabs.org Received: from lists.gnu.org (lists.gnu.org [208.118.235.17]) (using TLSv1 with cipher AES256-SHA (256/256 bits)) (Client did not present a certificate) by ozlabs.org (Postfix) with ESMTPS id BE3872C0091 for ; Thu, 25 Oct 2012 23:52:46 +1100 (EST) Received: from localhost ([::1]:52915 helo=lists.gnu.org) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1TRMvU-00072r-TV for incoming@patchwork.ozlabs.org; Thu, 25 Oct 2012 08:52:44 -0400 Received: from eggs.gnu.org ([208.118.235.92]:59781) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1TRMv2-0006ok-8z for qemu-devel@nongnu.org; Thu, 25 Oct 2012 08:52:26 -0400 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1TRMuz-000399-3v for qemu-devel@nongnu.org; Thu, 25 Oct 2012 08:52:16 -0400 Received: from mx1.redhat.com ([209.132.183.28]:39296) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1TRMuy-00038n-RL for qemu-devel@nongnu.org; Thu, 25 Oct 2012 08:52:13 -0400 Received: from int-mx10.intmail.prod.int.phx2.redhat.com (int-mx10.intmail.prod.int.phx2.redhat.com [10.5.11.23]) by mx1.redhat.com (8.14.4/8.14.4) with ESMTP id q9PCqBWI032145 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=OK) for ; Thu, 25 Oct 2012 08:52:11 -0400 Received: from rincewind.home.kraxel.org (ovpn-116-20.ams2.redhat.com [10.36.116.20]) by int-mx10.intmail.prod.int.phx2.redhat.com (8.14.4/8.14.4) with ESMTP id q9PCqApc023627; Thu, 25 Oct 2012 08:52:11 -0400 Received: by rincewind.home.kraxel.org (Postfix, from userid 500) id B30B34128E; Thu, 25 Oct 2012 14:52:09 +0200 (CEST) From: Gerd Hoffmann To: qemu-devel@nongnu.org Date: Thu, 25 Oct 2012 14:51:33 +0200 Message-Id: <1351169529-10799-1-git-send-email-kraxel@redhat.com> X-Scanned-By: MIMEDefang 2.68 on 10.5.11.23 X-detected-operating-system: by eggs.gnu.org: Genre and OS details not recognized. X-Received-From: 209.132.183.28 Cc: Gerd Hoffmann Subject: [Qemu-devel] [PULL 00/36] usb patch queue X-BeenThere: qemu-devel@nongnu.org X-Mailman-Version: 2.1.14 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: qemu-devel-bounces+incoming=patchwork.ozlabs.org@nongnu.org Sender: qemu-devel-bounces+incoming=patchwork.ozlabs.org@nongnu.org Hi, Here comes the usb patch queue. Nothing big standing out. Tons of cleanups and small bug fixes. Some performance improvements too. Some patches preparing the usb core for the upcoming input pipelining bits. please pull, Gerd The following changes since commit a8170e5e97ad17ca169c64ba87ae2f53850dab4c: Rename target_phys_addr_t to hwaddr (2012-10-23 08:58:25 -0500) are available in the git repository at: git://git.kraxel.org/qemu usb.68 Gerd Hoffmann (5): xhci: fix function name in error message xhci: flush endpoint context unconditinally xhci: allow disabling interrupters xhci: make number of interrupters and slots configurable xhci: fix usb name in caps Hans de Goede (31): uhci: Properly unmap packets on cancel / invalid pid uhci: Move checks to continue queuing to uhci_fill_queue() ehci: Get rid of packet tbytes field ehci: Set int flag on a short input packet ehci: Improve latency of interrupt delivery and async schedule scanning ehci: Speed up the timer of raising int from the async schedule ehci: Detect going in circles when filling the queue ehci: Retry to fill the queue while waiting for td completion xhci: Add a xhci_ep_nuke_one_xfer helper function usb: Rename __usb_packet_complete to usb_packet_complete_one usb: Add USB_RET_ADD_TO_QUEUE packet result code usb: Move clearing of queue on halt to the core usb: Move short-not-ok handling to the core usb: Add an int_req flag to USBPacket usb: Enforce iso endpoints never returing USB_RET_ASYNC uhci: No need to handle async completion of isoc packets uhci: cleanup: Add an unlink call to uhci_async_cancel() uhci: Don't retry on error uhci: Drop unnecessary forward declaration of some static functions uhci: Move emptying of the queue's asyncs' queue to uhci_queue_free uhci: Rename UHCIAsync->td to UHCIAsync->td_addr uhci: Add uhci_read_td() helper function uhci: Make uhci_fill_queue() actually operate on an UHCIQueue uhci: Store ep in UHCIQueue uhci: Immediately free queues on device disconnect uhci: Verify queue has not been changed by guest uhci: Detect guest td re-use uhci: When the guest marks a pending td non-active, cancel the queue uhci: Always mark a queue valid when we encounter it uhci: Retry to fill the queue while waiting for td completion uhci: Use only one queue for ctrl endpoints hw/usb.h | 28 +++- hw/usb/bus.c | 8 + hw/usb/core.c | 28 +++- hw/usb/hcd-ehci.c | 105 ++++++++------ hw/usb/hcd-musb.c | 3 +- hw/usb/hcd-ohci.c | 9 +- hw/usb/hcd-uhci.c | 380 +++++++++++++++++++++++++-------------------------- hw/usb/hcd-xhci.c | 169 +++++++++++++++-------- hw/usb/host-linux.c | 3 +- hw/usb/redirect.c | 18 ++- trace-events | 2 +- 11 files changed, 425 insertions(+), 328 deletions(-)